package/strace: don't remove strace-graph unconditionally
authorBaruch Siach <baruch@tkos.co.il>
Tue, 27 Nov 2018 10:16:56 +0000 (12:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 28 Nov 2018 20:53:22 +0000 (21:53 +0100)
strace-graph is a perl script. This script is removed unconditionally
since commit 720c0ca5ba7 ("strace: convert to makefile.autotools.in
format") from 2008. Since then Buildroot added support for perl on
target. Don't remove strace-graph when perl is built for target.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
[Thomas: move the hook definition inside the condition.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/strace/strace.mk

index 471dbc2e1dd3dead18fa675c6b527923d6712eac..6efe9c517444609241a2805cb8f5a904940f6147 100644 (file)
@@ -34,10 +34,12 @@ else
 STRACE_CONF_OPTS += --without-libiberty
 endif
 
+ifeq ($(BR2_PACKAGE_PERL),)
 define STRACE_REMOVE_STRACE_GRAPH
        rm -f $(TARGET_DIR)/usr/bin/strace-graph
 endef
 
 STRACE_POST_INSTALL_TARGET_HOOKS += STRACE_REMOVE_STRACE_GRAPH
+endif
 
 $(eval $(autotools-package))