lunit: new package
authorFrancois Perrad <fperrad@gmail.com>
Mon, 24 Feb 2014 07:34:58 +0000 (08:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Mar 2014 15:52:54 +0000 (16:52 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/lunit/Config.in [new file with mode: 0644]
package/lunit/lunit.mk [new file with mode: 0644]

index bfc6f58f5b12f1cf4d4681153ad088ccb7e52cba..410971dfe6afb5b95753ce853bb67dcd04525133 100644 (file)
@@ -396,6 +396,7 @@ source "package/lualogging/Config.in"
 source "package/luaposix/Config.in"
 source "package/luasec/Config.in"
 source "package/luasocket/Config.in"
+source "package/lunit/Config.in"
 source "package/lzlib/Config.in"
 source "package/orbit/Config.in"
 source "package/rings/Config.in"
diff --git a/package/lunit/Config.in b/package/lunit/Config.in
new file mode 100644 (file)
index 0000000..b3620ef
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_LUNIT
+       bool "lunit"
+       depends on !BR2_PACKAGE_LUA_5_2
+       help
+         A unit testing framework for Lua.
+
+         http://www.mroth.net/lunit/
+
+comment "lunit needs a Lua 5.1 interpreter"
+       depends on BR2_PACKAGE_LUA_5_2
diff --git a/package/lunit/lunit.mk b/package/lunit/lunit.mk
new file mode 100644 (file)
index 0000000..1b5f43c
--- /dev/null
@@ -0,0 +1,13 @@
+#############################################################
+#
+# lunit
+#
+#############################################################
+
+LUNIT_VERSION_UPSTREAM = 0.5
+LUNIT_VERSION = $(LUNIT_VERSION_UPSTREAM)-2
+LUNIT_SUBDIR  = lunit-$(LUNIT_VERSION_UPSTREAM)
+LUNIT_LICENSE = MIT
+LUNIT_LICENSE_FILES = $(LUNIT_SUBDIR)/LICENSE
+
+$(eval $(luarocks-package))