dos2unix: fix static build
authorBaruch Siach <baruch@tkos.co.il>
Sun, 24 Jun 2018 18:15:00 +0000 (21:15 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 24 Jun 2018 19:10:52 +0000 (21:10 +0200)
Pass the -static flag to the final link command. Otherwise, the
generated executables are not static when the external toolchain
provides both shared and static libraries.

Should also fix:
http://autobuild.buildroot.net/results/a5a/a5a64bc3ff5a91a8680ac52f3505362491923b26/
http://autobuild.buildroot.net/results/ebf/ebfe81e65751d7a5ca3aa4e20cc708a24ba65204/

Cc: David Bachelart <david.bachelart@bbright.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dos2unix/dos2unix.mk

index 9b823405902ebc53bbecb99754347a7c2deda2c0..5001397f05715f08d06071ac0ffff2ab344f930e 100644 (file)
@@ -24,6 +24,10 @@ ifeq ($(BR2_USE_WCHAR),)
 DOS2UNIX_MAKE_OPTS += UCS=
 endif
 
+ifeq ($(BR2_STATIC_LIBS),y)
+DOS2UNIX_MAKE_OPTS += LDFLAGS_USER=-static
+endif
+
 define DOS2UNIX_BUILD_CMDS
        $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) $(DOS2UNIX_MAKE_OPTS)
 endef