flex: needs M4 at runtime
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 May 2013 12:08:17 +0000 (12:08 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 27 May 2013 21:51:38 +0000 (23:51 +0200)
For proper runtime execution, flex requires m4 to be
installed. Passing a M4 variable at configure time is needed,
otherwise flex on the target will try to use a 'm4' binary with a
build machine path.

Fixes bug #4988.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/flex/Config.in
package/flex/flex.mk

index f74a0f0e8b041f4eb6a040300368224e4d8cc684..1ecd0c3572fd619812622528d36c6ec3b40b218e 100644 (file)
@@ -12,5 +12,7 @@ config BR2_PACKAGE_FLEX_BINARY
        # needs fork()
        depends on BR2_USE_MMU
        depends on BR2_PACKAGE_FLEX
+       # runtime dependency
+       select BR2_PACKAGE_M4
        help
          Install the flex binary tool in the target filesystem.
index f7e319f1c428e50287507d87fb4bb612d0bd37bd..748365b020cb8dd2bffb19632e9571ed5d3d5a55 100644 (file)
@@ -11,6 +11,7 @@ FLEX_LICENSE = FLEX
 FLEX_LICENSE_FILES = COPYING
 FLEX_DEPENDENCIES = \
        $(if $(BR2_PACKAGE_GETTEXT_IF_LOCALE),gettext) host-m4
+FLEX_CONF_ENV = M4=/usr/bin/m4
 # we don't have a host-gettext/libintl
 HOST_FLEX_DEPENDENCIES = host-m4