gnuplot: fix m68k uclinux compile
authorWaldemar Brodkorb <wbx@openadk.org>
Mon, 8 Aug 2016 04:47:04 +0000 (06:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 8 Aug 2016 21:47:12 +0000 (23:47 +0200)
The GCC manual suggest when getting:
relocation truncated to fit: R_68K_GOT16O foobar
to use -mxgot.

Fixes:
  http://autobuild.buildroot.net/results/d1e030c42f43f49575f36ecc82e9dd9018ca4f73/

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gnuplot/gnuplot.mk

index 4408ece5be36aa32a1b00907f4c76b163b55405d..a9e12045ec78e9daccf37e11a4c9a9da19e1e7ba 100644 (file)
@@ -25,6 +25,11 @@ GNUPLOT_CONF_OPTS = \
        --without-latex \
        --without-cairo
 
+# relocation truncated to fit: R_68K_GOT16O
+ifeq ($(BR2_m68k_cf),y)
+GNUPLOT_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -mxgot"
+endif
+
 ifeq ($(BR2_PACKAGE_GD)$(BR2_PACKAGE_LIBPNG),yy)
 GNUPLOT_CONF_OPTS += --with-gd
 GNUPLOT_DEPENDENCIES += gd