package/pkg-generic.mk: drop useless $(1) argument in step_pkg_size_{before, after}
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 30 Apr 2020 09:52:39 +0000 (11:52 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 23 Jul 2020 20:31:21 +0000 (22:31 +0200)
The $(1) argument passed to step_pkg_size_{before,after}, which
contains the package name, is no longer used. We simply use $(PKG) to
get the upper-case version of the package name.

So, let's drop this first argument that isn't needed.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/pkg-generic.mk

index 4ea1084f91ad918a2b5324579a4e159388f918cb..bcf5d9815c29c4055d2b46162310958897060883 100644 (file)
@@ -57,45 +57,43 @@ GLOBAL_INSTRUMENTATION_HOOKS += step_time
 
 # Hooks to collect statistics about installed files
 
-# $(1): package name
-# $(2): base directory to search in
-# $(3): suffix of file (optional)
+# $(1): base directory to search in
+# $(2): suffix of file (optional)
 define step_pkg_size_before
-       cd $(2); \
+       cd $(1); \
        LC_ALL=C find . \( -type f -o -type l \) -printf '%T@:%i:%#m:%y:%s,%p\n' \
-               | LC_ALL=C sort > $($(PKG)_DIR)/.files-list$(3).before
+               | LC_ALL=C sort > $($(PKG)_DIR)/.files-list$(2).before
 endef
 
-# $(1): package name
-# $(2): base directory to search in
-# $(3): suffix of file (optional)
+# $(1): base directory to search in
+# $(2): suffix of file (optional)
 define step_pkg_size_after
-       cd $(2); \
+       cd $(1); \
        LC_ALL=C find . \( -type f -o -type l \) -printf '%T@:%i:%#m:%y:%s,%p\n' \
-               | LC_ALL=C sort > $($(PKG)_DIR)/.files-list$(3).after
+               | LC_ALL=C sort > $($(PKG)_DIR)/.files-list$(2).after
        LC_ALL=C comm -13 \
-               $($(PKG)_DIR)/.files-list$(3).before \
-               $($(PKG)_DIR)/.files-list$(3).after \
+               $($(PKG)_DIR)/.files-list$(2).before \
+               $($(PKG)_DIR)/.files-list$(2).after \
                | sed -r -e 's/^[^,]+/$($(PKG)_NAME)/' \
-               > $($(PKG)_DIR)/.files-list$(3).txt
-       rm -f $($(PKG)_DIR)/.files-list$(3).before
-       rm -f $($(PKG)_DIR)/.files-list$(3).after
+               > $($(PKG)_DIR)/.files-list$(2).txt
+       rm -f $($(PKG)_DIR)/.files-list$(2).before
+       rm -f $($(PKG)_DIR)/.files-list$(2).after
 endef
 
 define step_pkg_size
        $(if $(filter start-install-target,$(1)-$(2)),\
-               $(call step_pkg_size_before,$(3),$(TARGET_DIR)))
+               $(call step_pkg_size_before,$(TARGET_DIR)))
        $(if $(filter start-install-staging,$(1)-$(2)),\
-               $(call step_pkg_size_before,$(3),$(STAGING_DIR),-staging))
+               $(call step_pkg_size_before,$(STAGING_DIR),-staging))
        $(if $(filter start-install-host,$(1)-$(2)),\
-               $(call step_pkg_size_before,$(3),$(HOST_DIR),-host))
+               $(call step_pkg_size_before,$(HOST_DIR),-host))
 
        $(if $(filter end-install-target,$(1)-$(2)),\
-               $(call step_pkg_size_after,$(3),$(TARGET_DIR)))
+               $(call step_pkg_size_after,$(TARGET_DIR)))
        $(if $(filter end-install-staging,$(1)-$(2)),\
-               $(call step_pkg_size_after,$(3),$(STAGING_DIR),-staging))
+               $(call step_pkg_size_after,$(STAGING_DIR),-staging))
        $(if $(filter end-install-host,$(1)-$(2)),\
-               $(call step_pkg_size_after,$(3),$(HOST_DIR),-host))
+               $(call step_pkg_size_after,$(HOST_DIR),-host))
 endef
 GLOBAL_INSTRUMENTATION_HOOKS += step_pkg_size