qt: fix build with opengl es
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 29 Nov 2013 10:25:25 +0000 (11:25 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 29 Nov 2013 10:25:25 +0000 (11:25 +0100)
Fixes http://autobuild.buildroot.net/results/efe/efe26c54361094fb1e201da6915900cd9b24d596/

qt doesn't use pkg-config to figure out the needed compiler/linker flags
for egl, so pass them explicitly instead.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qt/qt.mk

index 82ce51dbd045c61abfeb53793f5a0013c27325d8..7f799fdb99a68740dca0b1ff8bc509e0af49506f 100644 (file)
@@ -35,6 +35,7 @@ endif
 
 QT_CFLAGS = $(TARGET_CFLAGS)
 QT_CXXFLAGS = $(TARGET_CXXFLAGS)
+QT_LDFLAGS = $(TARGET_LDFLAGS)
 
 ifeq ($(BR2_LARGEFILE),y)
 QT_CONFIGURE_OPTS += -largefile
@@ -320,6 +321,9 @@ endif
 ifeq ($(BR2_PACKAGE_QT_OPENGL_ES),y)
 QT_CONFIGURE_OPTS += -opengl es2 -egl
 QT_DEPENDENCIES   += libgles libegl
+QT_CFLAGS   += $(shell $(PKG_CONFIG_HOST_BINARY) --cflags egl)
+QT_CXXFLAGS += $(shell $(PKG_CONFIG_HOST_BINARY) --cflags egl)
+QT_LDFLAGS  += $(shell $(PKG_CONFIG_HOST_BINARY) --libs egl)
 else
 QT_CONFIGURE_OPTS += -no-opengl
 endif
@@ -490,7 +494,7 @@ define QT_CONFIGURE_CMDS
        $(call QT_QMAKE_SET,QMAKE_STRIP,$(TARGET_STRIP),$(@D))
        $(call QT_QMAKE_SET,QMAKE_CFLAGS,$(QT_CFLAGS),$(@D))
        $(call QT_QMAKE_SET,QMAKE_CXXFLAGS,$(QT_CXXFLAGS),$(@D))
-       $(call QT_QMAKE_SET,QMAKE_LFLAGS,$(TARGET_LDFLAGS),$(@D))
+       $(call QT_QMAKE_SET,QMAKE_LFLAGS,$(QT_LDFLAGS),$(@D))
        $(call QT_QMAKE_SET,PKG_CONFIG,$(HOST_DIR)/usr/bin/pkg-config,$(@D))
 # Don't use TARGET_CONFIGURE_OPTS here, qmake would be compiled for the target
 # instead of the host then. So set PKG_CONFIG* manually.