package: set PKG_CONFIG_SYSROOT_DIR in HOST_MAKE_ENV
authorSven Neumann <s.neumann@raumfeld.com>
Wed, 4 Apr 2012 12:50:19 +0000 (14:50 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 15 Apr 2012 21:08:48 +0000 (23:08 +0200)
A host package that uses AUTORECONF (such as host-libglib2)
may end up running './config.status --recheck'. This will
call the configure script with the environment variables
set in HOST_MAKE_ENV. If PKG_CONFIG_SYSROOT_DIR is missing
this will cause the hardcoded sysroot dir take effect leading
to wrong paths.

See commit 22acade2ec311 which works around this problem by
fiddling with the generated .pc file. This commit becomes
obsolete with this fix.

Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Cc: Daniel Mack <zonque@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.in

index dc8d0383c1cedb5550d0dd1555cec0196152ca5a..c344c6b3f250fa526161b0b58b23ac869203956c 100644 (file)
@@ -222,6 +222,7 @@ HOST_CONFIGURE_OPTS=PATH=$(HOST_PATH) \
 HOST_MAKE_ENV=PATH=$(HOST_PATH) \
                LD_LIBRARY_PATH="$(HOST_DIR)/usr/lib:$(LD_LIBRARY_PATH)" \
                PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)" \
+               PKG_CONFIG_SYSROOT_DIR="/" \
                PKG_CONFIG_LIBDIR="$(HOST_DIR)/usr/lib/pkgconfig" \
                PERLLIB="$(HOST_DIR)/usr/lib/perl"