iucode-tool: install init script unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:43 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:20:06 +0000 (00:20 +0100)
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/iucode-tool/iucode-tool.mk

index 3124c73c340f5914e4d2290b1ac1c789638cc514..081b086bddc198ed0b90122a4d54c35d0feb3d69 100644 (file)
@@ -15,9 +15,8 @@ IUCODE_TOOL_LICENSE = GPLv2+
 IUCODE_TOOL_LICENSE_FILES = COPYING
 
 define IUCODE_TOOL_INSTALL_INIT_SYSV
-       [ -f $(TARGET_DIR)/etc/init.d/S00iucode-tool ] || \
-               $(INSTALL) -D -m 0755 package/iucode-tool/S00iucode-tool \
-                       $(TARGET_DIR)/etc/init.d/S00iucode-tool
+       $(INSTALL) -D -m 0755 package/iucode-tool/S00iucode-tool \
+               $(TARGET_DIR)/etc/init.d/S00iucode-tool
 endef
 
 $(eval $(autotools-package))