xdotool: new package
authorErico Nunes <nunes.erico@gmail.com>
Tue, 29 Dec 2015 01:59:27 +0000 (23:59 -0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 29 Dec 2015 15:00:45 +0000 (16:00 +0100)
xdotool is a command-line X11 automation tool.

http://www.semicomplete.com/projects/xdotool

[Thomas:
 - fix <pkg>_LICENSE, as noticed by Baruch
 - use $(TARGET_MAKE_ENV).]

Signed-off-by: Erico Nunes <nunes.erico@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/xdotool/Config.in [new file with mode: 0644]
package/xdotool/xdotool.hash [new file with mode: 0644]
package/xdotool/xdotool.mk [new file with mode: 0644]

index a024d3d17c767f8e8889ef5d6b4a64b2b997c63e..973fae1743ab06240d4d63499a248ad01ae0b565 100644 (file)
@@ -304,6 +304,7 @@ comment "X applications"
        source "package/torsmo/Config.in"
        source "package/wmctrl/Config.in"
        source "package/x11vnc/Config.in"
+       source "package/xdotool/Config.in"
        source "package/xscreensaver/Config.in"
        source "package/xterm/Config.in"
        source "package/xvkbd/Config.in"
diff --git a/package/xdotool/Config.in b/package/xdotool/Config.in
new file mode 100644 (file)
index 0000000..4d5f590
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_XDOTOOL
+       bool "xdotool"
+       depends on BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_XLIB_LIBXTST
+       select BR2_PACKAGE_XLIB_LIBXINERAMA
+       select BR2_PACKAGE_LIBXKBCOMMON
+       select BR2_PACKAGE_XLIB_LIBX11
+       help
+         Command-line X11 automation tool
+
+         http://www.semicomplete.com/projects/xdotool
diff --git a/package/xdotool/xdotool.hash b/package/xdotool/xdotool.hash
new file mode 100644 (file)
index 0000000..f8adcd5
--- /dev/null
@@ -0,0 +1,2 @@
+# locally computed hash
+sha256 b097ef0e3897d1a24e3f45f0faed58329742d3d9434b9b46eb97eb1040f999bf  xdotool-v3.20150503.1.tar.gz
diff --git a/package/xdotool/xdotool.mk b/package/xdotool/xdotool.mk
new file mode 100644 (file)
index 0000000..a799ea4
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# xdotool
+#
+################################################################################
+
+XDOTOOL_VERSION = v3.20150503.1
+XDOTOOL_SITE = $(call github,jordansissel,xdotool,$(XDOTOOL_VERSION))
+XDOTOOL_LICENSE = BSD-3c
+XDOTOOL_LICENSE_FILES = COPYRIGHT
+XDOTOOL_DEPENDENCIES = xlib_libXtst xlib_libXinerama libxkbcommon xlib_libX11
+
+define XDOTOOL_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+endef
+
+# Avoid 'install' target to skip 'post-install' which runs ldconfig on host
+define XDOTOOL_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+               pre-install installlib installprog installheader \
+               PREFIX="$(TARGET_DIR)/usr"
+endef
+
+$(eval $(generic-package))