package/{wlroots,cage}: change mesa3d dependency to virtual libegl/libgles
authorGilles Talis <gilles.talis@gmail.com>
Sat, 13 Feb 2021 12:33:53 +0000 (13:33 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 16 Feb 2021 20:07:52 +0000 (21:07 +0100)
Since commits:
https://github.com/swaywm/wlroots/commit/c2288a7b88240e4377bfc1c67b44efb58f704a42
https://github.com/swaywm/wlroots/commit/e18599b05e0f0cbeba11adbd489e801285470eab

Mesa dependency is no longer required. Wlroots is able to run on
drivers that provide EGL and GLES2.0 support, and with specific EGL
wayland extensions.  (thus the BR2_PACKAGE_HAS_LIBEGL_WAYLAND
dependency)

This was verified on NXP's i.MX8MMini using imx-gpu-viv driver.

Signed-off-by: Julien Olivain <ju.o@free.fr>
Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/cage/Config.in
package/wlroots/Config.in
package/wlroots/wlroots.mk

index 3bef08f03734f20ab555e79f76619eb5edf50d73..0844d6ff62a44a283214e8777b31c7cf814497e2 100644 (file)
@@ -1,6 +1,7 @@
-comment "cage needs udev, mesa3d w/ EGL and GLES support"
-       depends on !BR2_PACKAGE_MESA3D_OPENGL_EGL || \
-               !BR2_PACKAGE_MESA3D_OPENGL_ES || \
+comment "cage needs udev, EGL w/ Wayland backend and OpenGL ES support"
+       depends on !BR2_PACKAGE_HAS_LIBEGL || \
+               !BR2_PACKAGE_HAS_LIBEGL_WAYLAND || \
+               !BR2_PACKAGE_HAS_LIBGLES || \
                !BR2_PACKAGE_HAS_UDEV
 
 comment "cage needs a toolchain w/ threads, dynamic library"
@@ -11,9 +12,10 @@ config BR2_PACKAGE_CAGE
        bool "cage"
        depends on !BR2_STATIC_LIBS # wlroots
        depends on BR2_TOOLCHAIN_HAS_THREADS # wlroots
+       depends on BR2_PACKAGE_HAS_LIBEGL # wlroots
+       depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND # wlroots
+       depends on BR2_PACKAGE_HAS_LIBGLES # wlroots
        depends on BR2_PACKAGE_HAS_UDEV # wlroots
-       depends on BR2_PACKAGE_MESA3D_OPENGL_EGL # wlroots
-       depends on BR2_PACKAGE_MESA3D_OPENGL_ES # wlroots
        select BR2_PACKAGE_WLROOTS
        help
          Kiosk compositor for Wayland, which displays a single
index 2f72fd49452228a5ea550add9bbc6789391fdbfb..694aa79de4d05ef3d6a0a56ff21d5153173d4a78 100644 (file)
@@ -1,6 +1,7 @@
-comment "wlroots needs udev, mesa3d w/ EGL and GLES support"
-       depends on !BR2_PACKAGE_MESA3D_OPENGL_EGL || \
-               !BR2_PACKAGE_MESA3D_OPENGL_ES || \
+comment "wlroots needs udev, EGL w/ Wayland backend and OpenGL ES support"
+       depends on !BR2_PACKAGE_HAS_LIBEGL || \
+               !BR2_PACKAGE_HAS_LIBEGL_WAYLAND || \
+               !BR2_PACKAGE_HAS_LIBGLES || \
                !BR2_PACKAGE_HAS_UDEV
 
 comment "wlroots needs a toolchain w/ threads, dynamic library"
@@ -12,11 +13,9 @@ config BR2_PACKAGE_WLROOTS
        depends on !BR2_STATIC_LIBS # wayland
        depends on BR2_TOOLCHAIN_HAS_THREADS # libdrm, wayland
        depends on BR2_PACKAGE_HAS_UDEV # libinput
-       # Technically wlroots should work with any OpenGL implementation
-       # which provides EGL, GLES2, and libgbm; but in practice only
-       # Mesa ships an usable libgbm.
-       depends on BR2_PACKAGE_MESA3D_OPENGL_EGL
-       depends on BR2_PACKAGE_MESA3D_OPENGL_ES
+       depends on BR2_PACKAGE_HAS_LIBEGL
+       depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND
+       depends on BR2_PACKAGE_HAS_LIBGLES
        select BR2_PACKAGE_LIBDRM
        select BR2_PACKAGE_LIBINPUT
        select BR2_PACKAGE_LIBXKBCOMMON
index 5665d5a9561cd9a23a8fbc0c33ca9e69c568b9fe..0160b1aedbb4afe6466fae3595b6af5a36206013 100644 (file)
@@ -15,7 +15,8 @@ WLROOTS_DEPENDENCIES = \
        host-wayland \
        libinput \
        libxkbcommon \
-       mesa3d \
+       libegl \
+       libgles \
        pixman \
        udev \
        wayland \