Makefile.autotools.in: default to install-strip for non-debug target install
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 20 Oct 2008 11:32:22 +0000 (11:32 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 20 Oct 2008 11:32:22 +0000 (11:32 -0000)
package/Makefile.autotools.in

index 0760063005445e3849c3f42422b3a6f9d122d692..0925feb06b0bf9662ee46cf6e9107c0b74edbd41 100644 (file)
@@ -47,7 +47,7 @@
 #      install the package to the target directory
 # FOO_INSTALL_STAGING_OPT [default DESTDIR=$(STAGING_DIR) install]
 #      arguments passed to <make> while installing to the staging directory
-# FOO_INSTALL_TARGET_OPT [default DESTDIR=$(TARGET_DIR) install-exec]
+# FOO_INSTALL_TARGET_OPT [default DESTDIR=$(TARGET_DIR) install-exec/install-strip]
 #      arguments passed to <make> while installing to the target directory
 # FOO_CLEAN_OPT [default clean]
 #      arguments passed to <make> while installing to the staging directory
@@ -308,7 +308,11 @@ $(2)_MAKE_OPT                      ?=
 $(2)_INSTALL_STAGING           ?= NO
 $(2)_INSTALL_TARGET            ?= YES
 $(2)_INSTALL_STAGING_OPT       ?= DESTDIR=$$(STAGING_DIR) install
+ifeq ($(BR2_ENABLE_DEBUG),y)
 $(2)_INSTALL_TARGET_OPT                ?= DESTDIR=$$(TARGET_DIR)  install-exec
+else
+$(2)_INSTALL_TARGET_OPT                ?= DESTDIR=$$(TARGET_DIR)  install-strip
+endif
 $(2)_CLEAN_OPT                 ?= clean
 $(2)_UNINSTALL_STAGING_OPT     ?= DESTDIR=$$(STAGING_DIR) uninstall
 $(2)_UNINSTALL_TARGET_OPT      ?= DESTDIR=$$(TARGET_DIR)  uninstall