package/grpc: remove obsolete patch to support cross-compiling
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Mon, 1 Feb 2021 20:57:09 +0000 (21:57 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 2 Feb 2021 15:42:48 +0000 (16:42 +0100)
When cross-compiling grpc, a native tool 'grpc_cpp_plugin' is needed.
Patch '0001-target-build-using-host-plugin.patch' in Buildroot provides a
way to pass the path to this tool via a configure option
'gRPC_NATIVE_CPP_PLUGIN'.

In version 1.20.0, the upstream grpc project added better support for
cross-compiling via commit 0d7a0ded [1], searching for the native
grpc_cpp_plugin via PATH (rather than specifying it as configure option as
our patch was doing).

This change renders the mentioned Buildroot patch obsolete, so remove it.

[1] https://github.com/grpc/grpc/commit/0d7a0ded1cc93bb7f4d69a156b0a69829557cbf2

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Reviewed-by: Michael Nosthoff <buildroot@heine.tech>
Tested-by: Michael Nosthoff <buildroot@heine.tech>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/grpc/0001-target-build-using-host-plugin.patch [deleted file]
package/grpc/grpc.mk

diff --git a/package/grpc/0001-target-build-using-host-plugin.patch b/package/grpc/0001-target-build-using-host-plugin.patch
deleted file mode 100644 (file)
index c6de0c1..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-From aa18148e392ef28275a182db34397ccb66fb4617 Mon Sep 17 00:00:00 2001
-From: Robert Rose <robertroyrose@gmail.com>
-Date: Wed, 28 Nov 2018 09:41:52 -0800
-Subject: [PATCH] CMakeLists.txt: allow passing a pre-existing grpc_cpp_plugin
-
-The grpc_cpp_plugin is meant to be executed during the build process
-of grpc. As such, in cross-compilation contexts, this program needs to
-be built for the host machine and not the target machine. In order to
-allow this, this commit adds an option gRPC_NATIVE_CPP_PLUGIN that can
-be passed on the command line, with the path to an existing
-grpc_cpp_plugin binary. If not passed, grpc_cpp_plugin is built as
-usual.
-
-Signed-off-by: Robert Rose <robertroyrose@gmail.com>
----
- CMakeLists.txt | 13 +++++++++++++
- 1 file changed, 13 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index be695c2..45c2fcb 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -11199,6 +11199,18 @@ target_link_libraries(grpc_cli
- endif()
- if(gRPC_BUILD_CODEGEN AND gRPC_BUILD_GRPC_CPP_PLUGIN)
-+if (gRPC_NATIVE_CPP_PLUGIN)
-+
-+add_executable(grpc_cpp_plugin
-+  IMPORTED
-+)
-+
-+set_property(TARGET grpc_cpp_plugin
-+  PROPERTY IMPORTED_LOCATION ${gRPC_NATIVE_CPP_PLUGIN}
-+)
-+
-+else()
-+
- add_executable(grpc_cpp_plugin
-   src/compiler/cpp_plugin.cc
- )
-@@ -11233,6 +11245,7 @@ if(gRPC_INSTALL)
-     ARCHIVE DESTINATION ${gRPC_INSTALL_LIBDIR}
-   )
- endif()
-+endif()
- endif()
- if(gRPC_BUILD_CODEGEN AND gRPC_BUILD_GRPC_CSHARP_PLUGIN)
--- 
-2.26.2
-
index 857064327dca47295f80c742ea1639c04f861286..a8a3af89ef8487b7dbf69bd3248638369658886a 100644 (file)
@@ -27,8 +27,7 @@ GRPC_CONF_OPTS = \
        -DgRPC_PROTOBUF_PROVIDER=package \
        -DgRPC_RE2_PROVIDER=package \
        -DgRPC_SSL_PROVIDER=package \
-       -DgRPC_ZLIB_PROVIDER=package \
-       -DgRPC_NATIVE_CPP_PLUGIN=$(HOST_DIR)/bin/grpc_cpp_plugin
+       -DgRPC_ZLIB_PROVIDER=package
 
 # grpc can use __atomic builtins, so we need to link with
 # libatomic when available