efl/libevas: remove examples source code from target filesystem
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 28 Dec 2012 17:02:58 +0000 (18:02 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Dec 2012 06:21:58 +0000 (07:21 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/libevas/libevas.mk

index 098afe3f95ca4336899ca70676bfb2e4b7568347..0a908424f0a467ce539e34762b4d0ead4037a0b3 100644 (file)
@@ -203,5 +203,13 @@ else
 LIBEVAS_CONF_OPT += --disable-font-loader-eet
 endif
 
+# libevas installs the source code of examples on the target, which
+# are generally not useful.
+define LIBEVAS_REMOVE_EXAMPLES
+       rm -rf $(TARGET_DIR)/usr/share/evas/examples/
+endef
+
+LIBEVAS_POST_INSTALL_TARGET_HOOKS += LIBEVAS_REMOVE_EXAMPLES
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))