package/tinyproxy: new package
authorAlexander Mukhin <alexander.i.mukhin@gmail.com>
Sat, 14 Mar 2020 10:23:23 +0000 (13:23 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 15 Mar 2020 21:57:15 +0000 (22:57 +0100)
Tinyproxy is a small, efficient HTTP/SSL proxy daemon.

https://tinyproxy.github.io

Signed-off-by: Alexander Mukhin <alexander.i.mukhin@gmail.com>
Reviewed-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/tinyproxy/0001-Makefile.am-remove-docs-subdir.patch [new file with mode: 0644]
package/tinyproxy/Config.in [new file with mode: 0644]
package/tinyproxy/tinyproxy.hash [new file with mode: 0644]
package/tinyproxy/tinyproxy.mk [new file with mode: 0644]

index bcd293b4fba9301748f2c6eb679a51b88a65ad4d..16670a607bb9f5d0d44f9fce670fbd79899882b4 100644 (file)
@@ -132,6 +132,9 @@ F:  package/minimodem/
 N:     Alexander Lukichev <alexander.lukichev@gmail.com>
 F:     package/openpgm/
 
+N:     Alexander Mukhin <alexander.i.mukhin@gmail.com>
+F:     package/tinyproxy/
+
 N:     Alexander Sverdlin <alexander.sverdlin@gmail.com>
 F:     package/mini-snmpd/
 
index abcc9cdad502956d8062abcdf1d275ccbc26f97f..afe32f52b4af4f45f9340c0bd43ab8cd11a03ea2 100644 (file)
@@ -2179,6 +2179,7 @@ endif
        source "package/thttpd/Config.in"
        source "package/tinc/Config.in"
        source "package/tinyhttpd/Config.in"
+       source "package/tinyproxy/Config.in"
        source "package/tinyssh/Config.in"
        source "package/tor/Config.in"
        source "package/traceroute/Config.in"
diff --git a/package/tinyproxy/0001-Makefile.am-remove-docs-subdir.patch b/package/tinyproxy/0001-Makefile.am-remove-docs-subdir.patch
new file mode 100644 (file)
index 0000000..e2a0867
--- /dev/null
@@ -0,0 +1,27 @@
+From 7ce6ee22057489d280e0ea5f6439edbbf0ad7ee2 Mon Sep 17 00:00:00 2001
+From: Alexander Mukhin <alexander.i.mukhin@gmail.com>
+Date: Sat, 14 Mar 2020 12:45:29 +0300
+Subject: [PATCH] Makefile.am: remove docs subdir
+
+This avoids building the documentation, which requires asciidoc.
+
+Signed-off-by: Alexander Mukhin <alexander.i.mukhin@gmail.com>
+---
+ Makefile.am | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index e9113c2..2fe3d54 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -2,7 +2,6 @@ SUBDIRS = \
+       src \
+       data \
+       etc \
+-      docs \
+       m4macros \
+       tests
+-- 
+2.20.1
+
diff --git a/package/tinyproxy/Config.in b/package/tinyproxy/Config.in
new file mode 100644 (file)
index 0000000..aec2ab8
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_TINYPROXY
+       bool "tinyproxy"
+       depends on BR2_USE_WCHAR
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU # fork()
+       help
+         Tinyproxy is a small, efficient HTTP/SSL proxy daemon released
+         under the GNU General Public License. Tinyproxy is very
+         useful in a small network setting, where a larger proxy would
+         be too resource intensive.
+
+         https://tinyproxy.github.io
+
+comment "tinyproxy needs a toolchain w/ threads, wchar"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
+       depends on BR2_USE_MMU
diff --git a/package/tinyproxy/tinyproxy.hash b/package/tinyproxy/tinyproxy.hash
new file mode 100644 (file)
index 0000000..2d439de
--- /dev/null
@@ -0,0 +1,2 @@
+# locally computed
+sha256 ff4f3d1331d6d855d8b6ed794c22ab0a4285dd81fe9c98a7aa7ed591248d4ab9 tinyproxy-1.10.0.tar.gz
diff --git a/package/tinyproxy/tinyproxy.mk b/package/tinyproxy/tinyproxy.mk
new file mode 100644 (file)
index 0000000..f1a2a50
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# tinyproxy
+#
+################################################################################
+
+TINYPROXY_VERSION = 1.10.0
+TINYPROXY_SITE = $(call github,tinyproxy,tinyproxy,$(TINYPROXY_VERSION))
+TINYPROXY_LICENSE = GPL-2.0+
+TINYPROXY_LICENSE_FILES = COPYING
+
+# building from a git clone and patching Makefile.am
+TINYPROXY_AUTORECONF = YES
+
+$(eval $(autotools-package))