boot/uboot: license files hashes only valid for latest version
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 5 Feb 2020 14:48:40 +0000 (15:48 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 6 Feb 2020 17:38:35 +0000 (18:38 +0100)
We can only know the details of the license files for known versions.  For
custom, older or newer versions, the license files may change, or may be
moved around.

So, do for U-Boot as was done for ATF, linux, and linux-headers, and only
define the list of license files for the latest version.

Reported-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Markus Mayer <mmayer@broadcom.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
boot/uboot/uboot.mk

index 1f444351d70eec8780c6f42865a07de2cd5e7582..2bfa50779b66d03e5bb9389c3ceb0fa31d1cfae3 100644 (file)
@@ -8,7 +8,9 @@ UBOOT_VERSION = $(call qstrip,$(BR2_TARGET_UBOOT_VERSION))
 UBOOT_BOARD_NAME = $(call qstrip,$(BR2_TARGET_UBOOT_BOARDNAME))
 
 UBOOT_LICENSE = GPL-2.0+
+ifeq ($(BR2_TARGET_UBOOT_LATEST_VERSION),y)
 UBOOT_LICENSE_FILES = Licenses/gpl-2.0.txt
+endif
 
 UBOOT_INSTALL_IMAGES = YES