iso9660 fs: use cpio initrd instead of ext2
authorArnout Vandecappelle <arnout@mind.be>
Fri, 9 Nov 2012 13:54:09 +0000 (13:54 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 14 Nov 2012 21:53:25 +0000 (22:53 +0100)
The ext2 initrd is pretty broken, because it requires an additional
root=/dev/ram0 command line parameter, and a /init to mount
devtmps that isn't there in out ext2 rootfs.  So just use a cpio
instead.

Note that there is no check if the kernel supports initramfs or the
selected compression method.

Also removed a bit of dead code in iso9660.mk.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
fs/iso9660/Config.in
fs/iso9660/iso9660.mk

index 4c00583dc454fddb17256a4e7cc03be8c0df9ecc..98ff78b0ba6658528f76e608225e9026c7e856a6 100644 (file)
@@ -2,7 +2,7 @@ config BR2_TARGET_ROOTFS_ISO9660
        bool "iso image"
        depends on (BR2_i386 || BR2_x86_64)
        depends on BR2_LINUX_KERNEL
-       select BR2_TARGET_ROOTFS_EXT2
+       select BR2_TARGET_ROOTFS_CPIO
        select BR2_TARGET_GRUB
        help
          Build a bootable iso9660 image
index f51b6ee868a1b2477097a5cf83ea7f6c4c0c9aad..029c0dd94acbba0d343fc1c1162e6b88cced2e43 100644 (file)
@@ -9,20 +9,19 @@
 
 ISO9660_TARGET_DIR=$(BUILD_DIR)/iso9660
 ISO9660_BOOT_MENU:=$(call qstrip,$(BR2_TARGET_ROOTFS_ISO9660_BOOT_MENU))
-ISO9660_OPTS:=
 
-ifeq ($(BR2_TARGET_ROOTFS_ISO9660_SQUASH),y)
-ISO9660_OPTS+=-U
-endif
+ISO9660_CPIO_EXT-$(BR2_TARGET_ROOTFS_CPIO_GZIP)  = .gz
+ISO9660_CPIO_EXT-$(BR2_TARGET_ROOTFS_CPIO_BZIP2) = .bz2
+ISO9660_CPIO_EXT-$(BR2_TARGET_ROOTFS_CPIO_LZMA)  = .lzma
 
-$(BINARIES_DIR)/rootfs.iso9660: host-cdrkit host-fakeroot linux rootfs-ext2 grub
+$(BINARIES_DIR)/rootfs.iso9660: host-cdrkit host-fakeroot linux rootfs-cpio grub
        @$(call MESSAGE,"Generating root filesystem image rootfs.iso9660")
        mkdir -p $(ISO9660_TARGET_DIR)
        mkdir -p $(ISO9660_TARGET_DIR)/boot/grub
        cp $(GRUB_DIR)/stage2/stage2_eltorito $(ISO9660_TARGET_DIR)/boot/grub/
        cp $(ISO9660_BOOT_MENU) $(ISO9660_TARGET_DIR)/boot/grub/menu.lst
        cp $(LINUX_IMAGE_PATH) $(ISO9660_TARGET_DIR)/kernel
-       cp $(BINARIES_DIR)/rootfs.ext2 $(ISO9660_TARGET_DIR)/initrd
+       cp $(BINARIES_DIR)/rootfs.cpio$(ISO9660_CPIO_EXT-y) $(ISO9660_TARGET_DIR)/initrd
        # Use fakeroot to pretend all target binaries are owned by root
        rm -f $(FAKEROOT_SCRIPT)
        echo "chown -R 0:0 $(ISO9660_TARGET_DIR)" >> $(FAKEROOT_SCRIPT)