opencore-amr: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 28 Jun 2014 01:38:53 +0000 (22:38 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 1 Jul 2014 12:45:46 +0000 (14:45 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/opencore-amr/Config.in [new file with mode: 0644]
package/opencore-amr/opencore-amr.mk [new file with mode: 0644]

index 648e2c6886c1f99b046f8dfb10bff02ec6c9078a..4a2cf4fa522bcc2d832a96bcc24657aa44e5fcd8 100644 (file)
@@ -522,6 +522,7 @@ menu "Audio/Sound"
        source "package/libsndfile/Config.in"
        source "package/libsoxr/Config.in"
        source "package/libvorbis/Config.in"
+       source "package/opencore-amr/Config.in"
        source "package/opus/Config.in"
        source "package/portaudio/Config.in"
        source "package/speex/Config.in"
diff --git a/package/opencore-amr/Config.in b/package/opencore-amr/Config.in
new file mode 100644 (file)
index 0000000..93b6457
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_OPENCORE_AMR
+       bool "opencore-amr"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         Library of OpenCORE Framework implementation of Adaptive Multi Rate
+         Narrowband and Wideband (AMR-NB and AMR-WB) speech codec.
+
+         http://opencore-amr.sourceforge.net/
+
+comment "opencore-amr needs a toolchain w/ C++"
+        depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/opencore-amr/opencore-amr.mk b/package/opencore-amr/opencore-amr.mk
new file mode 100644 (file)
index 0000000..8b6aa29
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# opencore-amr
+#
+################################################################################
+
+OPENCORE_AMR_VERSION = 0.1.3
+OPENCORE_AMR_SITE = http://downloads.sourceforge.net/project/opencore-amr/opencore-amr
+OPENCORE_AMR_INSTALL_STAGING = YES
+OPENCORE_AMR_LICENSE = Apache-2.0
+OPENCORE_AMR_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))