polkit: new package
authorMarek Belisko <marek.belisko@open-nandra.com>
Fri, 18 Jan 2013 12:08:44 +0000 (12:08 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 20 Jan 2013 22:07:52 +0000 (23:07 +0100)
[Peter: Config.in comment tweak]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/polkit/Config.in [new file with mode: 0644]
package/polkit/polkit.mk [new file with mode: 0644]

index 3fe5c79224f1ce482f9d081be13a050900c1a736..167a52682a9b73d3d50a6b9db06f512596f956d2 100644 (file)
@@ -779,6 +779,7 @@ if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/module-init-tools/Config.in"
 endif
 source "package/monit/Config.in"
+source "package/polkit/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/procps/Config.in"
 source "package/psmisc/Config.in"
diff --git a/package/polkit/Config.in b/package/polkit/Config.in
new file mode 100644 (file)
index 0000000..da5f985
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_POLKIT
+       bool "polkit"
+       depends on BR2_USE_WCHAR # libglib2
+       select BR2_PACKAGE_LIBGLIB2
+       select BR2_PACKAGE_EXPAT
+       help
+         PolicyKit is a toolkit for defining and handling
+         authorizations.  It is used for allowing unprivileged
+         processes to speak to privileged processes.
+
+         http://www.freedesktop.org/wiki/Software/polkit
diff --git a/package/polkit/polkit.mk b/package/polkit/polkit.mk
new file mode 100644 (file)
index 0000000..3eb0422
--- /dev/null
@@ -0,0 +1,21 @@
+#############################################################
+#
+# polkit
+#
+#############################################################
+
+POLKIT_VERSION = 0.103
+POLKIT_SITE = http://www.freedesktop.org/software/polkit/releases/
+POLKIT_LICENSE = GPLv2
+POLKIT_LICENSE_FILES = COPYING
+
+POLKIT_INSTALL_STAGING = YES
+
+POLKIT_DEPENDENCIES = libglib2 host-intltool expat
+
+# We could also support --with-authfw=pam
+POLKIT_CONF_OPT = \
+       --with-authfw=shadow \
+       --with-os-type=unknown
+
+$(eval $(autotools-package))