qt5: expose a QT5_QMAKE variable for other Qt5 packages
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Nov 2014 22:15:09 +0000 (23:15 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 3 Nov 2014 22:06:08 +0000 (23:06 +0100)
Much like package/qt/qt.mk exposes a QT_QMAKE variable that other
qmake-based Qt4 libraries/applications can use in their .mk file, this
commit adds a QT5_QMAKE variable to allow the same for Qt5 packages.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qt5/qt5.mk

index e9c59db9d63bd8f720574da31b27cbbf1eecf85d..2a3e274320236fed320f214784069cdb4d9bd847 100644 (file)
@@ -17,3 +17,6 @@ define QT5_LA_PRL_FILES_FIXUP
                $(SED) "s%-L/usr/lib%%" $$i; \
        done
 endef
+
+# Variable for other Qt applications to use
+QT5_QMAKE = $(HOST_DIR)/usr/bin/qmake -spec devices/linux-buildroot-g++