package/pngquant: fix target build
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 6 Sep 2017 16:39:04 +0000 (18:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 6 Sep 2017 19:35:27 +0000 (21:35 +0200)
Pngquant 2.10 introduced a bundled library libimagequant, Makefile
passes $LIQCONFIGUREFLAGS to the configure script of libimagequant
before building this library:
https://github.com/pornel/pngquant/blob/master/Makefile#L27

This variable is filled by configure with the content of $LIQCONFIGURE
https://github.com/pornel/pngquant/blob/master/configure#L553

We need to pass CC/CFLAGS/LDFLAGS as parameter to configure to fill
$LIQCONFIGURE with correct values in order to use the target toolchain
for building libimagequant:
https://github.com/pornel/pngquant/blob/master/configure#L56

Fixes
http://autobuild.buildroot.net/results/ab1/ab1193db9d76adc02be44d6f273e0986952df3e2/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pngquant/pngquant.mk

index a602cbef594bb324c0579612cef9746a686b4da6..1ce8359d4026c32bebf66217ed61a6d3dbc08402 100644 (file)
@@ -22,6 +22,7 @@ define PNGQUANT_CONFIGURE_CMDS
                ./configure --prefix=/usr \
                $(if $(BR2_PACKAGE_LCMS2),--with-lcms2,--without-lcms2) \
                $(if $(BR2_X86_CPU_HAS_SSE),--enable-sse,--disable-sse) \
+               $(TARGET_CONFIGURE_OPTS) \
        )
 endef