bluez_utils: disable PIE for m68k
authorWaldemar Brodkorb <wbx@openadk.org>
Wed, 22 Jun 2016 19:13:23 +0000 (21:13 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 25 Jun 2016 13:46:02 +0000 (15:46 +0200)
PIE for m68k seems broken even for non-static case.
Fixes following kind of autobuild failures:
http://autobuild.buildroot.net/results/5bb524a58575d57de1006ffa70be17ca713e7730/

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/bluez_utils/bluez_utils.mk

index c2e8295154d386a728e5438235ab29481c4db094..91c2905603c6044a58db3d63b6b78448b9f94f37 100644 (file)
@@ -54,4 +54,9 @@ BLUEZ_UTILS_CONF_OPTS +=      \
        --disable-usb
 endif
 
+# PIE is broken for m68k
+ifeq ($(BR2_m68k),y)
+BLUEZ_UTILS_CONF_OPTS += --disable-pie
+endif
+
 $(eval $(autotools-package))