package/libupnp18: needs host-pkgconf
authorJörg Krause <joerg.krause@embedded.rocks>
Thu, 9 May 2019 11:04:37 +0000 (13:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 18 May 2019 21:31:18 +0000 (23:31 +0200)
Otherwise build fails with:

```
configure.ac:630: error: possibly undefined macro: AC_MSG_ERROR
      If this token and others are legitimate, please use m4_pattern_allow.
```

Fixes:

  http://autobuild.buildroot.net/results/6d734e45ec923dfa7549e0480b3d8913fc29fddd/

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libupnp18/libupnp18.mk

index 5154be5316b991859625ed59a795c48327727507..35e8dc4a47550b0c0b5c2355febb0b62eb9fc35e 100644 (file)
@@ -11,12 +11,13 @@ LIBUPNP18_CONF_ENV = ac_cv_lib_compat_ftime=no
 LIBUPNP18_INSTALL_STAGING = YES
 LIBUPNP18_LICENSE = BSD-3-Clause
 LIBUPNP18_LICENSE_FILES = COPYING
+LIBUPNP18_DEPENDENCIES = host-pkgconf
 # We're patching configure.ac
 LIBUPNP18_AUTORECONF = YES
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 LIBUPNP18_CONF_OPTS += --enable-open-ssl
-LIBUPNP18_DEPENDENCIES += host-pkgconf openssl
+LIBUPNP18_DEPENDENCIES += openssl
 else
 LIBUPNP18_CONF_OPTS += --disable-open-ssl
 endif