qt: Force arm mode instead of Thumb1 mode
authorRichard Genoud <richard.genoud@gmail.com>
Tue, 20 Jan 2015 11:24:39 +0000 (12:24 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Feb 2015 20:42:48 +0000 (21:42 +0100)
Qt has some assembly that doesn't exist in thumb1 mode.
So, force arm mode for Qt

Signed-off-by: Richard Genoud <richard.genoud@gmail.com>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qt/qt.mk

index 36afaad3f197717fee7c8e956978f406e9ebeedb..9ea676cafd72f890ae28b3aa5dd6f03fa84242de 100644 (file)
@@ -52,6 +52,14 @@ endif
 
 endif
 
+# Qt has some assembly function that are not present in thumb1 mode:
+# Error: selected processor does not support Thumb mode `swp r3,r7,[r4]'
+# so, we desactivate thumb mode
+ifeq ($(BR2_ARM_INSTRUCTIONS_THUMB),y)
+QT_CFLAGS += -marm
+QT_CXXFLAGS += -marm
+endif
+
 ifeq ($(BR2_PACKAGE_QT_QT3SUPPORT),y)
 QT_CONFIGURE_OPTS += -qt3support
 else