package/supertuxkart: needs freetype
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 29 Sep 2017 19:01:40 +0000 (21:01 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 1 Oct 2017 21:10:16 +0000 (23:10 +0200)
https://github.com/supertuxkart/stk-code/blob/master/CMakeLists.txt#L231

Build would fail without this patch using this defconfig:

BR2_x86_64=y
BR2_TOOLCHAIN_BUILDROOT_LOCALE=y
BR2_TOOLCHAIN_BUILDROOT_CXX=y
BR2_PACKAGE_SUPERTUXKART=y
BR2_PACKAGE_MESA3D=y
BR2_PACKAGE_MESA3D_DRI_DRIVER_I965=y
BR2_PACKAGE_MESA3D_OPENGL_EGL=y
BR2_PACKAGE_XORG7=y

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Acked-by: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>
Acked-by: Romain Naour <romain.naour@gmail.com>
Tested-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/supertuxkart/Config.in
package/supertuxkart/supertuxkart.mk

index 4919b50a2b8c8c39a98db7301d9a9e9e45bc974c..51759160ebf8290f22065f8ea3f3cf03e654ffd5 100644 (file)
@@ -9,6 +9,7 @@ config BR2_PACKAGE_SUPERTUXKART
        depends on BR2_PACKAGE_HAS_LIBGL
        depends on BR2_PACKAGE_XORG7
        depends on !BR2_TOOLCHAIN_USES_MUSL
+       select BR2_PACKAGE_FREETYPE
        select BR2_PACKAGE_JPEG
        select BR2_PACKAGE_LIBCURL
        select BR2_PACKAGE_LIBGLU
index 76366877806ab5b68144050555390f3141d09ede..dc4b23227de791ac3b584bf4b438c1fb6a11f0e5 100644 (file)
@@ -15,6 +15,7 @@ SUPERTUXKART_LICENSE = GPL-3.0+
 SUPERTUXKART_LICENSE_FILES = COPYING
 
 SUPERTUXKART_DEPENDENCIES = \
+       freetype \
        jpeg \
        libcurl \
        libgl \