uclibc: properly set UCLIBC_HAS_MMU option
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 9 Jun 2017 08:05:04 +0000 (10:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 11 Jun 2017 16:00:48 +0000 (18:00 +0200)
gdbserver's code looks at both UCLIBC_USE_MMU *and* UCLIBC_HAS_MMU to
decide whether to enable the no-MMU code. So far, on noMMU platforms,
UCLIBC_HAS_MMU was still set to 'y'. This commit adjusts this, which is
a step forward in getting gdbserver to build on m68k/coldfire.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
Changes since v2:
 - None
Changes since v1:
 - New patch in the series

package/uclibc/uclibc.mk

index a5a20ea51f29a79d3a931e58a3395d4cbb7c9e7a..fa970df6d587b05034bb95d8552bbfd813777912 100644 (file)
@@ -253,10 +253,12 @@ endif
 
 ifeq ($(BR2_USE_MMU),y)
 define UCLIBC_MMU_CONFIG
+       $(call KCONFIG_ENABLE_OPT,ARCH_HAS_MMU,$(@D)/.config)
        $(call KCONFIG_ENABLE_OPT,ARCH_USE_MMU,$(@D)/.config)
 endef
 else
 define UCLIBC_MMU_CONFIG
+       $(call KCONFIG_DISABLE_OPT,ARCH_HAS_MMU,$(@D)/.config)
        $(call KCONFIG_DISABLE_OPT,ARCH_USE_MMU,$(@D)/.config)
 endef
 endif