lcdproc: fix autobuilder failures
authorSimon Dawson <spdawson@gmail.com>
Sun, 11 Nov 2012 23:18:12 +0000 (23:18 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 15 Nov 2012 23:06:10 +0000 (00:06 +0100)
The lcdproc version bump to 0.5.6 has resulted in autobuilder failures such as
the following.

  http://autobuild.buildroot.org/results/9967bc20a6094e836c4c18ff2cd30edef143bb8e/build-end.log

The 0.5.6 release added a new glcd driver, which requires the freetype and zlib
libraries. This patch makes the lcdproc package depend on freetype and zlib.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/lcdproc/Config.in
package/lcdproc/lcdproc.mk

index 820f4eae57bc8321f51afaffe03ae3d811a64865..e0afc44b96cd0fe9d2934204d01d694ddbc9f8ca 100644 (file)
@@ -1,6 +1,8 @@
 config BR2_PACKAGE_LCDPROC
        bool "lcdproc"
+       select BR2_PACKAGE_FREETYPE
        select BR2_PACKAGE_NCURSES
+       select BR2_PACKAGE_ZLIB
        help
          LCD display driver daemon and clients
 
index aa204f15c6de9778c7d835c61c120866ee219374..2a80289e39396fe423e82b2a3aaebd3b155280e1 100644 (file)
@@ -16,6 +16,6 @@ ifeq ($(BR2_PACKAGE_LCDPROC_MENUS),y)
 LCDPROC_CONF_OPT += --enable-lcdproc-menus
 endif
 
-LCDPROC_DEPENDENCIES = ncurses
+LCDPROC_DEPENDENCIES = freetype ncurses zlib
 
 $(eval $(autotools-package))