ccache: Make the cache directory after ccache is built
authorDan Moulding <dan.moulding@rackwareinc.com>
Thu, 20 Mar 2014 21:08:54 +0000 (15:08 -0600)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 23 Mar 2014 19:50:46 +0000 (20:50 +0100)
This ensures that the cache directory (and all of its ancestor
directories) exist. This is a nice thing to do because, if the parent
of the cache directory doesn't exist, then ccache will complain that
it cannot create the cache directory, causing the build to fail.

[Peter: drop BR2_CCACHE conditional, use POST_INSTALL hook]
Signed-off-by: Dan Moulding <dan.moulding@rackwareinc.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ccache/ccache.mk

index c2c9731f3437df4d39f49ffe79a25b2ca0e45113..650290dced2f4e1257a7d215101a3ddeb75026f7 100644 (file)
@@ -38,6 +38,13 @@ endef
 HOST_CCACHE_POST_CONFIGURE_HOOKS += \
        HOST_CCACHE_PATCH_CONFIGURATION
 
+define HOST_CCACHE_MAKE_CACHE_DIR
+       mkdir -p $(BR_CACHE_DIR)
+endef
+
+HOST_CCACHE_POST_INSTALL_HOOKS += \
+       HOST_CCACHE_MAKE_CACHE_DIR
+
 $(eval $(host-autotools-package))
 
 ifeq ($(BR2_CCACHE),y)