package/freerdp: fix build with gstreamer support
authorSamuel Martin <s.martin49@gmail.com>
Tue, 19 May 2015 22:35:33 +0000 (00:35 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 20 May 2015 21:20:53 +0000 (23:20 +0200)
FreeRDP with gstreamer support enabled needs gstreamer and gst-plugins-base
with gstapp.

Fixes:
  http://autobuild.buildroot.net/results/937/9373d4238bc3f027e571581bd3531018c4faed91/
  http://autobuild.buildroot.org/results/f77/f77a2c9eea7973b54a22e12ab33ee8964adaddfd/

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Tested-by: Gergely Imreh <imrehg@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/freerdp/Config.in
package/freerdp/freerdp.mk

index 2e879b47e111f5a4745c272c8671dd4ff73caac5..f7d655095689ed9f86753c0498c1f7220f173eb3 100644 (file)
@@ -5,6 +5,8 @@ config BR2_PACKAGE_FREERDP
        depends on BR2_TOOLCHAIN_HAS_THREADS
        select BR2_PACKAGE_OPENSSL
        select BR2_PACKAGE_ZLIB
+       select BR2_PACKAGE_GST_PLUGINS_BASE if BR2_PACKAGE_GSTREAMER
+       select BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_APP if BR2_PACKAGE_GSTREAMER
        help
          FreeRDP is a free implementation of the Remote Desktop
          Protocol (RDP), released under the Apache license
index c7c933e177dccf6d8a429aa3563f3a1210efe80e..0d10ef8530dfe84bbb5b7b3fed718282c147e22f 100644 (file)
@@ -17,7 +17,8 @@ FREERDP_CONF_OPTS = -DWITH_MANPAGES=OFF -Wno-dev
 
 ifeq ($(BR2_PACKAGE_GSTREAMER),y)
 FREERDP_CONF_OPTS += -DWITH_GSTREAMER=ON
-FREERDP_DEPENDENCIES += gstreamer
+# freerdp needs gstinterface and gstapp from gst-plugins-base
+FREERDP_DEPENDENCIES += gstreamer gst-plugins-base
 else
 FREERDP_CONF_OPTS += -DWITH_GSTREAMER=OFF
 endif