Makefile: improve detection of make "-s" flag
authorFabio Porcedda <fabio.porcedda@gmail.com>
Thu, 1 Jan 2015 20:03:50 +0000 (21:03 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 2 Jan 2015 15:34:15 +0000 (16:34 +0100)
Because it's just checking the presence of the "s" character even a
  make --warn-undefined-variables
is detected as a silent build.

Fix that by filtering out long options.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index 5e0b4f254a0507f4bb31780fb7400c71c4313abd..9995df74ac99dc0c2fb085beca0098eb42ac381f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -304,7 +304,7 @@ GNU_HOST_NAME := $(shell support/gnuconfig/config.guess)
 TARGETS :=
 
 # silent mode requested?
-QUIET := $(if $(findstring s,$(MAKEFLAGS)),-q)
+QUIET := $(if $(findstring s,$(filter-out --%,$(MAKEFLAGS))),-q)
 
 # Strip off the annoying quoting
 ARCH := $(call qstrip,$(BR2_ARCH))