From: Pascal de Bruijn
Date: Thu, 2 Jan 2020 15:26:45 +0000 (+0100)
Subject: package/lvm2: install udev rules
X-Git-Url: https://git.libre-soc.org/?a=commitdiff_plain;h=51ec0f48eee4115b4eee745902151e2583b01016;p=buildroot.git
package/lvm2: install udev rules
Without the device-mapper udev rules, dm devices will not get a proper
symlink like /dev/disk/by-label/LABEL, which in turn causes fstab
LABEL= mounts to fails.
And by extension causes shenanigans with systemd, where it will
unmount a manually mounted disk because it can't resolve the label.
Signed-off-by: Pascal de Bruijn
Signed-off-by: Thomas Petazzoni
---
diff --git a/package/lvm2/lvm2.mk b/package/lvm2/lvm2.mk
index 14575668a5..3da713fe83 100644
--- a/package/lvm2/lvm2.mk
+++ b/package/lvm2/lvm2.mk
@@ -31,6 +31,10 @@ LVM2_MAKE_ENV = $(TARGET_CONFIGURE_OPTS)
# package/readline is GPL-3.0+, so not license compatible
LVM2_CONF_OPTS += --disable-readline
+ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
+LVM2_CONF_OPTS += --enable-udev_rules
+endif
+
ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
LVM2_CONF_OPTS += --enable-selinux
LVM2_DEPENDENCIES += libselinux