From: Bernhard Reutner-Fischer
- 1 ############################################################# - 2 # - 3 # foo - 4 # - 5 ############################################################# - 6 FOO_VERSION:=1.0 - 7 FOO_SOURCE:=foo-$(FOO_VERSION).tar.gz - 8 FOO_SITE:=http://www.foosoftware.org/downloads - 9 FOO_DIR:=$(BUILD_DIR)/foo-$(FOO_VERSION) - 10 FOO_BINARY:=foo - 11 FOO_TARGET_BINARY:=usr/bin/foo - 12 - 13 $(DL_DIR)/$(FOO_SOURCE): - 14 $(WGET) -P $(DL_DIR) $(FOO_SITE)/$(FOO_SOURCE) - 15 - 16 $(FOO_DIR)/.source: $(DL_DIR)/$(FOO_SOURCE) - 17 $(ZCAT) $(DL_DIR)/$(FOO_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) - - 18 touch $@ - 19 - 20 $(FOO_DIR)/.configured: $(FOO_DIR)/.source - 21 (cd $(FOO_DIR); rm -rf config.cache ; \ - 22 $(TARGET_CONFIGURE_OPTS) \ - 23 CFLAGS="$(TARGET_CFLAGS)" \ - 24 ./configure \ - 25 --target=$(GNU_TARGET_NAME) \ - 26 --host=$(GNU_TARGET_NAME) \ - 27 --build=$(GNU_HOST_NAME) \ - 28 --prefix=/usr \ - 29 --sysconfdir=/etc \ - 30 ); - 31 touch $@ - 32 - 33 $(FOO_DIR)/$(FOO_BINARY): $(FOO_DIR)/.configured - 34 $(MAKE) CC=$(TARGET_CC) -C $(FOO_DIR) - 35 - 36 $(TARGET_DIR)/$(FOO_TARGET_BINARY): $(FOO_DIR)/$(FOO_BINARY) - 37 $(MAKE) prefix=$(TARGET_DIR)/usr -C $(FOO_DIR) install - 38 rm -Rf $(TARGET_DIR)/usr/man - 39 - 40 foo: uclibc ncurses $(TARGET_DIR)/$(FOO_TARGET_BINARY) - 41 - 42 foo-source: $(DL_DIR)/$(FOO_SOURCE) - 43 - 44 foo-clean: - 45 $(MAKE) prefix=$(TARGET_DIR)/usr -C $(FOO_DIR) uninstall - 46 -$(MAKE) -C $(FOO_DIR) clean - 47 - 48 foo-dirclean: - 49 rm -rf $(FOO_DIR) - 50 - 51 ############################################################# - 52 # - 53 # Toplevel Makefile options - 54 # - 55 ############################################################# - 56 ifeq ($(strip $(BR2_PACKAGE_FOO)),y) - 57 TARGETS+=foo - 58 endif + 1 ############################################################# + 2 # + 3 # foo + 4 # + 5 ############################################################# + 6 FOO_VERSION:=1.0 + 7 FOO_SOURCE:=foo-$(FOO_VERSION).tar.gz + 8 FOO_SITE:=http://www.foosoftware.org/downloads + 9 FOO_DIR:=$(BUILD_DIR)/foo-$(FOO_VERSION) + 10 FOO_BINARY:=foo + 11 FOO_TARGET_BINARY:=usr/bin/foo + 12 + 13 $(DL_DIR)/$(FOO_SOURCE): + 14 $(WGET) -P $(DL_DIR) $(FOO_SITE)/$(FOO_SOURCE) + 15 + 16 $(FOO_DIR)/.source: $(DL_DIR)/$(FOO_SOURCE) + 17 $(ZCAT) $(DL_DIR)/$(FOO_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) - + 18 touch $@ + 19 + 20 $(FOO_DIR)/.configured: $(FOO_DIR)/.source + 21 (cd $(FOO_DIR); rm -rf config.cache ; \ + 22 $(TARGET_CONFIGURE_OPTS) \ + 23 CFLAGS="$(TARGET_CFLAGS)" \ + 24 ./configure \ + 25 --target=$(GNU_TARGET_NAME) \ + 26 --host=$(GNU_TARGET_NAME) \ + 27 --build=$(GNU_HOST_NAME) \ + 28 --prefix=/usr \ + 29 --sysconfdir=/etc \ + 30 ); + 31 touch $@ + 32 + 33 $(FOO_DIR)/$(FOO_BINARY): $(FOO_DIR)/.configured + 34 $(MAKE) CC=$(TARGET_CC) -C $(FOO_DIR) + 35 + 36 $(TARGET_DIR)/$(FOO_TARGET_BINARY): $(FOO_DIR)/$(FOO_BINARY) + 37 $(MAKE) prefix=$(TARGET_DIR)/usr -C $(FOO_DIR) install + 38 rm -Rf $(TARGET_DIR)/usr/man + 39 + 40 foo: uclibc ncurses $(TARGET_DIR)/$(FOO_TARGET_BINARY) + 41 + 42 foo-source: $(DL_DIR)/$(FOO_SOURCE) + 43 + 44 foo-clean: + 45 $(MAKE) prefix=$(TARGET_DIR)/usr -C $(FOO_DIR) uninstall + 46 -$(MAKE) -C $(FOO_DIR) clean + 47 + 48 foo-dirclean: + 49 rm -rf $(FOO_DIR) + 50 + 51 ############################################################# + 52 # + 53 # Toplevel Makefile options + 54 # + 55 ############################################################# + 56 ifeq ($(strip $(BR2_PACKAGE_FOO)),y) + 57 TARGETS+=foo + 58 endif@@ -516,7 +516,7 @@ config BR2_PACKAGE_FOO the other
*.mk
files in the package
directory.
- At lines 6-11, a couple of useful variables are defined :
+At lines 6-11, a couple of useful variables are defined :
Lines 13-14 defines a target that downloads the tarball from +
Lines 13-14 defines a target that downloads the tarball from
the remote site to the download directory
(DL_DIR
).
Lines 16-18 defines a target and associated rules that +
Lines 16-18 defines a target and associated rules that uncompress the downloaded tarball. As you can see, this target depends on the tarball file, so that the previous target (line - 13-14) is called before executing the rules of the current + 13-14) is called before executing the rules of the current target. Uncompressing is followed by touching a hidden file to mark the software has having been uncompressed. This trick is used everywhere in Buildroot Makefile to split steps (download, uncompress, configure, compile, install) while still having correct dependencies.
-Lines 20-31 defines a target and associated rules that +
Lines 20-31 defines a target and associated rules that
configures the software. It depends on the previous target (the
hidden .source
file) so that we are sure the software has
been uncompressed. In order to configure it, it basically runs the
@@ -571,14 +571,14 @@ config BR2_PACKAGE_FOO
filesystem. Finally it creates a .configured
file to
mark the software as configured.
Lines 33-34 defines a target and a rule that compiles the +
Lines 33-34 defines a target and a rule that compiles the
software. This target will create the binary file in the
compilation directory, and depends on the software being already
configured (hence the reference to the .configured
file). It basically runs make
inside the source
directory.
Lines 36-38 defines a target and associated rules that install +
Lines 36-38 defines a target and associated rules that install
the software inside the target filesystem. It depends on the
binary file in the source directory, to make sure the software has
been compiled. It uses the install
target of the
@@ -589,7 +589,7 @@ config BR2_PACKAGE_FOO
/usr/man
directory inside the target filesystem is
removed to save space.
Line 40 defines the main target of the software, the one +
Line 40 defines the main target of the software, the one
that will be eventually be used by the top level
Makefile
to download, compile, and then install
this package. This target should first of all depends on all
@@ -598,7 +598,7 @@ config BR2_PACKAGE_FOO
final binary. This last dependency will call all previous
dependencies in the correct order.
Line 42 defines a simple target that only downloads the code +
Line 42 defines a simple target that only downloads the code source. This is not used during normal operation of Buildroot, but is needed if you intend to download all required sources at once for later offline build. Note that if you add a new package providing @@ -606,24 +606,24 @@ config BR2_PACKAGE_FOO users that wish to do offline-builds. Furthermore it eases checking if all package-sources are downloadable.
-Lines 44-46 define a simple target to clean the software build +
Lines 44-46 define a simple target to clean the software build
by calling the Makefiles with the appropriate option.
The clean
target should run make clean
on $(BUILD_DIR)/package-version and MUST uninstall all files of the
package from $(STAGING_DIR) and from $(TARGET_DIR).
Lines 48-49 define a simple target to completely remove the +
Lines 48-49 define a simple target to completely remove the directory in which the software was uncompressed, configured and compiled. This target MUST completely rm $(BUILD_DIR)/package-version.
-Lines 51-58 adds the target foo
to the list
+
Lines 51-58 adds the target foo
to the list
of targets to be compiled by Buildroot by first checking if
the configuration option for this package has been enabled
using the configuration tool, and if so then "subscribes"
this package to be compiled by adding it to the TARGETS
global variable. The name added to the TARGETS global
variable is the name of this package's target, as defined on
- line 40, which is used by Buildroot to download, compile, and
+ line 40, which is used by Buildroot to download, compile, and
then install this package.