From: Ulf Samuelsson An example that uses config files located in the toplevel directory and
@@ -635,52 +638,22 @@ $ make me<TAB>
conflicts, but will use unique build directories, where the user
can configure the build. THINGS TO DO The current Linux implementation is flawed. It only works
- if the user chooses to use one of the few kernels selected
- as base for the kernel-headers. While the Makefile seems to have
- hooks, allowing the developer to specify whatever version he/she
- wants in the target/device/*/* Makefiles, the build will fail
- if another kernel version is choosen. The reason for this is that the kernel patches are not
- applied by the If the kernel-header version and the linux version differs,
- there will be two The solution in the works, is to move the build of Linux to
- The user will be able to select from three different
- Linux strategies:
+
+ The user can select from three different Linux strategies:
The current kernel patches can be configured to be applied to the
+ The current kernel patches can be applied to the
linux source tree even if the version differs from the
kernel header version. Linux
-
"target/linux/linux.mk"
- build script fragment. They are only applied by the
- "toolchain/kernel-headers/*.makefile"
- build script fragments"linux-2.6.X.Y"
- directories in
- "build_<ARCH>/<>"
,
- each with its own set of patches. "project_build_<ARCH>/<project name>/linux-2.6.X.Y"
combined with method to configure
- which patches can be applied. Possibly, the linux source tree
- used to generate the kernel headers will be moved to the
- "toolchain_build_<ARCH>"
- directory
-
-
- "-git"
, or
"-mm"
, or user downloadable kernels
Other optional patches will be board specific or +
There is also support for board specific and architecture specific patches.
There will also be a way for the user to supply absolute @@ -701,9 +674,27 @@ $ make me<TAB>
Maybe, there will also be a possibility to supply an
"URL"
to a patch available on Internet.
+export BUILDROOT_USE_XWINDOWS <> ++ +
+ If there is no linux config file available, + buildroot starts the linux configuration system, which + defaults to "make menuconfig". There is a menuoption + allowing you to use the less archaic "make xconfig" + You can override any .config setting by defining + the BUILDROOT_USE_XWINDOWS environment variable. +
-Many packages can, on top of the simple "enable/disable build", be further configured using Kconfig.