check out specific version of yosys needed for ls180 build
[dev-env-setup.git] / install-hdl-apt-reqs
1 #!/bin/bash
2 if [ "$EUID" -ne 0 ]
3 then echo "Please run as root"
4 exit
5 fi
6 apt-get update -y
7 apt-get upgrade -y
8 apt-get install -y autoconf \
9 bison \
10 build-essential \
11 clang \
12 cmake \
13 exuberant-ctags \
14 flex \
15 g++ \
16 gawk \
17 gcc-8-powerpc64-linux-gnu \
18 git \
19 gperf \
20 graphviz \
21 gtkwave \
22 iverilog \
23 libboost-program-options-dev \
24 libffi-dev \
25 libftdi-dev \
26 libgmp-dev \
27 libmpfr-dev \
28 libpng++-dev \
29 libreadline-dev \
30 libreadline7 \
31 ninja-build \
32 pkg-config \
33 python \
34 python-dev \
35 python-setuptools \
36 python-virtualenv \
37 python3.7 \
38 python3.7-dev \
39 python3-nose \
40 python3-setuptools \
41 python3-venv \
42 qemu-system-ppc \
43 tcl \
44 tcl-dev \
45 tcl-tclreadline \
46 vim \
47 xdot