util/rand_xor: use getrandom() when available
[mesa.git] / meson.build
1 # Copyright © 2017-2019 Intel Corporation
2
3 # Permission is hereby granted, free of charge, to any person obtaining a copy
4 # of this software and associated documentation files (the "Software"), to deal
5 # in the Software without restriction, including without limitation the rights
6 # to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
7 # copies of the Software, and to permit persons to whom the Software is
8 # furnished to do so, subject to the following conditions:
9
10 # The above copyright notice and this permission notice shall be included in
11 # all copies or substantial portions of the Software.
12
13 # THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
14 # IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
15 # FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
16 # AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
17 # LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
18 # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
19 # SOFTWARE.
20
21 project(
22 'mesa',
23 ['c', 'cpp'],
24 version : run_command(
25 [find_program('python', 'python3'), 'bin/meson_get_version.py']
26 ).stdout(),
27 license : 'MIT',
28 meson_version : '>= 0.46',
29 default_options : ['buildtype=debugoptimized', 'b_ndebug=if-release', 'c_std=c99', 'cpp_std=c++14']
30 )
31
32 cc = meson.get_compiler('c')
33 cpp = meson.get_compiler('cpp')
34
35 null_dep = dependency('', required : false)
36
37 if get_option('layout') != 'mirror'
38 error('`mirror` is the only build directory layout supported')
39 endif
40
41 # Arguments for the preprocessor, put these in a separate array from the C and
42 # C++ (cpp in meson terminology) arguments since they need to be added to the
43 # default arguments for both C and C++.
44 pre_args = [
45 '-D__STDC_CONSTANT_MACROS',
46 '-D__STDC_FORMAT_MACROS',
47 '-D__STDC_LIMIT_MACROS',
48 '-DPACKAGE_VERSION="@0@"'.format(meson.project_version()),
49 '-DPACKAGE_BUGREPORT="https://gitlab.freedesktop.org/mesa/mesa/issues"',
50 ]
51
52 with_vulkan_icd_dir = get_option('vulkan-icd-dir')
53 with_tests = get_option('build-tests')
54 with_valgrind = get_option('valgrind')
55 with_libunwind = get_option('libunwind')
56 with_glx_read_only_text = get_option('glx-read-only-text')
57 with_glx_direct = get_option('glx-direct')
58 with_osmesa = get_option('osmesa')
59 with_swr_arches = get_option('swr-arches')
60 with_vulkan_overlay_layer = get_option('vulkan-overlay-layer')
61 with_tools = get_option('tools')
62 if with_tools.contains('all')
63 with_tools = [
64 'drm-shim',
65 'etnaviv',
66 'freedreno',
67 'glsl',
68 'intel',
69 'intel-ui',
70 'lima',
71 'nir',
72 'nouveau',
73 'xvmc',
74 ]
75 endif
76
77 with_intel_tools = with_tools.contains('intel') or with_tools.contains('intel-ui')
78 with_imgui = with_intel_tools or with_vulkan_overlay_layer
79
80 dri_drivers_path = get_option('dri-drivers-path')
81 if dri_drivers_path == ''
82 dri_drivers_path = join_paths(get_option('prefix'), get_option('libdir'), 'dri')
83 endif
84 dri_search_path = get_option('dri-search-path')
85 if dri_search_path == ''
86 dri_search_path = dri_drivers_path
87 endif
88
89 with_gles1 = get_option('gles1')
90 with_gles2 = get_option('gles2')
91 if host_machine.system() == 'windows'
92 if with_gles1 == 'auto'
93 with_gles1 = 'false'
94 endif
95 if with_gles2 == 'auto'
96 with_gles2 = 'false'
97 endif
98 endif
99 with_opengl = get_option('opengl')
100
101 # Default shared glapi off for windows, on elsewhere.
102 _sg = get_option('shared-glapi')
103 if _sg == 'auto'
104 with_shared_glapi = host_machine.system() != 'windows'
105 else
106 with_shared_glapi = _sg == 'true'
107 endif
108
109 # shared-glapi is required if at least two OpenGL APIs are being built
110 if not with_shared_glapi
111 if ((with_gles1 == 'true' and with_gles2 == 'true') or
112 (with_gles1 == 'true' and with_opengl) or
113 (with_gles2 == 'true' and with_opengl))
114 error('shared-glapi required for building two or more of OpenGL, OpenGL ES 1.x, OpenGL ES 2.x')
115 endif
116 with_gles1 = 'false'
117 with_gles2 = 'false'
118 endif
119
120 # We require OpenGL for OpenGL ES
121 if not with_opengl
122 if (with_gles1 == 'true' or with_gles2 == 'true') and not with_opengl
123 error('building OpenGL ES without OpenGL is not supported.')
124 endif
125 with_gles1 = 'false'
126 with_gles2 = 'false'
127 endif
128
129 with_gles1 = with_gles1 != 'false'
130 with_gles2 = with_gles2 != 'false'
131 with_any_opengl = with_opengl or with_gles1 or with_gles2
132 # Only build shared_glapi if at least one OpenGL API is enabled
133 with_shared_glapi = with_shared_glapi and with_any_opengl
134
135 system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos'].contains(host_machine.system())
136
137 dri_drivers = get_option('dri-drivers')
138 if dri_drivers.contains('auto')
139 if system_has_kms_drm
140 # TODO: PPC, Sparc
141 if ['x86', 'x86_64'].contains(host_machine.cpu_family())
142 dri_drivers = ['i915', 'i965', 'r100', 'r200', 'nouveau']
143 elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
144 dri_drivers = []
145 else
146 error('Unknown architecture @0@. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.'.format(
147 host_machine.cpu_family()))
148 endif
149 elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
150 # only swrast would make sense here, but gallium swrast is a much better default
151 dri_drivers = []
152 else
153 error('Unknown OS @0@. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.'.format(
154 host_machine.system()))
155 endif
156 endif
157
158 with_dri_i915 = dri_drivers.contains('i915')
159 with_dri_i965 = dri_drivers.contains('i965')
160 with_dri_r100 = dri_drivers.contains('r100')
161 with_dri_r200 = dri_drivers.contains('r200')
162 with_dri_nouveau = dri_drivers.contains('nouveau')
163 with_dri_swrast = dri_drivers.contains('swrast')
164
165 with_dri = dri_drivers.length() != 0 and dri_drivers != ['']
166
167 gallium_drivers = get_option('gallium-drivers')
168 if gallium_drivers.contains('auto')
169 if system_has_kms_drm
170 # TODO: PPC, Sparc
171 if ['x86', 'x86_64'].contains(host_machine.cpu_family())
172 gallium_drivers = [
173 'r300', 'r600', 'radeonsi', 'nouveau', 'virgl', 'svga', 'swrast',
174 'iris'
175 ]
176 elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
177 gallium_drivers = [
178 'kmsro', 'v3d', 'vc4', 'freedreno', 'etnaviv', 'nouveau',
179 'tegra', 'virgl', 'lima', 'panfrost', 'swrast'
180 ]
181 else
182 error('Unknown architecture @0@. Please pass -Dgallium-drivers to set driver options. Patches gladly accepted to fix this.'.format(
183 host_machine.cpu_family()))
184 endif
185 elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
186 gallium_drivers = ['swrast']
187 else
188 error('Unknown OS @0@. Please pass -Dgallium-drivers to set driver options. Patches gladly accepted to fix this.'.format(
189 host_machine.system()))
190 endif
191 endif
192 with_gallium_kmsro = gallium_drivers.contains('kmsro')
193 with_gallium_radeonsi = gallium_drivers.contains('radeonsi')
194 with_gallium_r300 = gallium_drivers.contains('r300')
195 with_gallium_r600 = gallium_drivers.contains('r600')
196 with_gallium_nouveau = gallium_drivers.contains('nouveau')
197 with_gallium_freedreno = gallium_drivers.contains('freedreno')
198 with_gallium_softpipe = gallium_drivers.contains('swrast')
199 with_gallium_vc4 = gallium_drivers.contains('vc4')
200 with_gallium_v3d = gallium_drivers.contains('v3d')
201 with_gallium_panfrost = gallium_drivers.contains('panfrost')
202 with_gallium_etnaviv = gallium_drivers.contains('etnaviv')
203 with_gallium_tegra = gallium_drivers.contains('tegra')
204 with_gallium_iris = gallium_drivers.contains('iris')
205 with_gallium_i915 = gallium_drivers.contains('i915')
206 with_gallium_svga = gallium_drivers.contains('svga')
207 with_gallium_virgl = gallium_drivers.contains('virgl')
208 with_gallium_swr = gallium_drivers.contains('swr')
209 with_gallium_lima = gallium_drivers.contains('lima')
210 with_gallium_zink = gallium_drivers.contains('zink')
211
212 if cc.get_id().startswith('intel') and meson.version().version_compare('< 0.49.1')
213 error('Meson does not have sufficient support of ICC before 0.49.1 to compile mesa')
214 endif
215
216 with_gallium = gallium_drivers.length() != 0 and gallium_drivers != ['']
217
218 if with_gallium and system_has_kms_drm
219 _glx = get_option('glx')
220 _egl = get_option('egl')
221 if _glx == 'dri' or _egl == 'true' or (_glx == 'disabled' and _egl != 'false')
222 with_dri = true
223 endif
224 endif
225
226 _vulkan_drivers = get_option('vulkan-drivers')
227 if _vulkan_drivers.contains('auto')
228 if system_has_kms_drm
229 if host_machine.cpu_family().startswith('x86')
230 _vulkan_drivers = ['amd', 'intel']
231 elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
232 _vulkan_drivers = []
233 else
234 error('Unknown architecture @0@. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.'.format(
235 host_machine.cpu_family()))
236 endif
237 elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
238 # No vulkan driver supports windows or macOS currently
239 _vulkan_drivers = []
240 else
241 error('Unknown OS @0@. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.'.format(
242 host_machine.system()))
243 endif
244 endif
245
246 with_intel_vk = _vulkan_drivers.contains('intel')
247 with_amd_vk = _vulkan_drivers.contains('amd')
248 with_freedreno_vk = _vulkan_drivers.contains('freedreno')
249 with_any_vk = _vulkan_drivers.length() != 0 and _vulkan_drivers != ['']
250
251 if with_dri_swrast and (with_gallium_softpipe or with_gallium_swr)
252 error('Only one swrast provider can be built')
253 endif
254 if with_dri_i915 and with_gallium_i915
255 error('Only one i915 provider can be built')
256 endif
257 if with_gallium_kmsro and not (with_gallium_v3d or with_gallium_vc4 or with_gallium_etnaviv or with_gallium_freedreno or with_gallium_panfrost or with_gallium_lima)
258 error('kmsro driver requires one or more renderonly drivers (vc4, etnaviv, freedreno, panfrost, lima)')
259 endif
260 if with_gallium_tegra and not with_gallium_nouveau
261 error('tegra driver requires nouveau driver')
262 endif
263
264 if host_machine.system() == 'darwin'
265 with_dri_platform = 'apple'
266 pre_args += '-DBUILDING_MESA'
267 elif ['windows', 'cygwin'].contains(host_machine.system())
268 with_dri_platform = 'windows'
269 elif system_has_kms_drm
270 with_dri_platform = 'drm'
271 else
272 # FIXME: haiku doesn't use dri, and xlib doesn't use dri, probably should
273 # assert here that one of those cases has been met.
274 # FIXME: illumos ends up here as well
275 with_dri_platform = 'none'
276 endif
277
278 _platforms = get_option('platforms')
279 if _platforms.contains('auto')
280 if system_has_kms_drm
281 _platforms = ['x11', 'wayland', 'drm', 'surfaceless']
282 elif ['darwin', 'cygwin'].contains(host_machine.system())
283 _platforms = ['x11', 'surfaceless']
284 elif ['haiku'].contains(host_machine.system())
285 _platforms = ['haiku']
286 elif host_machine.system() == 'windows'
287 _platforms = ['windows']
288 else
289 error('Unknown OS @0@. Please pass -Dplatforms to set platforms. Patches gladly accepted to fix this.'.format(
290 host_machine.system()))
291 endif
292 endif
293
294 with_platform_android = _platforms.contains('android')
295 with_platform_x11 = _platforms.contains('x11')
296 with_platform_wayland = _platforms.contains('wayland')
297 with_platform_drm = _platforms.contains('drm')
298 with_platform_haiku = _platforms.contains('haiku')
299 with_platform_surfaceless = _platforms.contains('surfaceless')
300 with_platform_windows = _platforms.contains('windows')
301
302 with_platforms = false
303 if _platforms.length() != 0 and _platforms != ['']
304 # sanity check that list contains no empty strings
305 if _platforms.contains('')
306 error('Invalid argument list given to -Dplatforms, please fix.')
307 endif
308 with_platforms = true
309 egl_native_platform = _platforms[0]
310 endif
311
312 _xlib_lease = get_option('xlib-lease')
313 if _xlib_lease == 'auto'
314 with_xlib_lease = with_platform_x11 and with_platform_drm
315 else
316 with_xlib_lease = _xlib_lease == 'true'
317 endif
318
319 with_glx = get_option('glx')
320 if with_glx == 'auto'
321 if with_dri
322 with_glx = 'dri'
323 elif with_platform_haiku
324 with_glx = 'disabled'
325 elif host_machine.system() == 'windows'
326 with_glx = 'disabled'
327 elif with_gallium
328 # Even when building just gallium drivers the user probably wants dri
329 with_glx = 'dri'
330 elif with_platform_x11 and with_any_opengl and not with_any_vk
331 # The automatic behavior should not be to turn on xlib based glx when
332 # building only vulkan drivers
333 with_glx = 'xlib'
334 else
335 with_glx = 'disabled'
336 endif
337 endif
338 if with_glx == 'dri'
339 if with_gallium
340 with_dri = true
341 endif
342 endif
343
344 if not (with_dri or with_gallium or with_glx != 'disabled')
345 with_gles1 = false
346 with_gles2 = false
347 with_opengl = false
348 with_any_opengl = false
349 with_shared_glapi = false
350 endif
351
352 _gbm = get_option('gbm')
353 if _gbm == 'auto'
354 with_gbm = system_has_kms_drm and with_dri
355 else
356 with_gbm = _gbm == 'true'
357 endif
358 if with_gbm and not system_has_kms_drm
359 error('GBM only supports DRM/KMS platforms')
360 endif
361
362 _egl = get_option('egl')
363 if _egl == 'auto'
364 with_egl = (
365 not ['darwin', 'windows'].contains(host_machine.system()) and
366 with_dri and with_shared_glapi and with_platforms
367 )
368 elif _egl == 'true'
369 if not with_dri
370 error('EGL requires dri')
371 elif not with_shared_glapi
372 error('EGL requires shared-glapi')
373 elif not with_platforms
374 error('No platforms specified, consider -Dplatforms=drm,x11,surfaceless at least')
375 elif not ['disabled', 'dri'].contains(with_glx)
376 error('EGL requires dri, but a GLX is being built without dri')
377 elif ['darwin', 'windows'].contains(host_machine.system())
378 error('EGL is not available on Windows or MacOS')
379 endif
380 with_egl = true
381 else
382 with_egl = false
383 endif
384
385 if with_egl and not (with_platform_drm or with_platform_surfaceless or with_platform_android)
386 if with_gallium_radeonsi
387 error('RadeonSI requires the drm, surfaceless or android platform when using EGL')
388 endif
389 if with_gallium_virgl
390 error('Virgl requires the drm, surfaceless or android platform when using EGL')
391 endif
392 endif
393
394 # Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
395 if host_machine.system() != 'windows' and (not with_platform_android or get_option('platform-sdk-version') >= 29)
396 pre_args += '-DUSE_ELF_TLS'
397 endif
398
399 if with_glx != 'disabled'
400 if not (with_platform_x11 and with_any_opengl)
401 error('Cannot build GLX support without X11 platform support and at least one OpenGL API')
402 elif with_glx == 'gallium-xlib'
403 if not with_gallium
404 error('Gallium-xlib based GLX requires at least one gallium driver')
405 elif not with_gallium_softpipe
406 error('Gallium-xlib based GLX requires softpipe or llvmpipe.')
407 elif with_dri
408 error('gallium-xlib conflicts with any dri driver')
409 endif
410 elif with_glx == 'xlib'
411 if with_dri
412 error('xlib conflicts with any dri driver')
413 endif
414 elif with_glx == 'dri'
415 if not with_shared_glapi
416 error('dri based GLX requires shared-glapi')
417 endif
418 endif
419 endif
420
421 with_glvnd = get_option('glvnd')
422 if with_glvnd
423 if with_platform_windows
424 error('glvnd cannot be used on Windows')
425 elif with_glx == 'xlib' or with_glx == 'gallium-xlib'
426 error('Cannot build glvnd support for GLX that is not DRI based.')
427 elif with_glx == 'disabled' and not with_egl
428 error('glvnd requires DRI based GLX and/or EGL')
429 endif
430 if get_option('egl-lib-suffix') != ''
431 error('''EGL lib suffix can't be used with libglvnd''')
432 endif
433 endif
434
435 if with_vulkan_icd_dir == ''
436 with_vulkan_icd_dir = join_paths(get_option('datadir'), 'vulkan/icd.d')
437 endif
438
439 # GNU/Hurd includes egl_dri2, without drm.
440 with_dri2 = (with_dri or with_any_vk) and (with_dri_platform == 'drm' or
441 host_machine.system() == 'gnu')
442 _dri3 = get_option('dri3')
443 if _dri3 == 'auto'
444 with_dri3 = system_has_kms_drm and with_dri2
445 else
446 with_dri3 = _dri3 == 'true'
447 endif
448
449 if with_any_vk and (with_platform_x11 and not with_dri3)
450 error('Vulkan drivers require dri3 for X11 support')
451 endif
452 if with_dri
453 if with_glx == 'disabled' and not with_egl and not with_gbm and with_osmesa != 'classic'
454 error('building dri drivers require at least one windowing system or classic osmesa')
455 endif
456 endif
457
458 _vdpau = get_option('gallium-vdpau')
459 if not system_has_kms_drm
460 if _vdpau == 'true'
461 error('VDPAU state tracker can only be build on unix-like OSes.')
462 else
463 _vdpau = 'false'
464 endif
465 elif not with_platform_x11
466 if _vdpau == 'true'
467 error('VDPAU state tracker requires X11 support.')
468 else
469 _vdpau = 'false'
470 endif
471 elif not (with_gallium_r300 or with_gallium_r600 or with_gallium_radeonsi or
472 with_gallium_nouveau)
473 if _vdpau == 'true'
474 error('VDPAU state tracker requires at least one of the following gallium drivers: r300, r600, radeonsi, nouveau.')
475 else
476 _vdpau = 'false'
477 endif
478 endif
479 dep_vdpau = null_dep
480 with_gallium_vdpau = false
481 if _vdpau != 'false'
482 dep_vdpau = dependency('vdpau', version : '>= 1.1', required : _vdpau == 'true')
483 if dep_vdpau.found()
484 dep_vdpau = dep_vdpau.partial_dependency(compile_args : true)
485 with_gallium_vdpau = true
486 endif
487 endif
488
489 if with_gallium_vdpau
490 pre_args += '-DHAVE_ST_VDPAU'
491 endif
492 vdpau_drivers_path = get_option('vdpau-libs-path')
493 if vdpau_drivers_path == ''
494 vdpau_drivers_path = join_paths(get_option('libdir'), 'vdpau')
495 endif
496
497 if with_gallium_zink
498 dep_vulkan = dependency('vulkan')
499 endif
500
501 _xvmc = get_option('gallium-xvmc')
502 if not system_has_kms_drm
503 if _xvmc == 'true'
504 error('XVMC state tracker can only be build on unix-like OSes.')
505 else
506 _xvmc = 'false'
507 endif
508 elif not with_platform_x11
509 if _xvmc == 'true'
510 error('XVMC state tracker requires X11 support.')
511 else
512 _xvmc = 'false'
513 endif
514 elif not (with_gallium_r600 or with_gallium_nouveau)
515 if _xvmc == 'true'
516 error('XVMC state tracker requires at least one of the following gallium drivers: r600, nouveau.')
517 else
518 _xvmc = 'false'
519 endif
520 endif
521 dep_xvmc = null_dep
522 dep_xv = null_dep
523 with_gallium_xvmc = false
524 if _xvmc != 'false'
525 dep_xvmc = dependency('xvmc', version : '>= 1.0.6', required : _xvmc == 'true')
526 dep_xv = dependency('xv', required : _xvmc == 'true')
527 with_gallium_xvmc = dep_xvmc.found() and dep_xv.found()
528 endif
529
530 xvmc_drivers_path = get_option('xvmc-libs-path')
531 if xvmc_drivers_path == ''
532 xvmc_drivers_path = get_option('libdir')
533 endif
534
535 _omx = get_option('gallium-omx')
536 if not system_has_kms_drm
537 if ['auto', 'disabled'].contains(_omx)
538 _omx = 'disabled'
539 else
540 error('OMX state tracker can only be built on unix-like OSes.')
541 endif
542 elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
543 if ['auto', 'disabled'].contains(_omx)
544 _omx = 'disabled'
545 else
546 error('OMX state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau.')
547 endif
548 endif
549 with_gallium_omx = _omx
550 dep_omx = null_dep
551 dep_omx_other = []
552 if ['auto', 'bellagio'].contains(_omx)
553 dep_omx = dependency(
554 'libomxil-bellagio', required : _omx == 'bellagio'
555 )
556 if dep_omx.found()
557 with_gallium_omx = 'bellagio'
558 endif
559 endif
560 if ['auto', 'tizonia'].contains(_omx)
561 if with_dri and with_egl
562 dep_omx = dependency(
563 'libtizonia', version : '>= 0.10.0',
564 required : _omx == 'tizonia',
565 )
566 dep_omx_other = [
567 dependency('libtizplatform', required : _omx == 'tizonia'),
568 dependency('tizilheaders', required : _omx == 'tizonia'),
569 ]
570 if dep_omx.found() and dep_omx_other[0].found() and dep_omx_other[1].found()
571 with_gallium_omx = 'tizonia'
572 endif
573 elif _omx == 'tizonia'
574 error('OMX-Tizonia state tracker requires dri and egl')
575 endif
576 endif
577 if _omx == 'auto'
578 with_gallium_omx = 'disabled'
579 else
580 with_gallium_omx = _omx
581 endif
582
583 pre_args += [
584 '-DENABLE_ST_OMX_BELLAGIO=' + (with_gallium_omx == 'bellagio' ? '1' : '0'),
585 '-DENABLE_ST_OMX_TIZONIA=' + (with_gallium_omx == 'tizonia' ? '1' : '0'),
586 ]
587
588
589 omx_drivers_path = get_option('omx-libs-path')
590
591 if with_gallium_omx != 'disabled'
592 # Figure out where to put the omx driver.
593 # FIXME: this could all be vastly simplified by adding a 'defined_variable'
594 # argument to meson's get_pkgconfig_variable method.
595 if omx_drivers_path == ''
596 _omx_libdir = dep_omx.get_pkgconfig_variable('libdir')
597 _omx_drivers_dir = dep_omx.get_pkgconfig_variable('pluginsdir')
598 if _omx_libdir == get_option('libdir')
599 omx_drivers_path = _omx_drivers_dir
600 else
601 _omx_base_dir = []
602 # This will fail on windows. Does OMX run on windows?
603 _omx_libdir = _omx_libdir.split('/')
604 _omx_drivers_dir = _omx_drivers_dir.split('/')
605 foreach o : _omx_drivers_dir
606 if not _omx_libdir.contains(o)
607 _omx_base_dir += o
608 endif
609 endforeach
610 omx_drivers_path = join_paths(get_option('libdir'), _omx_base_dir)
611 endif
612 endif
613 endif
614
615 _va = get_option('gallium-va')
616 if not system_has_kms_drm
617 if _va == 'true'
618 error('VA state tracker can only be built on unix-like OSes.')
619 else
620 _va = 'false'
621 endif
622 elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
623 if _va == 'true'
624 error('VA state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau.')
625 else
626 _va = 'false'
627 endif
628 endif
629 with_gallium_va = false
630 dep_va = null_dep
631 if _va != 'false'
632 dep_va = dependency('libva', version : '>= 0.38.0', required : _va == 'true')
633 if dep_va.found()
634 dep_va_headers = dep_va.partial_dependency(compile_args : true)
635 with_gallium_va = true
636 endif
637 endif
638
639 va_drivers_path = get_option('va-libs-path')
640 if va_drivers_path == ''
641 va_drivers_path = join_paths(get_option('libdir'), 'dri')
642 endif
643
644 _xa = get_option('gallium-xa')
645 if not system_has_kms_drm
646 if _xa == 'true'
647 error('XA state tracker can only be built on unix-like OSes.')
648 else
649 _xa = 'false'
650 endif
651 elif not (with_gallium_nouveau or with_gallium_freedreno or with_gallium_i915
652 or with_gallium_svga)
653 if _xa == 'true'
654 error('XA state tracker requires at least one of the following gallium drivers: nouveau, freedreno, i915, svga.')
655 else
656 _xa = 'false'
657 endif
658 endif
659 with_gallium_xa = _xa != 'false'
660
661 d3d_drivers_path = get_option('d3d-drivers-path')
662 if d3d_drivers_path == ''
663 d3d_drivers_path = join_paths(get_option('prefix'), get_option('libdir'), 'd3d')
664 endif
665
666 with_gallium_st_nine = get_option('gallium-nine')
667 if with_gallium_st_nine
668 if not with_gallium_softpipe
669 error('The nine state tracker requires gallium softpipe/llvmpipe.')
670 elif not (with_gallium_radeonsi or with_gallium_nouveau or with_gallium_r600
671 or with_gallium_r300 or with_gallium_svga or with_gallium_i915
672 or with_gallium_iris)
673 error('The nine state tracker requires at least one non-swrast gallium driver.')
674 endif
675 if not with_dri3
676 error('Using nine with wine requires dri3')
677 endif
678 endif
679
680 if get_option('power8') != 'false'
681 # on old versions of meson the cpu family would return as ppc64le on little
682 # endian power8, this was changed in 0.48 such that the family would always
683 # be ppc64 regardless of endianness, and then the machine.endian() value
684 # should be checked. Since we support versions < 0.48 we need to use
685 # startswith.
686 if host_machine.cpu_family().startswith('ppc64') and host_machine.endian() == 'little'
687 if cc.get_id() == 'gcc' and cc.version().version_compare('< 4.8')
688 error('Altivec is not supported with gcc version < 4.8.')
689 endif
690 if cc.compiles('''
691 #include <altivec.h>
692 int main() {
693 vector unsigned char r;
694 vector unsigned int v = vec_splat_u32 (1);
695 r = __builtin_vec_vgbbd ((vector unsigned char) v);
696 return 0;
697 }''',
698 args : '-mpower8-vector',
699 name : 'POWER8 intrinsics')
700 pre_args += ['-D_ARCH_PWR8', '-mpower8-vector']
701 elif get_option('power8') == 'true'
702 error('POWER8 intrinsic support required but not found.')
703 endif
704 endif
705 endif
706
707 _opencl = get_option('gallium-opencl')
708 clover_cpp_std = []
709 if _opencl != 'disabled'
710 if not with_gallium
711 error('OpenCL Clover implementation requires at least one gallium driver.')
712 endif
713
714 dep_clc = dependency('libclc')
715 with_gallium_opencl = true
716 with_opencl_icd = _opencl == 'icd'
717
718 with_opencl_spirv = get_option('opencl-spirv')
719 if with_opencl_spirv
720 dep_spirv_tools = dependency('SPIRV-Tools', required : true, version : '>= 2018.0')
721 # LLVMSPIRVLib is available at https://github.com/KhronosGroup/SPIRV-LLVM-Translator
722 dep_llvmspirvlib = dependency('LLVMSPIRVLib', required : true, version : '>= 0.2.1')
723 else
724 dep_spirv_tools = null_dep
725 dep_llvmspirvlib = null_dep
726 endif
727
728 if host_machine.cpu_family().startswith('ppc') and cpp.compiles('''
729 #if !defined(__VEC__) || !defined(__ALTIVEC__)
730 #error "AltiVec not enabled"
731 #endif''',
732 name : 'Altivec')
733 clover_cpp_std += ['cpp_std=gnu++11']
734 endif
735 else
736 dep_clc = null_dep
737 dep_spirv_tools = null_dep
738 dep_llvmspirvlib = null_dep
739 with_gallium_opencl = false
740 with_opencl_icd = false
741 with_opencl_spirv = false
742 endif
743
744 gl_pkgconfig_c_flags = []
745 if with_platform_x11
746 if with_any_vk or with_egl or (with_glx == 'dri' and with_dri_platform == 'drm')
747 pre_args += '-DHAVE_X11_PLATFORM'
748 endif
749 if with_glx == 'xlib' or with_glx == 'gallium-xlib'
750 pre_args += '-DUSE_XSHM'
751 else
752 pre_args += '-DGLX_INDIRECT_RENDERING'
753 if with_glx_direct
754 pre_args += '-DGLX_DIRECT_RENDERING'
755 endif
756 if with_dri_platform == 'drm'
757 pre_args += '-DGLX_USE_DRM'
758 elif with_dri_platform == 'apple'
759 pre_args += '-DGLX_USE_APPLEGL'
760 elif with_dri_platform == 'windows'
761 pre_args += '-DGLX_USE_WINDOWSGL'
762 endif
763 endif
764 else
765 pre_args += '-DEGL_NO_X11'
766 gl_pkgconfig_c_flags += '-DEGL_NO_X11'
767 endif
768 if with_platform_drm
769 if with_egl and not with_gbm
770 error('EGL drm platform requires gbm')
771 endif
772 pre_args += '-DHAVE_DRM_PLATFORM'
773 endif
774 if with_platform_surfaceless
775 pre_args += '-DHAVE_SURFACELESS_PLATFORM'
776 endif
777 if with_platform_android
778 dep_android = [
779 dependency('cutils'),
780 dependency('hardware'),
781 dependency('sync'),
782 ]
783 if with_gallium
784 dep_android += dependency('backtrace')
785 endif
786 if get_option('platform-sdk-version') >= 26
787 dep_android += dependency('nativewindow')
788 endif
789 pre_args += '-DHAVE_ANDROID_PLATFORM'
790 endif
791 if with_platform_haiku
792 pre_args += '-DHAVE_HAIKU_PLATFORM'
793 endif
794
795 if meson.version().version_compare('>=0.50')
796 prog_python = import('python').find_installation('python3')
797 else
798 prog_python = import('python3').find_python()
799 endif
800 has_mako = run_command(
801 prog_python, '-c',
802 '''
803 from distutils.version import StrictVersion
804 import mako
805 assert StrictVersion(mako.__version__) > StrictVersion("0.8.0")
806 ''')
807 if has_mako.returncode() != 0
808 error('Python (3.x) mako module >= 0.8.0 required to build mesa.')
809 endif
810
811 if cc.get_id() == 'gcc' and cc.version().version_compare('< 4.4.6')
812 error('When using GCC, version 4.4.6 or later is required.')
813 endif
814
815 # Support systems without ETIME (e.g. FreeBSD)
816 if cc.get_define('ETIME', prefix : '#include <errno.h>') == ''
817 pre_args += '-DETIME=ETIMEDOUT'
818 endif
819
820 # Define DEBUG for debug builds only (debugoptimized is not included on this one)
821 if get_option('buildtype') == 'debug'
822 pre_args += '-DDEBUG'
823 endif
824
825 with_shader_cache = false
826 _shader_cache = get_option('shader-cache')
827 if _shader_cache != 'false'
828 if host_machine.system() == 'windows'
829 if _shader_cache == 'true'
830 error('Shader Cache does not currently work on Windows')
831 endif
832 else
833 pre_args += '-DENABLE_SHADER_CACHE'
834 with_shader_cache = true
835 endif
836 endif
837 if with_amd_vk and not with_shader_cache
838 error('Radv requires shader cache support')
839 endif
840
841 # Check for GCC style builtins
842 foreach b : ['bswap32', 'bswap64', 'clz', 'clzll', 'ctz', 'expect', 'ffs',
843 'ffsll', 'popcount', 'popcountll', 'unreachable']
844 if cc.has_function(b)
845 pre_args += '-DHAVE___BUILTIN_@0@'.format(b.to_upper())
846 endif
847 endforeach
848
849 # check for GCC __attribute__
850 foreach a : ['const', 'flatten', 'malloc', 'pure', 'unused',
851 'warn_unused_result', 'weak',]
852 if cc.compiles('int foo(void) __attribute__((@0@));'.format(a),
853 name : '__attribute__((@0@))'.format(a))
854 pre_args += '-DHAVE_FUNC_ATTRIBUTE_@0@'.format(a.to_upper())
855 endif
856 endforeach
857 if cc.compiles('int foo(const char *p, ...) __attribute__((format(printf, 1, 2)));',
858 name : '__attribute__((format(...)))')
859 pre_args += '-DHAVE_FUNC_ATTRIBUTE_FORMAT'
860 endif
861 if cc.compiles('struct __attribute__((packed)) foo { int bar; };',
862 name : '__attribute__((packed))')
863 pre_args += '-DHAVE_FUNC_ATTRIBUTE_PACKED'
864 endif
865 if cc.compiles('int *foo(void) __attribute__((returns_nonnull));',
866 name : '__attribute__((returns_nonnull))')
867 pre_args += '-DHAVE_FUNC_ATTRIBUTE_RETURNS_NONNULL'
868 endif
869 if cc.compiles('''int foo_def(void) __attribute__((visibility("default")));
870 int foo_hid(void) __attribute__((visibility("hidden")));
871 int foo_int(void) __attribute__((visibility("internal")));
872 int foo_pro(void) __attribute__((visibility("protected")));''',
873 name : '__attribute__((visibility(...)))')
874 pre_args += '-DHAVE_FUNC_ATTRIBUTE_VISIBILITY'
875 endif
876 if cc.compiles('int foo(void) { return 0; } int bar(void) __attribute__((alias("foo")));',
877 name : '__attribute__((alias(...)))')
878 pre_args += '-DHAVE_FUNC_ATTRIBUTE_ALIAS'
879 endif
880 if cc.compiles('int foo(void) __attribute__((__noreturn__));',
881 name : '__attribute__((__noreturn__))')
882 pre_args += '-DHAVE_FUNC_ATTRIBUTE_NORETURN'
883 endif
884 if cc.compiles('__uint128_t foo(void) { return 0; }',
885 name : '__uint128_t')
886 pre_args += '-DHAVE_UINT128'
887 endif
888
889 # TODO: this is very incomplete
890 if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd'].contains(host_machine.system())
891 pre_args += '-D_GNU_SOURCE'
892 elif host_machine.system() == 'sunos'
893 pre_args += '-D__EXTENSIONS__'
894 elif host_machine.system() == 'windows'
895 pre_args += [
896 '-D_WINDOWS', '-D_WIN32_WINNT=0x0601', '-DWINVER=0x0601',
897 '-DPIPE_SUBSYSTEM_WINDOWS_USER',
898 '-D_USE_MATH_DEFINES', # XXX: scons doesn't use this for mingw
899 ]
900 if cc.get_id() == 'msvc'
901 pre_args += [
902 '-DVC_EXTRALEAN',
903 '-D_CRT_SECURE_NO_WARNINGS',
904 '-D_CRT_SECURE_NO_DEPRECATE',
905 '-D_SCL_SECURE_NO_WARNINGS',
906 '-D_SCL_SECURE_NO_DEPRECATE',
907 '-D_ALLOW_KEYWORD_MACROS',
908 '-D_HAS_EXCEPTIONS=0', # Tell C++ STL to not use exceptions
909 ]
910 else
911 pre_args += ['-D__MSVCRT_VERSION__=0x0700']
912 endif
913 endif
914
915 # Check for generic C arguments
916 c_args = []
917 c_vis_args = []
918 c_msvc_compat_args = []
919 no_override_init_args = []
920 cpp_args = []
921 cpp_vis_args = []
922 cpp_msvc_compat_args = []
923 if cc.get_id() == 'msvc'
924 foreach a : ['/wd4018', # signed/unsigned mismatch
925 '/wd4056', # overflow in floating-point constant arithmetic
926 '/wd4244', # conversion from 'type1' to 'type2', possible loss of data
927 '/wd4267', # 'var' : conversion from 'size_t' to 'type', possible loss of data
928 '/wd4305', # trancation from 'type1' to 'type2'
929 '/wd4351', # new behavior: elements of array 'array' will be default initialized
930 '/wd4756', # overflow in constant arithmetic
931 '/wd4800', # forcing value to bool 'true' or 'false' (performance warning)
932 '/wd4996', # disabled deprecated POSIX name warnings
933 '/wd4291', # no matching operator delete found
934 '/wd4146', # unary minus operator applied to unsigned type, result still unsigned
935 '/wd4200', # nonstandard extension used: zero-sized array in struct/union
936 '/wd4624', # destructor was implicitly defined as deleted [from LLVM]
937 ]
938 if cc.has_argument(a)
939 c_args += a
940 endif
941 if cpp.has_argument(a)
942 cpp_args += a
943 endif
944 endforeach
945 if cc.has_argument('-Wmicrosoft-enum-value') # Clang
946 c_args += '-Wno-microsoft-enum-value'
947 cpp_args += '-Wno-microsoft-enum-value'
948 endif
949 else
950 _trial = [
951 '-Werror=implicit-function-declaration',
952 '-Werror=missing-prototypes',
953 '-Werror=return-type',
954 '-Werror=empty-body',
955 '-Werror=incompatible-pointer-types',
956 '-Werror=int-conversion',
957 '-Wno-missing-field-initializers',
958 '-Wno-format-truncation',
959 '-fno-math-errno',
960 '-fno-trapping-math',
961 '-Qunused-arguments',
962 '-fno-common',
963 ]
964 # MinGW chokes on format specifiers and I can't get it all working
965 if not (cc.get_id() == 'gcc' and host_machine.system() == 'windows')
966 _trial += ['-Werror=format', '-Wformat-security']
967 endif
968 foreach a : _trial
969 if cc.has_argument(a)
970 c_args += a
971 endif
972 endforeach
973
974 _trial = [
975 '-Werror=return-type',
976 '-Werror=empty-body',
977 '-Wno-non-virtual-dtor',
978 '-Wno-missing-field-initializers',
979 '-Wno-format-truncation',
980 '-fno-math-errno',
981 '-fno-trapping-math',
982 '-Qunused-arguments',
983 ]
984 # MinGW chokes on format specifiers and I can't get it all working
985 if not (cc.get_id() == 'gcc' and host_machine.system() == 'windows')
986 _trial += ['-Werror=format', '-Wformat-security']
987 endif
988 foreach a : _trial
989 if cpp.has_argument(a)
990 cpp_args += a
991 endif
992 endforeach
993
994 foreach a : ['-Wno-override-init', '-Wno-initializer-overrides']
995 if cc.has_argument(a)
996 no_override_init_args += a
997 endif
998 endforeach
999
1000 if cc.has_argument('-fvisibility=hidden')
1001 c_vis_args += '-fvisibility=hidden'
1002 endif
1003
1004 # Check for C and C++ arguments for MSVC compatibility. These are only used
1005 # in parts of the mesa code base that need to compile with MSVC, mainly
1006 # common code
1007 foreach a : ['-Werror=pointer-arith', '-Werror=vla', '-Werror=gnu-empty-initializer']
1008 if cc.has_argument(a)
1009 c_msvc_compat_args += a
1010 endif
1011 if cpp.has_argument(a)
1012 cpp_msvc_compat_args += a
1013 endif
1014 endforeach
1015
1016 if cpp.has_argument('-fvisibility=hidden')
1017 cpp_vis_args += '-fvisibility=hidden'
1018 endif
1019
1020 endif
1021
1022 # set linker arguments
1023 if host_machine.system() == 'windows'
1024 if cc.get_id() == 'msvc'
1025 add_project_link_arguments(
1026 '/fixed:no',
1027 '/dynamicbase',
1028 '/nxcompat',
1029 language : ['c', 'cpp'],
1030 )
1031 if get_option('buildtype') != 'debug'
1032 add_project_link_arguments(
1033 '/incremental:no',
1034 language : ['c', 'cpp'],
1035 )
1036 endif
1037 else
1038 add_project_link_arguments(
1039 '-Wl,--nxcompat',
1040 '-Wl,--dynamicbase',
1041 '-static-libgcc',
1042 '-static-libstdc++',
1043 language : ['c', 'cpp'],
1044 )
1045 endif
1046 endif
1047
1048 if host_machine.cpu_family().startswith('x86') and cc.get_id() != 'msvc'
1049 pre_args += '-DUSE_SSE41'
1050 with_sse41 = true
1051 sse41_args = ['-msse4.1']
1052
1053 # GCC on x86 (not x86_64) with -msse* assumes a 16 byte aligned stack, but
1054 # that's not guaranteed
1055 if host_machine.cpu_family() == 'x86'
1056 sse41_args += '-mstackrealign'
1057 endif
1058 else
1059 with_sse41 = false
1060 sse41_args = []
1061 endif
1062
1063 # Check for GCC style atomics
1064 dep_atomic = null_dep
1065
1066 if cc.compiles('''#include <stdint.h>
1067 int main() {
1068 struct {
1069 uint64_t *v;
1070 } x;
1071 return (int)__atomic_load_n(x.v, __ATOMIC_ACQUIRE) &
1072 (int)__atomic_add_fetch(x.v, (uint64_t)1, __ATOMIC_ACQ_REL);
1073
1074 }''',
1075 name : 'GCC atomic builtins')
1076 pre_args += '-DUSE_GCC_ATOMIC_BUILTINS'
1077
1078 # Not all atomic calls can be turned into lock-free instructions, in which
1079 # GCC will make calls into the libatomic library. Check whether we need to
1080 # link with -latomic.
1081 #
1082 # This can happen for 64-bit atomic operations on 32-bit architectures such
1083 # as ARM.
1084 if not cc.links('''#include <stdint.h>
1085 int main() {
1086 struct {
1087 uint64_t *v;
1088 } x;
1089 return (int)__atomic_load_n(x.v, __ATOMIC_ACQUIRE) &
1090 (int)__atomic_add_fetch(x.v, (uint64_t)1, __ATOMIC_ACQ_REL);
1091 }''',
1092 name : 'GCC atomic builtins required -latomic')
1093 dep_atomic = cc.find_library('atomic')
1094 endif
1095 endif
1096 if not cc.links('''#include <stdint.h>
1097 uint64_t v;
1098 int main() {
1099 return __sync_add_and_fetch(&v, (uint64_t)1);
1100 }''',
1101 dependencies : dep_atomic,
1102 name : 'GCC 64bit atomics')
1103 pre_args += '-DMISSING_64BIT_ATOMICS'
1104 endif
1105
1106 dep_ws2_32 = cc.find_library('ws2_32', required : with_platform_windows)
1107
1108 # TODO: shared/static? Is this even worth doing?
1109
1110 with_asm_arch = ''
1111 if host_machine.cpu_family() == 'x86'
1112 if system_has_kms_drm or host_machine.system() == 'gnu'
1113 with_asm_arch = 'x86'
1114 pre_args += ['-DUSE_X86_ASM', '-DUSE_MMX_ASM', '-DUSE_3DNOW_ASM',
1115 '-DUSE_SSE_ASM']
1116
1117 if with_glx_read_only_text
1118 pre_args += ['-DGLX_X86_READONLY_TEXT']
1119 endif
1120 endif
1121 elif host_machine.cpu_family() == 'x86_64'
1122 if system_has_kms_drm
1123 with_asm_arch = 'x86_64'
1124 pre_args += ['-DUSE_X86_64_ASM']
1125 endif
1126 elif host_machine.cpu_family() == 'arm'
1127 if system_has_kms_drm
1128 with_asm_arch = 'arm'
1129 pre_args += ['-DUSE_ARM_ASM']
1130 endif
1131 elif host_machine.cpu_family() == 'aarch64'
1132 if system_has_kms_drm
1133 with_asm_arch = 'aarch64'
1134 pre_args += ['-DUSE_AARCH64_ASM']
1135 endif
1136 elif host_machine.cpu_family() == 'sparc64'
1137 if system_has_kms_drm
1138 with_asm_arch = 'sparc'
1139 pre_args += ['-DUSE_SPARC_ASM']
1140 endif
1141 elif host_machine.cpu_family().startswith('ppc64') and host_machine.endian() == 'little'
1142 if system_has_kms_drm
1143 with_asm_arch = 'ppc64le'
1144 pre_args += ['-DUSE_PPC64LE_ASM']
1145 endif
1146 endif
1147
1148 # Check for standard headers and functions
1149 if (cc.has_header_symbol('sys/sysmacros.h', 'major') and
1150 cc.has_header_symbol('sys/sysmacros.h', 'minor') and
1151 cc.has_header_symbol('sys/sysmacros.h', 'makedev'))
1152 pre_args += '-DMAJOR_IN_SYSMACROS'
1153 endif
1154 if (cc.has_header_symbol('sys/mkdev.h', 'major') and
1155 cc.has_header_symbol('sys/mkdev.h', 'minor') and
1156 cc.has_header_symbol('sys/mkdev.h', 'makedev'))
1157 pre_args += '-DMAJOR_IN_MKDEV'
1158 endif
1159
1160 foreach h : ['xlocale.h', 'sys/sysctl.h', 'linux/futex.h', 'endian.h', 'dlfcn.h', 'execinfo.h', 'sys/shm.h', 'cet.h']
1161 if cc.compiles('#include <@0@>'.format(h), name : '@0@'.format(h))
1162 pre_args += '-DHAVE_@0@'.format(h.to_upper().underscorify())
1163 endif
1164 endforeach
1165
1166 foreach f : ['strtof', 'mkostemp', 'timespec_get', 'memfd_create', 'random_r', 'flock', 'strtok_r', 'getrandom']
1167 if cc.has_function(f)
1168 pre_args += '-DHAVE_@0@'.format(f.to_upper())
1169 endif
1170 endforeach
1171
1172 if cc.has_header_symbol('errno.h', 'program_invocation_name',
1173 args : '-D_GNU_SOURCE')
1174 pre_args += '-DHAVE_PROGRAM_INVOCATION_NAME'
1175 elif with_tools.contains('intel')
1176 error('Intel tools require the program_invocation_name variable')
1177 endif
1178
1179 # MinGW provides a __builtin_posix_memalign function, but not a posix_memalign.
1180 # This means that this check will succeed, but then compilation will later
1181 # fail. MSVC doesn't have this function at all, so only check for it on
1182 # non-windows platforms.
1183 if host_machine.system() != 'windows'
1184 if cc.has_function('posix_memalign')
1185 pre_args += '-DHAVE_POSIX_MEMALIGN'
1186 endif
1187 endif
1188
1189 if cc.has_member('struct dirent', 'd_type', prefix: '''#include <sys/types.h>
1190 #include <dirent.h>''')
1191 pre_args += '-DHAVE_DIRENT_D_TYPE'
1192 endif
1193
1194 # strtod locale support
1195 if cc.links('''
1196 #define _GNU_SOURCE
1197 #include <stdlib.h>
1198 #include <locale.h>
1199 #ifdef HAVE_XLOCALE_H
1200 #include <xlocale.h>
1201 #endif
1202 int main() {
1203 locale_t loc = newlocale(LC_CTYPE_MASK, "C", NULL);
1204 const char *s = "1.0";
1205 char *end;
1206 double d = strtod_l(s, end, loc);
1207 float f = strtof_l(s, end, loc);
1208 freelocale(loc);
1209 return 0;
1210 }''',
1211 args : pre_args,
1212 name : 'strtod has locale support')
1213 pre_args += '-DHAVE_STRTOD_L'
1214 endif
1215
1216 # Check for some linker flags
1217 ld_args_bsymbolic = []
1218 if cc.links('int main() { return 0; }', args : '-Wl,-Bsymbolic', name : 'Bsymbolic')
1219 ld_args_bsymbolic += '-Wl,-Bsymbolic'
1220 endif
1221 ld_args_gc_sections = []
1222 if cc.links('static char unused() { return 5; } int main() { return 0; }',
1223 args : '-Wl,--gc-sections', name : 'gc-sections')
1224 ld_args_gc_sections += '-Wl,--gc-sections'
1225 endif
1226 with_ld_version_script = false
1227 if cc.links('int main() { return 0; }',
1228 args : '-Wl,--version-script=@0@'.format(
1229 join_paths(meson.source_root(), 'build-support/conftest.map')),
1230 name : 'version-script')
1231 with_ld_version_script = true
1232 endif
1233 with_ld_dynamic_list = false
1234 if cc.links('int main() { return 0; }',
1235 args : '-Wl,--dynamic-list=@0@'.format(
1236 join_paths(meson.source_root(), 'build-support/conftest.dyn')),
1237 name : 'dynamic-list')
1238 with_ld_dynamic_list = true
1239 endif
1240
1241 ld_args_build_id = cc.get_supported_link_arguments('-Wl,--build-id=sha1')
1242
1243 # check for dl support
1244 dep_dl = null_dep
1245 if not cc.has_function('dlopen')
1246 dep_dl = cc.find_library('dl', required : host_machine.system() != 'windows')
1247 endif
1248 if cc.has_function('dladdr', dependencies : dep_dl)
1249 # This is really only required for megadrivers
1250 pre_args += '-DHAVE_DLADDR'
1251 endif
1252
1253 if cc.has_function('dl_iterate_phdr')
1254 pre_args += '-DHAVE_DL_ITERATE_PHDR'
1255 elif with_intel_vk
1256 error('Intel "Anvil" Vulkan driver requires the dl_iterate_phdr function')
1257 elif with_dri_i965 and with_shader_cache
1258 error('Intel i965 GL driver requires dl_iterate_phdr when built with shader caching.')
1259 endif
1260
1261 # Determine whether or not the rt library is needed for time functions
1262 if host_machine.system() == 'windows' or cc.has_function('clock_gettime')
1263 dep_clock = null_dep
1264 else
1265 dep_clock = cc.find_library('rt')
1266 endif
1267
1268 # TODO: some of these may be conditional
1269 dep_zlib = dependency('zlib', version : '>= 1.2.3', fallback : ['zlib', 'zlib_dep'])
1270 pre_args += '-DHAVE_ZLIB'
1271
1272 _zstd = get_option('zstd')
1273 if _zstd != 'false'
1274 dep_zstd = dependency('libzstd', required : _zstd == 'true')
1275 if dep_zstd.found()
1276 pre_args += '-DHAVE_ZSTD'
1277 endif
1278 else
1279 dep_zstd = null_dep
1280 endif
1281
1282 dep_thread = dependency('threads')
1283 if dep_thread.found() and host_machine.system() != 'windows'
1284 pre_args += '-DHAVE_PTHREAD'
1285 if cc.has_function(
1286 'pthread_setaffinity_np',
1287 dependencies : dep_thread,
1288 prefix : '#include <pthread.h>',
1289 args : '-D_GNU_SOURCE')
1290 pre_args += '-DHAVE_PTHREAD_SETAFFINITY'
1291 endif
1292 if cc.has_function(
1293 'pthread_setaffinity_np',
1294 dependencies : dep_thread,
1295 prefix : '#include <pthread_np.h>')
1296 pre_args += '-DPTHREAD_SETAFFINITY_IN_NP_HEADER'
1297 endif
1298 endif
1299 if host_machine.system() != 'windows'
1300 dep_expat = dependency('expat', fallback : ['expat', 'expat_dep'])
1301 else
1302 dep_expat = null_dep
1303 endif
1304 # this only exists on linux so either this is linux and it will be found, or
1305 # it's not linux and wont
1306 dep_m = cc.find_library('m', required : false)
1307
1308 # Check for libdrm. Various drivers have different libdrm version requirements,
1309 # but we always want to use the same version for all libdrm modules. That means
1310 # even if driver foo requires 2.4.0 and driver bar requires 2.4.3, if foo and
1311 # bar are both on use 2.4.3 for both of them
1312 dep_libdrm_amdgpu = null_dep
1313 dep_libdrm_radeon = null_dep
1314 dep_libdrm_nouveau = null_dep
1315 dep_libdrm_intel = null_dep
1316
1317 _drm_amdgpu_ver = '2.4.100'
1318 _drm_radeon_ver = '2.4.71'
1319 _drm_nouveau_ver = '2.4.66'
1320 _drm_intel_ver = '2.4.75'
1321 _drm_ver = '2.4.81'
1322
1323 _libdrm_checks = [
1324 ['intel', with_dri_i915 or with_gallium_i915],
1325 ['amdgpu', with_amd_vk or with_gallium_radeonsi],
1326 ['radeon', (with_gallium_radeonsi or with_dri_r100 or with_dri_r200 or
1327 with_gallium_r300 or with_gallium_r600)],
1328 ['nouveau', (with_gallium_nouveau or with_dri_nouveau)],
1329 ]
1330
1331 # VC4 only needs core libdrm support of this version, not a libdrm_vc4
1332 # library.
1333 if with_gallium_vc4
1334 _drm_ver = '2.4.89'
1335 endif
1336
1337 # etnaviv only needs core libdrm
1338 if with_gallium_etnaviv
1339 _drm_ver = '2.4.89'
1340 endif
1341
1342 # Loop over the enables versions and get the highest libdrm requirement for all
1343 # active drivers.
1344 _drm_blame = ''
1345 foreach d : _libdrm_checks
1346 ver = get_variable('_drm_@0@_ver'.format(d[0]))
1347 if d[1] and ver.version_compare('>' + _drm_ver)
1348 _drm_ver = ver
1349 _drm_blame = d[0]
1350 endif
1351 endforeach
1352 if _drm_blame != ''
1353 message('libdrm @0@ needed because @1@ has the highest requirement'.format(_drm_ver, _drm_blame))
1354 endif
1355
1356 # Then get each libdrm module
1357 foreach d : _libdrm_checks
1358 if d[1]
1359 set_variable(
1360 'dep_libdrm_' + d[0],
1361 dependency('libdrm_' + d[0], version : '>=' + _drm_ver)
1362 )
1363 endif
1364 endforeach
1365
1366 with_gallium_drisw_kms = false
1367 dep_libdrm = dependency(
1368 'libdrm', version : '>=' + _drm_ver,
1369 # GNU/Hurd includes egl_dri2, without drm.
1370 required : (with_dri2 and host_machine.system() != 'gnu') or with_dri3
1371 )
1372 if dep_libdrm.found()
1373 pre_args += '-DHAVE_LIBDRM'
1374 if with_dri_platform == 'drm' and with_dri
1375 with_gallium_drisw_kms = true
1376 endif
1377 endif
1378
1379 llvm_modules = ['bitwriter', 'engine', 'mcdisassembler', 'mcjit', 'core', 'executionengine', 'scalaropts', 'transformutils', 'instcombine']
1380 llvm_optional_modules = ['coroutines']
1381 if with_amd_vk or with_gallium_radeonsi or with_gallium_r600
1382 llvm_modules += ['amdgpu', 'native', 'bitreader', 'ipo']
1383 if with_gallium_r600
1384 llvm_modules += 'asmparser'
1385 endif
1386 endif
1387 if with_gallium_opencl
1388 llvm_modules += [
1389 'all-targets', 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
1390 'lto', 'option', 'objcarcopts', 'profiledata',
1391 ]
1392 endif
1393
1394 if with_amd_vk or with_gallium_radeonsi
1395 _llvm_version = '>= 8.0.0'
1396 elif with_gallium_swr
1397 _llvm_version = '>= 6.0.0'
1398 else
1399 _llvm_version = '>= 3.9.0'
1400 endif
1401
1402 _shared_llvm = get_option('shared-llvm')
1403 if _shared_llvm == 'auto'
1404 _shared_llvm = (host_machine.system() != 'windows')
1405 else
1406 _shared_llvm = (_shared_llvm == 'true')
1407 endif
1408 _llvm = get_option('llvm')
1409
1410 # the cmake method can only link statically, so don't attempt to use it if we
1411 # want to link dynamically. Before 0.54.0 meson will try cmake even when shared
1412 # linking is requested, so we need to force the config-tool method to be used
1413 # in that case, but in 0.54.0 meson won't try the cmake method if shared
1414 # linking is requested.
1415 _llvm_method = 'auto'
1416 if meson.version().version_compare('< 0.54.0') and _shared_llvm
1417 _llvm_method = 'config-tool'
1418 endif
1419
1420 dep_llvm = null_dep
1421 with_llvm = false
1422 if _llvm != 'false'
1423 dep_llvm = dependency(
1424 'llvm',
1425 version : _llvm_version,
1426 modules : llvm_modules,
1427 optional_modules : llvm_optional_modules,
1428 required : (
1429 with_amd_vk or with_gallium_radeonsi or with_gallium_swr or
1430 with_gallium_opencl or _llvm == 'true'
1431 ),
1432 static : not _shared_llvm,
1433 method : _llvm_method,
1434 fallback : ['llvm', 'dep_llvm'],
1435 )
1436 with_llvm = dep_llvm.found()
1437 endif
1438 if with_llvm
1439 pre_args += '-DLLVM_AVAILABLE'
1440 pre_args += '-DMESA_LLVM_VERSION_STRING="@0@"'.format(dep_llvm.version())
1441
1442 # LLVM can be built without rtti, turning off rtti changes the ABI of C++
1443 # programs, so we need to build all C++ code in mesa without rtti as well to
1444 # ensure that linking works.
1445 #
1446 # In meson 0.51.0 we can use cmake to find LLVM in addittion to meson's
1447 # builtin llvm-config based finder. A new generic variable getter method
1448 # has also been added, so we'll use that if we can, to cover the cmake case.
1449 if dep_llvm.type_name() == 'internal'
1450 _rtti = subproject('llvm').get_variable('has_rtti', true)
1451 elif meson.version().version_compare('>=0.51')
1452 # The CMake finder will return 'ON', the llvm-config will return 'YES'
1453 _rtti = ['ON', 'YES'].contains(dep_llvm.get_variable(cmake : 'LLVM_ENABLE_RTTI', configtool: 'has-rtti'))
1454 else
1455 _rtti = dep_llvm.get_configtool_variable('has-rtti') == 'YES'
1456 endif
1457 if not _rtti
1458 if with_gallium_nouveau
1459 error('The Nouveau driver requires rtti. You either need to turn off nouveau or use an LLVM built with LLVM_ENABLE_RTTI.')
1460 elif with_gallium_opencl
1461 error('The Clover OpenCL state tracker requires rtti, you need to turn off clover or use an LLVM built with LLVM_ENABLE_RTTI.')
1462 endif
1463 if cc.get_id() == 'msvc'
1464 cpp_args += '/GR-'
1465 else
1466 cpp_args += '-fno-rtti'
1467 endif
1468 endif
1469 elif with_amd_vk or with_gallium_radeonsi or with_gallium_swr
1470 error('The following drivers require LLVM: Radv, RadeonSI, SWR. One of these is enabled, but LLVM is disabled.')
1471 elif with_gallium_opencl
1472 error('The OpenCL "Clover" state tracker requires LLVM, but LLVM is disabled.')
1473 endif
1474
1475 if (with_amd_vk or with_gallium_radeonsi or with_gallium_opencl or
1476 (with_gallium_r600 and with_llvm))
1477 dep_elf = dependency('libelf', required : false)
1478 if not dep_elf.found()
1479 dep_elf = cc.find_library('elf')
1480 endif
1481 else
1482 dep_elf = null_dep
1483 endif
1484
1485 dep_glvnd = null_dep
1486 if with_glvnd
1487 dep_glvnd = dependency('libglvnd', version : '>= 1.2.0')
1488 pre_args += '-DUSE_LIBGLVND=1'
1489 endif
1490
1491 if with_valgrind != 'false'
1492 dep_valgrind = dependency('valgrind', required : with_valgrind == 'true')
1493 if dep_valgrind.found()
1494 pre_args += '-DHAVE_VALGRIND'
1495 endif
1496 else
1497 dep_valgrind = null_dep
1498 endif
1499
1500 # pthread stubs. Lets not and say we didn't
1501
1502 if host_machine.system() == 'windows'
1503 # Prefer the winflexbison versions, they're much easier to install and have
1504 # better windows support.
1505
1506 prog_flex = find_program('win_flex', required : false)
1507 if prog_flex.found()
1508 # windows compatibility (uses <io.h> instead of <unistd.h> and _isatty,
1509 # _fileno functions)
1510 prog_flex = [prog_flex, '--wincompat', '-D__STDC_VERSION__=199901']
1511 else
1512 prog_flex = [find_program('lex', 'flex', required : with_any_opengl)]
1513 endif
1514 # Force flex to use const keyword in prototypes, as relies on __cplusplus or
1515 # __STDC__ macro to determine whether it's safe to use const keyword, but
1516 # MSVC never defines __STDC__ unless we disable all MSVC extensions.
1517 prog_flex += '-DYY_USE_CONST='
1518
1519 prog_bison = find_program('win_bison', required : false)
1520 if not prog_bison.found()
1521 prog_bison = find_program('yacc', 'bison', required : with_any_opengl)
1522 endif
1523 else
1524 prog_bison = find_program('bison', required : with_any_opengl)
1525
1526 # Disable deprecated keyword warnings, since we have to use them for
1527 # old-bison compat. See discussion in
1528 # https://gitlab.freedesktop.org/mesa/mesa/merge_requests/2161
1529 if meson.version().version_compare('>= 0.52.0') and find_program('bison', required : false, version : '> 2.3').found()
1530 prog_bison = [prog_bison, '-Wno-deprecated']
1531 endif
1532
1533 prog_flex = find_program('flex', required : with_any_opengl)
1534 endif
1535
1536 dep_selinux = null_dep
1537 if get_option('selinux')
1538 dep_selinux = dependency('libselinux')
1539 pre_args += '-DMESA_SELINUX'
1540 endif
1541
1542 if with_libunwind != 'false'
1543 dep_unwind = dependency('libunwind', required : with_libunwind == 'true')
1544 if dep_unwind.found()
1545 pre_args += '-DHAVE_LIBUNWIND'
1546 endif
1547 else
1548 dep_unwind = null_dep
1549 endif
1550
1551 if with_osmesa != 'none'
1552 if with_osmesa == 'gallium' and not with_gallium_softpipe
1553 error('OSMesa gallium requires gallium softpipe or llvmpipe.')
1554 endif
1555 if host_machine.system() == 'windows'
1556 osmesa_lib_name = 'osmesa'
1557 else
1558 osmesa_lib_name = 'OSMesa'
1559 endif
1560 osmesa_bits = get_option('osmesa-bits')
1561 if osmesa_bits != '8'
1562 if with_dri or with_glx != 'disabled'
1563 error('OSMesa bits must be 8 if building glx or dir based drivers')
1564 endif
1565 osmesa_lib_name = osmesa_lib_name + osmesa_bits
1566 pre_args += [
1567 '-DCHAN_BITS=@0@'.format(osmesa_bits), '-DDEFAULT_SOFTWARE_DEPTH_BITS=31'
1568 ]
1569 endif
1570 endif
1571
1572 # TODO: symbol mangling
1573
1574 if with_platform_wayland
1575 dep_wl_scanner = dependency('wayland-scanner', native: true)
1576 prog_wl_scanner = find_program(dep_wl_scanner.get_pkgconfig_variable('wayland_scanner'))
1577 if dep_wl_scanner.version().version_compare('>= 1.15')
1578 wl_scanner_arg = 'private-code'
1579 else
1580 wl_scanner_arg = 'code'
1581 endif
1582 dep_wl_protocols = dependency('wayland-protocols', version : '>= 1.8')
1583 dep_wayland_client = dependency('wayland-client', version : '>=1.11')
1584 dep_wayland_server = dependency('wayland-server', version : '>=1.11')
1585 if with_egl
1586 dep_wayland_egl = dependency('wayland-egl-backend', version : '>= 3')
1587 dep_wayland_egl_headers = dep_wayland_egl.partial_dependency(compile_args : true)
1588 endif
1589 wayland_dmabuf_xml = join_paths(
1590 dep_wl_protocols.get_pkgconfig_variable('pkgdatadir'), 'unstable',
1591 'linux-dmabuf', 'linux-dmabuf-unstable-v1.xml'
1592 )
1593 pre_args += ['-DHAVE_WAYLAND_PLATFORM', '-DWL_HIDE_DEPRECATED']
1594 endif
1595
1596 dep_x11 = null_dep
1597 dep_xext = null_dep
1598 dep_xdamage = null_dep
1599 dep_xfixes = null_dep
1600 dep_x11_xcb = null_dep
1601 dep_xcb = null_dep
1602 dep_xcb_glx = null_dep
1603 dep_xcb_dri2 = null_dep
1604 dep_xcb_dri3 = null_dep
1605 dep_dri2proto = null_dep
1606 dep_glproto = null_dep
1607 dep_xxf86vm = null_dep
1608 dep_xcb_dri3 = null_dep
1609 dep_xcb_present = null_dep
1610 dep_xcb_sync = null_dep
1611 dep_xcb_xfixes = null_dep
1612 dep_xshmfence = null_dep
1613 dep_xcb_xrandr = null_dep
1614 dep_xlib_xrandr = null_dep
1615 if with_platform_x11
1616 if with_glx == 'xlib' or with_glx == 'gallium-xlib'
1617 dep_x11 = dependency('x11')
1618 dep_xext = dependency('xext')
1619 dep_xcb = dependency('xcb')
1620 elif with_glx == 'dri'
1621 dep_x11 = dependency('x11')
1622 dep_xext = dependency('xext')
1623 dep_xdamage = dependency('xdamage', version : '>= 1.1')
1624 dep_xfixes = dependency('xfixes')
1625 dep_xcb_glx = dependency('xcb-glx', version : '>= 1.8.1')
1626 endif
1627 if (with_any_vk or with_glx == 'dri' or with_egl or
1628 (with_gallium_vdpau or with_gallium_xvmc or with_gallium_va or
1629 with_gallium_omx != 'disabled'))
1630 dep_xcb = dependency('xcb')
1631 dep_x11_xcb = dependency('x11-xcb')
1632 if with_dri_platform == 'drm' and not dep_libdrm.found()
1633 error('libdrm required for gallium video statetrackers when using x11')
1634 endif
1635 endif
1636 if with_any_vk or with_egl or (with_glx == 'dri' and with_dri_platform == 'drm')
1637 dep_xcb_dri2 = dependency('xcb-dri2', version : '>= 1.8')
1638
1639 if with_dri3
1640 pre_args += '-DHAVE_DRI3'
1641 dep_xcb_dri3 = dependency('xcb-dri3')
1642 dep_xcb_present = dependency('xcb-present')
1643 # until xcb-dri3 has been around long enough to make a hard-dependency:
1644 if (dep_xcb_dri3.version().version_compare('>= 1.13') and
1645 dep_xcb_present.version().version_compare('>= 1.13'))
1646 pre_args += '-DHAVE_DRI3_MODIFIERS'
1647 endif
1648 dep_xcb_sync = dependency('xcb-sync')
1649 dep_xshmfence = dependency('xshmfence', version : '>= 1.1')
1650 endif
1651 endif
1652 if with_glx == 'dri' or with_glx == 'gallium-xlib'
1653 dep_glproto = dependency('glproto', version : '>= 1.4.14')
1654 endif
1655 if with_glx == 'dri'
1656 if with_dri_platform == 'drm'
1657 dep_dri2proto = dependency('dri2proto', version : '>= 2.8')
1658 dep_xxf86vm = dependency('xxf86vm')
1659 endif
1660 endif
1661 if (with_egl or (
1662 with_gallium_vdpau or with_gallium_xvmc or with_gallium_xa or
1663 with_gallium_omx != 'disabled'))
1664 dep_xcb_xfixes = dependency('xcb-xfixes')
1665 endif
1666 if with_xlib_lease
1667 dep_xcb_xrandr = dependency('xcb-randr')
1668 dep_xlib_xrandr = dependency('xrandr', version : '>= 1.3')
1669 endif
1670 endif
1671
1672 if get_option('gallium-extra-hud')
1673 pre_args += '-DHAVE_GALLIUM_EXTRA_HUD=1'
1674 endif
1675
1676 _sensors = get_option('lmsensors')
1677 if _sensors != 'false'
1678 dep_lmsensors = cc.find_library('sensors', required : _sensors == 'true')
1679 if dep_lmsensors.found()
1680 pre_args += '-DHAVE_LIBSENSORS=1'
1681 endif
1682 else
1683 dep_lmsensors = null_dep
1684 endif
1685
1686 foreach a : pre_args
1687 add_project_arguments(a, language : ['c', 'cpp'])
1688 endforeach
1689 foreach a : c_args
1690 add_project_arguments(a, language : ['c'])
1691 endforeach
1692 foreach a : cpp_args
1693 add_project_arguments(a, language : ['cpp'])
1694 endforeach
1695
1696 gl_priv_reqs = []
1697
1698 if with_glx == 'xlib' or with_glx == 'gallium-xlib'
1699 gl_priv_reqs += ['x11', 'xext', 'xcb']
1700 elif with_glx == 'dri'
1701 gl_priv_reqs += [
1702 'x11', 'xext', 'xdamage >= 1.1', 'xfixes', 'x11-xcb', 'xcb',
1703 'xcb-glx >= 1.8.1']
1704 if with_dri_platform == 'drm'
1705 gl_priv_reqs += 'xcb-dri2 >= 1.8'
1706 gl_priv_reqs += 'xxf86vm'
1707 endif
1708 endif
1709 if dep_libdrm.found()
1710 gl_priv_reqs += 'libdrm >= 2.4.75'
1711 endif
1712
1713 gl_priv_libs = []
1714 if dep_thread.found()
1715 gl_priv_libs += ['-lpthread', '-pthread']
1716 endif
1717 if dep_m.found()
1718 gl_priv_libs += '-lm'
1719 endif
1720 if dep_dl.found()
1721 gl_priv_libs += '-ldl'
1722 endif
1723
1724 pkg = import('pkgconfig')
1725
1726 if host_machine.system() == 'windows'
1727 prog_dumpbin = find_program('dumpbin', required : false)
1728 with_symbols_check = prog_dumpbin.found() and with_tests
1729 symbols_check_args = ['--dumpbin', prog_dumpbin.path()]
1730 else
1731 prog_nm = find_program('nm')
1732 with_symbols_check = with_tests
1733 symbols_check_args = ['--nm', prog_nm.path()]
1734 endif
1735
1736 # This quirk needs to be applied to sources with functions defined in assembly
1737 # as GCC LTO drops them. See: https://bugs.freedesktop.org/show_bug.cgi?id=109391
1738 gcc_lto_quirk = (cc.get_id() == 'gcc') ? ['-fno-lto'] : []
1739
1740 subdir('include')
1741 subdir('bin')
1742 subdir('src')
1743
1744 # Meson 0.49 and earlier seems to have a bug that fails to evaluate the string-
1745 # formatting below unless the first argument is passed as a variable. This has
1746 # been fixed in Meson 0.50 and beyond, but we need to keep it like this for now
1747 # for backwards compatibility.
1748 _with_opengl_string = with_opengl ? 'yes' : 'no'
1749
1750 lines = ['',
1751 'prefix: ' + get_option('prefix'),
1752 'libdir: ' + get_option('libdir'),
1753 'includedir: ' + get_option('includedir'),
1754 '',
1755 'OpenGL: @0@ (ES1: @1@ ES2: @2@)'.format(_with_opengl_string,
1756 with_gles1 ? 'yes' : 'no',
1757 with_gles2 ? 'yes' : 'no'),
1758 ]
1759
1760 if with_osmesa != 'none'
1761 lines += ''
1762 suffix = ''
1763 if with_osmesa == 'gallium'
1764 suffix = '(Gallium)'
1765 endif
1766 lines += 'OSMesa: lib' + osmesa_lib_name + suffix
1767 else
1768 lines += 'OSMesa: no'
1769 endif
1770
1771 if with_dri
1772 lines += ''
1773 lines += 'DRI platform: ' + with_dri_platform
1774 if dri_drivers.length() != 0 and dri_drivers != ['']
1775 lines += 'DRI drivers: ' + ' '.join(dri_drivers)
1776 else
1777 lines += 'DRI drivers: no'
1778 endif
1779 lines += 'DRI driver dir: ' + dri_drivers_path
1780 endif
1781
1782 if with_glx != 'disabled'
1783 lines += ''
1784 if with_glx == 'dri'
1785 lines += 'GLX: DRI-based'
1786 elif with_glx == 'xlib'
1787 lines += 'GLX: Xlib-based'
1788 elif with_glx == 'gallium-xlib'
1789 lines += 'GLX: Xlib-based (Gallium)'
1790 else
1791 lines += 'GLX: ' + with_glx
1792 endif
1793 endif
1794
1795 lines += ''
1796 lines += 'EGL: ' + (with_egl ? 'yes' : 'no')
1797 if with_egl
1798 egl_drivers = []
1799 if with_dri
1800 egl_drivers += 'builtin:egl_dri2'
1801 endif
1802 if with_dri3
1803 egl_drivers += 'builtin:egl_dri3'
1804 endif
1805 lines += 'EGL drivers: ' + ' '.join(egl_drivers)
1806 endif
1807 lines += 'GBM: ' + (with_gbm ? 'yes' : 'no')
1808 if with_platforms
1809 lines += 'EGL/Vulkan/VL platforms: ' + ' '.join(_platforms)
1810 endif
1811
1812 lines += ''
1813 if with_any_vk
1814 lines += 'Vulkan drivers: ' + ' '.join(_vulkan_drivers)
1815 lines += 'Vulkan ICD dir: ' + with_vulkan_icd_dir
1816 else
1817 lines += 'Vulkan drivers: no'
1818 endif
1819
1820 lines += ''
1821 if with_llvm
1822 lines += 'llvm: yes'
1823 lines += 'llvm-version: ' + dep_llvm.version()
1824 else
1825 lines += 'llvm: no'
1826 endif
1827
1828 lines += ''
1829 if with_gallium
1830 lines += 'Gallium drivers: ' + ' '.join(gallium_drivers)
1831 gallium_st = ['mesa']
1832 if with_gallium_xa
1833 gallium_st += 'xa'
1834 endif
1835 if with_gallium_xvmc
1836 gallium_st += 'xvmc'
1837 endif
1838 if with_gallium_xvmc
1839 gallium_st += 'xvmc'
1840 endif
1841 if with_gallium_vdpau
1842 gallium_st += 'vdpau'
1843 endif
1844 if with_gallium_omx != 'disabled'
1845 gallium_st += 'omx' + with_gallium_omx
1846 endif
1847 if with_gallium_va
1848 gallium_st += 'va'
1849 endif
1850 if with_gallium_st_nine
1851 gallium_st += 'nine'
1852 endif
1853 if with_gallium_opencl
1854 gallium_st += 'clover'
1855 endif
1856 lines += 'Gallium st: ' + ' '.join(gallium_st)
1857 else
1858 lines += 'Gallium: no'
1859 endif
1860
1861 lines += 'HUD lmsensors: ' + (dep_lmsensors.found() ? 'yes' : 'no')
1862
1863 lines += ''
1864 lines += 'Shared-glapi: ' + (with_shared_glapi ? 'yes' : 'no')
1865
1866
1867 indent = ' '
1868 summary = indent + ('\n' + indent).join(lines)
1869 message('Configuration summary:\n@0@\n'.format(summary))