etnaviv: Fix disabling early-z rejection on GC7000L (HALTI5)
[mesa.git] / meson.build
1 # Copyright © 2017-2020 Intel Corporation
2
3 # Permission is hereby granted, free of charge, to any person obtaining a copy
4 # of this software and associated documentation files (the "Software"), to deal
5 # in the Software without restriction, including without limitation the rights
6 # to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
7 # copies of the Software, and to permit persons to whom the Software is
8 # furnished to do so, subject to the following conditions:
9
10 # The above copyright notice and this permission notice shall be included in
11 # all copies or substantial portions of the Software.
12
13 # THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
14 # IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
15 # FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
16 # AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
17 # LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
18 # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
19 # SOFTWARE.
20
21 project(
22 'mesa',
23 ['c', 'cpp'],
24 version : run_command(
25 [find_program('python', 'python3'), 'bin/meson_get_version.py']
26 ).stdout(),
27 license : 'MIT',
28 meson_version : '>= 0.52',
29 default_options : ['buildtype=debugoptimized', 'b_ndebug=if-release', 'c_std=c99', 'cpp_std=c++14']
30 )
31
32 cc = meson.get_compiler('c')
33 cpp = meson.get_compiler('cpp')
34
35 null_dep = dependency('', required : false)
36
37 if get_option('layout') != 'mirror'
38 error('`mirror` is the only build directory layout supported')
39 endif
40
41 # Arguments for the preprocessor, put these in a separate array from the C and
42 # C++ (cpp in meson terminology) arguments since they need to be added to the
43 # default arguments for both C and C++.
44 pre_args = [
45 '-D__STDC_CONSTANT_MACROS',
46 '-D__STDC_FORMAT_MACROS',
47 '-D__STDC_LIMIT_MACROS',
48 '-DPACKAGE_VERSION="@0@"'.format(meson.project_version()),
49 '-DPACKAGE_BUGREPORT="https://gitlab.freedesktop.org/mesa/mesa/-/issues"',
50 ]
51
52 with_vulkan_icd_dir = get_option('vulkan-icd-dir')
53 with_tests = get_option('build-tests')
54 with_aco_tests = get_option('build-aco-tests')
55 with_glx_read_only_text = get_option('glx-read-only-text')
56 with_glx_direct = get_option('glx-direct')
57 with_osmesa = get_option('osmesa')
58 with_swr_arches = get_option('swr-arches')
59 with_vulkan_overlay_layer = get_option('vulkan-overlay-layer')
60 with_tools = get_option('tools')
61 if with_tools.contains('all')
62 with_tools = [
63 'drm-shim',
64 'etnaviv',
65 'freedreno',
66 'glsl',
67 'intel',
68 'intel-ui',
69 'lima',
70 'nir',
71 'nouveau',
72 'xvmc',
73 ]
74 endif
75
76 with_intel_tools = with_tools.contains('intel') or with_tools.contains('intel-ui')
77 with_imgui = with_intel_tools or with_vulkan_overlay_layer
78
79 dri_drivers_path = get_option('dri-drivers-path')
80 if dri_drivers_path == ''
81 dri_drivers_path = join_paths(get_option('prefix'), get_option('libdir'), 'dri')
82 endif
83 dri_search_path = get_option('dri-search-path')
84 if dri_search_path == ''
85 dri_search_path = dri_drivers_path
86 endif
87
88 with_gles1 = get_option('gles1')
89 if with_gles1 == 'true'
90 with_gles1 = 'enabled'
91 warning('gles1 option "true" deprecated, please use "enabled" instead.')
92 elif with_gles1 == 'false'
93 with_gles1 = 'disabled'
94 warning('gles1 option "false" deprecated, please use "disabled" instead.')
95 endif
96 with_gles2 = get_option('gles2')
97 if with_gles2 == 'true'
98 with_gles2 = 'enabled'
99 warning('gles2 option "true" deprecated, please use "enabled" instead.')
100 elif with_gles2 == 'false'
101 with_gles2 = 'disabled'
102 warning('gles2 option "false" deprecated, please use "disabled" instead.')
103 endif
104 if host_machine.system() == 'windows'
105 if with_gles1 == 'auto'
106 with_gles1 = 'disabled'
107 endif
108 if with_gles2 == 'auto'
109 with_gles2 = 'disabled'
110 endif
111 endif
112 with_opengl = get_option('opengl')
113
114 # Default shared glapi off for windows, on elsewhere.
115 _sg = get_option('shared-glapi')
116 if _sg == 'true'
117 _sg = 'enabled'
118 warning('shared-glapi option "true" deprecated, please use "enabled" instead.')
119 elif _sg == 'false'
120 _sg = 'disabled'
121 warning('shared-glapi option "false" deprecated, please use "disabled" instead.')
122 endif
123 if _sg == 'auto'
124 with_shared_glapi = host_machine.system() != 'windows'
125 else
126 with_shared_glapi = _sg == 'enabled'
127 endif
128
129 # shared-glapi is required if at least two OpenGL APIs are being built
130 if not with_shared_glapi
131 if ((with_gles1 == 'enabled' and with_gles2 == 'enabled') or
132 (with_gles1 == 'enabled' and with_opengl) or
133 (with_gles2 == 'enabled' and with_opengl))
134 error('shared-glapi required for building two or more of OpenGL, OpenGL ES 1.x, OpenGL ES 2.x')
135 endif
136 with_gles1 = 'disabled'
137 with_gles2 = 'disabled'
138 endif
139
140 # We require OpenGL for OpenGL ES
141 if not with_opengl
142 if (with_gles1 == 'enabled' or with_gles2 == 'enabled') and not with_opengl
143 error('building OpenGL ES without OpenGL is not supported.')
144 endif
145 with_gles1 = 'disabled'
146 with_gles2 = 'disabled'
147 endif
148
149 with_gles1 = with_gles1 != 'disabled'
150 with_gles2 = with_gles2 != 'disabled'
151 with_any_opengl = with_opengl or with_gles1 or with_gles2
152 # Only build shared_glapi if at least one OpenGL API is enabled
153 with_shared_glapi = with_shared_glapi and with_any_opengl
154
155 system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos'].contains(host_machine.system())
156
157 dri_drivers = get_option('dri-drivers')
158 if dri_drivers.contains('auto')
159 if system_has_kms_drm
160 # TODO: PPC, Sparc
161 if ['x86', 'x86_64'].contains(host_machine.cpu_family())
162 dri_drivers = ['i915', 'i965', 'r100', 'r200', 'nouveau']
163 elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
164 dri_drivers = []
165 else
166 error('Unknown architecture @0@. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.'.format(
167 host_machine.cpu_family()))
168 endif
169 elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
170 # only swrast would make sense here, but gallium swrast is a much better default
171 dri_drivers = []
172 else
173 error('Unknown OS @0@. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.'.format(
174 host_machine.system()))
175 endif
176 endif
177
178 with_dri_i915 = dri_drivers.contains('i915')
179 with_dri_i965 = dri_drivers.contains('i965')
180 with_dri_r100 = dri_drivers.contains('r100')
181 with_dri_r200 = dri_drivers.contains('r200')
182 with_dri_nouveau = dri_drivers.contains('nouveau')
183 with_dri_swrast = dri_drivers.contains('swrast')
184
185 with_dri = dri_drivers.length() != 0
186
187 gallium_drivers = get_option('gallium-drivers')
188 if gallium_drivers.contains('auto')
189 if system_has_kms_drm
190 # TODO: PPC, Sparc
191 if ['x86', 'x86_64'].contains(host_machine.cpu_family())
192 gallium_drivers = [
193 'r300', 'r600', 'radeonsi', 'nouveau', 'virgl', 'svga', 'swrast',
194 'iris'
195 ]
196 elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
197 gallium_drivers = [
198 'kmsro', 'v3d', 'vc4', 'freedreno', 'etnaviv', 'nouveau',
199 'tegra', 'virgl', 'lima', 'panfrost', 'swrast'
200 ]
201 else
202 error('Unknown architecture @0@. Please pass -Dgallium-drivers to set driver options. Patches gladly accepted to fix this.'.format(
203 host_machine.cpu_family()))
204 endif
205 elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
206 gallium_drivers = ['swrast']
207 else
208 error('Unknown OS @0@. Please pass -Dgallium-drivers to set driver options. Patches gladly accepted to fix this.'.format(
209 host_machine.system()))
210 endif
211 endif
212 with_gallium_kmsro = gallium_drivers.contains('kmsro')
213 with_gallium_radeonsi = gallium_drivers.contains('radeonsi')
214 with_gallium_r300 = gallium_drivers.contains('r300')
215 with_gallium_r600 = gallium_drivers.contains('r600')
216 with_gallium_nouveau = gallium_drivers.contains('nouveau')
217 with_gallium_freedreno = gallium_drivers.contains('freedreno')
218 with_gallium_softpipe = gallium_drivers.contains('swrast')
219 with_gallium_vc4 = gallium_drivers.contains('vc4')
220 with_gallium_v3d = gallium_drivers.contains('v3d')
221 with_gallium_panfrost = gallium_drivers.contains('panfrost')
222 with_gallium_etnaviv = gallium_drivers.contains('etnaviv')
223 with_gallium_tegra = gallium_drivers.contains('tegra')
224 with_gallium_iris = gallium_drivers.contains('iris')
225 with_gallium_i915 = gallium_drivers.contains('i915')
226 with_gallium_svga = gallium_drivers.contains('svga')
227 with_gallium_virgl = gallium_drivers.contains('virgl')
228 with_gallium_swr = gallium_drivers.contains('swr')
229 with_gallium_lima = gallium_drivers.contains('lima')
230 with_gallium_zink = gallium_drivers.contains('zink')
231
232 with_gallium = gallium_drivers.length() != 0
233
234 if with_gallium and system_has_kms_drm
235 _glx = get_option('glx')
236 _egl = get_option('egl')
237 if _glx == 'dri' or _egl == 'enabled' or (_glx == 'disabled' and _egl != 'disabled')
238 with_dri = true
239 endif
240 endif
241
242 _vulkan_drivers = get_option('vulkan-drivers')
243 if _vulkan_drivers.contains('auto')
244 if system_has_kms_drm
245 if host_machine.cpu_family().startswith('x86')
246 _vulkan_drivers = ['amd', 'intel', 'swrast']
247 elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
248 _vulkan_drivers = ['swrast']
249 else
250 error('Unknown architecture @0@. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.'.format(
251 host_machine.cpu_family()))
252 endif
253 elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
254 # No vulkan driver supports windows or macOS currently
255 _vulkan_drivers = []
256 else
257 error('Unknown OS @0@. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.'.format(
258 host_machine.system()))
259 endif
260 endif
261
262 with_intel_vk = _vulkan_drivers.contains('intel')
263 with_amd_vk = _vulkan_drivers.contains('amd')
264 with_freedreno_vk = _vulkan_drivers.contains('freedreno')
265 with_swrast_vk = _vulkan_drivers.contains('swrast')
266 with_any_vk = _vulkan_drivers.length() != 0
267
268 if with_swrast_vk and not with_gallium_softpipe
269 error('swrast vulkan requires gallium swrast')
270 endif
271 if with_dri_swrast and (with_gallium_softpipe or with_gallium_swr)
272 error('Only one swrast provider can be built')
273 endif
274 if with_dri_i915 and with_gallium_i915
275 error('Only one i915 provider can be built')
276 endif
277 if with_gallium_kmsro and not (with_gallium_v3d or with_gallium_vc4 or with_gallium_etnaviv or with_gallium_freedreno or with_gallium_panfrost or with_gallium_lima)
278 error('kmsro driver requires one or more renderonly drivers (vc4, etnaviv, freedreno, panfrost, lima)')
279 endif
280 if with_gallium_tegra and not with_gallium_nouveau
281 error('tegra driver requires nouveau driver')
282 endif
283 if with_aco_tests and not with_amd_vk
284 error('ACO tests require Radv')
285 endif
286
287 if host_machine.system() == 'darwin'
288 with_dri_platform = 'apple'
289 pre_args += '-DBUILDING_MESA'
290 elif ['windows', 'cygwin'].contains(host_machine.system())
291 with_dri_platform = 'windows'
292 elif system_has_kms_drm
293 with_dri_platform = 'drm'
294 else
295 # FIXME: haiku doesn't use dri, and xlib doesn't use dri, probably should
296 # assert here that one of those cases has been met.
297 # FIXME: illumos ends up here as well
298 with_dri_platform = 'none'
299 endif
300
301 _platforms = get_option('platforms')
302 if _platforms.contains('auto')
303 if system_has_kms_drm
304 _platforms = ['x11', 'wayland']
305 elif ['darwin', 'cygwin'].contains(host_machine.system())
306 _platforms = ['x11']
307 elif ['haiku'].contains(host_machine.system())
308 _platforms = ['haiku']
309 elif host_machine.system() == 'windows'
310 _platforms = ['windows']
311 else
312 error('Unknown OS @0@. Please pass -Dplatforms to set platforms. Patches gladly accepted to fix this.'.format(
313 host_machine.system()))
314 endif
315 endif
316
317 with_platform_android = _platforms.contains('android')
318 with_platform_x11 = _platforms.contains('x11')
319 with_platform_wayland = _platforms.contains('wayland')
320 with_platform_haiku = _platforms.contains('haiku')
321 with_platform_windows = _platforms.contains('windows')
322
323 if _platforms.contains('surfaceless')
324 warning('Platform `surfaceless` is now always selected; setting this option will be an error in Mesa 20.3')
325 endif
326
327 if _platforms.contains('drm')
328 warning('Platform `drm` is now automatically selected; setting this option will be an error in Mesa 20.3')
329 endif
330
331 if _platforms.length() != 0
332 egl_native_platform = _platforms[0]
333 else
334 egl_native_platform = 'surfaceless'
335 endif
336
337 with_glx = get_option('glx')
338 if with_glx == 'auto'
339 if with_dri
340 with_glx = 'dri'
341 elif with_platform_haiku
342 with_glx = 'disabled'
343 elif host_machine.system() == 'windows'
344 with_glx = 'disabled'
345 elif with_gallium
346 # Even when building just gallium drivers the user probably wants dri
347 with_glx = 'dri'
348 elif with_platform_x11 and with_any_opengl and not with_any_vk
349 # The automatic behavior should not be to turn on xlib based glx when
350 # building only vulkan drivers
351 with_glx = 'xlib'
352 else
353 with_glx = 'disabled'
354 endif
355 endif
356 if with_glx == 'dri'
357 if with_gallium
358 with_dri = true
359 endif
360 endif
361
362 if not (with_dri or with_gallium or with_glx != 'disabled')
363 with_gles1 = false
364 with_gles2 = false
365 with_opengl = false
366 with_any_opengl = false
367 with_shared_glapi = false
368 endif
369
370 _gbm = get_option('gbm')
371 if _gbm == 'true'
372 _gbm = 'enabled'
373 warning('gbm option "true" deprecated, please use "enabled" instead.')
374 elif _gbm == 'false'
375 _gbm = 'disabled'
376 warning('gbm option "false" deprecated, please use "disabled" instead.')
377 endif
378 if _gbm == 'auto'
379 with_gbm = system_has_kms_drm and with_dri
380 else
381 with_gbm = _gbm == 'enabled'
382 endif
383 if with_gbm and not system_has_kms_drm
384 error('GBM only supports DRM/KMS platforms')
385 endif
386
387 _xlib_lease = get_option('xlib-lease')
388 if _xlib_lease == 'true'
389 _xlib_lease = 'enabled'
390 warning('xlib_lease option "true" deprecated, please use "enabled" instead.')
391 elif _xlib_lease == 'false'
392 _xlib_lease = 'disabled'
393 warning('xlib_lease option "false" deprecated, please use "disabled" instead.')
394 endif
395 if _xlib_lease == 'auto'
396 with_xlib_lease = with_platform_x11 and system_has_kms_drm
397 else
398 with_xlib_lease = _xlib_lease == 'enabled'
399 endif
400
401 _egl = get_option('egl')
402 if _egl == 'true'
403 _egl = 'enabled'
404 warning('egl option "true" deprecated, please use "enabled" instead.')
405 elif _egl == 'false'
406 _egl = 'disabled'
407 warning('egl option "false" deprecated, please use "disabled" instead.')
408 endif
409 if _egl == 'auto'
410 with_egl = (
411 not ['darwin', 'windows'].contains(host_machine.system()) and
412 with_dri and with_shared_glapi
413 )
414 elif _egl == 'enabled'
415 if not with_dri
416 error('EGL requires dri')
417 elif not with_shared_glapi
418 error('EGL requires shared-glapi')
419 elif not ['disabled', 'dri'].contains(with_glx)
420 error('EGL requires dri, but a GLX is being built without dri')
421 elif ['darwin', 'windows'].contains(host_machine.system())
422 error('EGL is not available on Windows or MacOS')
423 endif
424 with_egl = true
425 else
426 with_egl = false
427 endif
428
429 # Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
430 if not ['windows', 'freebsd'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
431 pre_args += '-DUSE_ELF_TLS'
432 endif
433
434 if with_glx != 'disabled'
435 if not (with_platform_x11 and with_any_opengl)
436 error('Cannot build GLX support without X11 platform support and at least one OpenGL API')
437 elif with_glx == 'gallium-xlib'
438 if not with_gallium
439 error('Gallium-xlib based GLX requires at least one gallium driver')
440 elif not with_gallium_softpipe
441 error('Gallium-xlib based GLX requires softpipe or llvmpipe.')
442 elif with_dri
443 error('gallium-xlib conflicts with any dri driver')
444 endif
445 elif with_glx == 'xlib'
446 if with_dri
447 error('xlib conflicts with any dri driver')
448 endif
449 elif with_glx == 'dri'
450 if not with_shared_glapi
451 error('dri based GLX requires shared-glapi')
452 endif
453 endif
454 endif
455
456 with_glvnd = get_option('glvnd')
457 if with_glvnd
458 if with_platform_windows
459 error('glvnd cannot be used on Windows')
460 elif with_glx == 'xlib' or with_glx == 'gallium-xlib'
461 error('Cannot build glvnd support for GLX that is not DRI based.')
462 elif with_glx == 'disabled' and not with_egl
463 error('glvnd requires DRI based GLX and/or EGL')
464 endif
465 if get_option('egl-lib-suffix') != ''
466 error('''EGL lib suffix can't be used with libglvnd''')
467 endif
468 endif
469
470 if with_vulkan_icd_dir == ''
471 with_vulkan_icd_dir = join_paths(get_option('datadir'), 'vulkan/icd.d')
472 endif
473
474 # GNU/Hurd includes egl_dri2, without drm.
475 with_dri2 = (with_dri or with_any_vk) and (with_dri_platform == 'drm' or
476 host_machine.system() == 'gnu')
477 _dri3 = get_option('dri3')
478 if _dri3 == 'true'
479 _dri3 = 'enabled'
480 warning('dri3 option "true" deprecated, please use "enabled" instead.')
481 elif _dri3 == 'false'
482 _dri3 = 'disabled'
483 warning('dri3 option "false" deprecated, please use "disabled" instead.')
484 endif
485 if _dri3 == 'auto'
486 with_dri3 = system_has_kms_drm and with_dri2
487 else
488 with_dri3 = _dri3 == 'enabled'
489 endif
490
491 if with_any_vk and (with_platform_x11 and not with_dri3)
492 error('Vulkan drivers require dri3 for X11 support')
493 endif
494 if with_dri
495 if with_glx == 'disabled' and not with_egl and not with_gbm and with_osmesa != 'classic'
496 error('building dri drivers require at least one windowing system or classic osmesa')
497 endif
498 endif
499
500 _vdpau = get_option('gallium-vdpau')
501 if _vdpau == 'true'
502 _vdpau = 'enabled'
503 warning('gallium-vdpau option "true" deprecated, please use "enabled" instead.')
504 elif _vdpau == 'false'
505 _vdpau = 'disabled'
506 warning('gallium-vdpau option "false" deprecated, please use "disabled" instead.')
507 endif
508 if not system_has_kms_drm
509 if _vdpau == 'enabled'
510 error('VDPAU state tracker can only be build on unix-like OSes.')
511 else
512 _vdpau = 'disabled'
513 endif
514 elif not with_platform_x11
515 if _vdpau == 'enabled'
516 error('VDPAU state tracker requires X11 support.')
517 else
518 _vdpau = 'disabled'
519 endif
520 elif not (with_gallium_r300 or with_gallium_r600 or with_gallium_radeonsi or
521 with_gallium_nouveau)
522 if _vdpau == 'enabled'
523 error('VDPAU state tracker requires at least one of the following gallium drivers: r300, r600, radeonsi, nouveau.')
524 else
525 _vdpau = 'disabled'
526 endif
527 endif
528 dep_vdpau = null_dep
529 with_gallium_vdpau = false
530 if _vdpau != 'disabled'
531 dep_vdpau = dependency('vdpau', version : '>= 1.1', required : _vdpau == 'enabled')
532 if dep_vdpau.found()
533 dep_vdpau = dep_vdpau.partial_dependency(compile_args : true)
534 with_gallium_vdpau = true
535 endif
536 endif
537
538 if with_gallium_vdpau
539 pre_args += '-DHAVE_ST_VDPAU'
540 endif
541 vdpau_drivers_path = get_option('vdpau-libs-path')
542 if vdpau_drivers_path == ''
543 vdpau_drivers_path = join_paths(get_option('libdir'), 'vdpau')
544 endif
545
546 if with_gallium_zink
547 dep_vulkan = dependency('vulkan')
548 endif
549
550 if with_vulkan_overlay_layer or with_aco_tests
551 prog_glslang = find_program('glslangValidator')
552 endif
553
554 _xvmc = get_option('gallium-xvmc')
555 if _xvmc == 'true'
556 _xvmc = 'enabled'
557 warning('gallium-xvmc option "true" deprecated, please use "enabled" instead.')
558 elif _xvmc == 'false'
559 _xvmc = 'disabled'
560 warning('gallium-xvmc option "false" deprecated, please use "disabled" instead.')
561 endif
562 if not system_has_kms_drm
563 if _xvmc == 'enabled'
564 error('XVMC state tracker can only be build on unix-like OSes.')
565 else
566 _xvmc = 'disabled'
567 endif
568 elif not with_platform_x11
569 if _xvmc == 'enabled'
570 error('XVMC state tracker requires X11 support.')
571 else
572 _xvmc = 'disabled'
573 endif
574 elif not (with_gallium_r600 or with_gallium_nouveau)
575 if _xvmc == 'enabled'
576 error('XVMC state tracker requires at least one of the following gallium drivers: r600, nouveau.')
577 else
578 _xvmc = 'disabled'
579 endif
580 endif
581 dep_xvmc = null_dep
582 dep_xv = null_dep
583 with_gallium_xvmc = false
584 if _xvmc != 'disabled'
585 dep_xvmc = dependency('xvmc', version : '>= 1.0.6', required : _xvmc == 'enabled')
586 dep_xv = dependency('xv', required : _xvmc == 'enabled')
587 with_gallium_xvmc = dep_xvmc.found() and dep_xv.found()
588 endif
589
590 xvmc_drivers_path = get_option('xvmc-libs-path')
591 if xvmc_drivers_path == ''
592 xvmc_drivers_path = get_option('libdir')
593 endif
594
595 _omx = get_option('gallium-omx')
596 if not system_has_kms_drm
597 if ['auto', 'disabled'].contains(_omx)
598 _omx = 'disabled'
599 else
600 error('OMX state tracker can only be built on unix-like OSes.')
601 endif
602 elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
603 if ['auto', 'disabled'].contains(_omx)
604 _omx = 'disabled'
605 else
606 error('OMX state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau.')
607 endif
608 endif
609 with_gallium_omx = _omx
610 dep_omx = null_dep
611 dep_omx_other = []
612 if ['auto', 'bellagio'].contains(_omx)
613 dep_omx = dependency(
614 'libomxil-bellagio', required : _omx == 'bellagio'
615 )
616 if dep_omx.found()
617 with_gallium_omx = 'bellagio'
618 endif
619 endif
620 if ['auto', 'tizonia'].contains(_omx)
621 if with_dri and with_egl
622 dep_omx = dependency(
623 'libtizonia', version : '>= 0.10.0',
624 required : _omx == 'tizonia',
625 )
626 dep_omx_other = [
627 dependency('libtizplatform', required : _omx == 'tizonia'),
628 dependency('tizilheaders', required : _omx == 'tizonia'),
629 ]
630 if dep_omx.found() and dep_omx_other[0].found() and dep_omx_other[1].found()
631 with_gallium_omx = 'tizonia'
632 endif
633 elif _omx == 'tizonia'
634 error('OMX-Tizonia state tracker requires dri and egl')
635 endif
636 endif
637 if _omx == 'auto'
638 with_gallium_omx = 'disabled'
639 else
640 with_gallium_omx = _omx
641 endif
642
643 pre_args += [
644 '-DENABLE_ST_OMX_BELLAGIO=' + (with_gallium_omx == 'bellagio' ? '1' : '0'),
645 '-DENABLE_ST_OMX_TIZONIA=' + (with_gallium_omx == 'tizonia' ? '1' : '0'),
646 ]
647
648
649 omx_drivers_path = get_option('omx-libs-path')
650
651 if with_gallium_omx != 'disabled'
652 # Figure out where to put the omx driver.
653 # FIXME: this could all be vastly simplified by adding a 'defined_variable'
654 # argument to meson's get_pkgconfig_variable method.
655 if omx_drivers_path == ''
656 _omx_libdir = dep_omx.get_pkgconfig_variable('libdir')
657 _omx_drivers_dir = dep_omx.get_pkgconfig_variable('pluginsdir')
658 if _omx_libdir == get_option('libdir')
659 omx_drivers_path = _omx_drivers_dir
660 else
661 _omx_base_dir = []
662 # This will fail on windows. Does OMX run on windows?
663 _omx_libdir = _omx_libdir.split('/')
664 _omx_drivers_dir = _omx_drivers_dir.split('/')
665 foreach o : _omx_drivers_dir
666 if not _omx_libdir.contains(o)
667 _omx_base_dir += o
668 endif
669 endforeach
670 omx_drivers_path = join_paths(get_option('libdir'), _omx_base_dir)
671 endif
672 endif
673 endif
674
675 _va = get_option('gallium-va')
676 if _va == 'true'
677 _va = 'enabled'
678 warning('gallium-va option "true" deprecated, please use "enabled" instead.')
679 elif _va == 'false'
680 _va = 'disabled'
681 warning('gallium-va option "false" deprecated, please use "disabled" instead.')
682 endif
683 if not system_has_kms_drm
684 if _va == 'enabled'
685 error('VA state tracker can only be built on unix-like OSes.')
686 else
687 _va = 'disabled'
688 endif
689 elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
690 if _va == 'enabled'
691 error('VA state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau.')
692 else
693 _va = 'disabled'
694 endif
695 endif
696 with_gallium_va = false
697 dep_va = null_dep
698 if _va != 'disabled'
699 dep_va = dependency('libva', version : '>= 0.38.0', required : _va == 'enabled')
700 if dep_va.found()
701 dep_va_headers = dep_va.partial_dependency(compile_args : true)
702 with_gallium_va = true
703 endif
704 endif
705
706 va_drivers_path = get_option('va-libs-path')
707 if va_drivers_path == ''
708 va_drivers_path = join_paths(get_option('libdir'), 'dri')
709 endif
710
711 _xa = get_option('gallium-xa')
712 if _xa == 'true'
713 _xa = 'enabled'
714 warning('gallium-xa option "true" deprecated, please use "enabled" instead.')
715 elif _xa == 'false'
716 _xa = 'disabled'
717 warning('gallium-xa option "false" deprecated, please use "disabled" instead.')
718 endif
719 if not system_has_kms_drm
720 if _xa == 'enabled'
721 error('XA state tracker can only be built on unix-like OSes.')
722 else
723 _xa = 'disabled'
724 endif
725 elif not (with_gallium_nouveau or with_gallium_freedreno or with_gallium_i915
726 or with_gallium_svga)
727 if _xa == 'enabled'
728 error('XA state tracker requires at least one of the following gallium drivers: nouveau, freedreno, i915, svga.')
729 else
730 _xa = 'disabled'
731 endif
732 endif
733 with_gallium_xa = _xa != 'disabled'
734
735 d3d_drivers_path = get_option('d3d-drivers-path')
736 if d3d_drivers_path == ''
737 d3d_drivers_path = join_paths(get_option('prefix'), get_option('libdir'), 'd3d')
738 endif
739
740 with_gallium_st_nine = get_option('gallium-nine')
741 if with_gallium_st_nine
742 if not with_gallium_softpipe
743 error('The nine state tracker requires gallium softpipe/llvmpipe.')
744 elif not (with_gallium_radeonsi or with_gallium_nouveau or with_gallium_r600
745 or with_gallium_r300 or with_gallium_svga or with_gallium_i915
746 or with_gallium_iris)
747 error('The nine state tracker requires at least one non-swrast gallium driver.')
748 endif
749 if not with_dri3
750 error('Using nine with wine requires dri3')
751 endif
752 endif
753 _power8 = get_option('power8')
754 if _power8 == 'true'
755 _power8 = 'enabled'
756 warning('power8 option "true" deprecated, please use "enabled" instead.')
757 elif _power8 == 'disabled'
758 _power8 = 'disabled'
759 warning('power8 option "false" deprecated, please use "disabled" instead.')
760 endif
761 if _power8 != 'disabled'
762 # on old versions of meson the cpu family would return as ppc64le on little
763 # endian power8, this was changed in 0.48 such that the family would always
764 # be ppc64 regardless of endianness, and then the machine.endian() value
765 # should be checked. Since we support versions < 0.48 we need to use
766 # startswith.
767 if host_machine.cpu_family().startswith('ppc64') and host_machine.endian() == 'little'
768 if cc.get_id() == 'gcc' and cc.version().version_compare('< 4.8')
769 error('Altivec is not supported with gcc version < 4.8.')
770 endif
771 if cc.compiles('''
772 #include <altivec.h>
773 int main() {
774 vector unsigned char r;
775 vector unsigned int v = vec_splat_u32 (1);
776 r = __builtin_vec_vgbbd ((vector unsigned char) v);
777 return 0;
778 }''',
779 args : '-mpower8-vector',
780 name : 'POWER8 intrinsics')
781 pre_args += ['-D_ARCH_PWR8', '-mpower8-vector']
782 elif get_option('power8') == 'enabled'
783 error('POWER8 intrinsic support required but not found.')
784 endif
785 endif
786 endif
787
788 _opencl = get_option('gallium-opencl')
789 if _opencl != 'disabled'
790 if not with_gallium
791 error('OpenCL Clover implementation requires at least one gallium driver.')
792 endif
793
794 dep_clc = dependency('libclc')
795 with_gallium_opencl = true
796 with_opencl_icd = _opencl == 'icd'
797 else
798 dep_clc = null_dep
799 with_gallium_opencl = false
800 with_opencl_icd = false
801 endif
802
803 gl_pkgconfig_c_flags = []
804 if with_platform_x11
805 if with_any_vk or with_egl or (with_glx == 'dri' and with_dri_platform == 'drm')
806 pre_args += '-DHAVE_X11_PLATFORM'
807 endif
808 if with_glx == 'xlib' or with_glx == 'gallium-xlib'
809 pre_args += '-DUSE_XSHM'
810 else
811 pre_args += '-DGLX_INDIRECT_RENDERING'
812 if with_glx_direct
813 pre_args += '-DGLX_DIRECT_RENDERING'
814 endif
815 if with_dri_platform == 'drm'
816 pre_args += '-DGLX_USE_DRM'
817 elif with_dri_platform == 'apple'
818 pre_args += '-DGLX_USE_APPLEGL'
819 elif with_dri_platform == 'windows'
820 pre_args += '-DGLX_USE_WINDOWSGL'
821 endif
822 endif
823 else
824 pre_args += '-DEGL_NO_X11'
825 gl_pkgconfig_c_flags += '-DEGL_NO_X11'
826 endif
827 if with_gbm
828 pre_args += '-DHAVE_DRM_PLATFORM'
829 endif
830
831 with_android_stub = get_option('android-stub')
832 if with_android_stub and not with_platform_android
833 error('`-D android-stub=true` makes no sense without `-D platforms=android`')
834 endif
835
836 if with_platform_android
837 if not with_android_stub
838 dep_android = [
839 dependency('cutils'),
840 dependency('hardware'),
841 dependency('sync'),
842 dependency('backtrace')
843 ]
844 if get_option('platform-sdk-version') >= 26
845 dep_android += dependency('nativewindow')
846 endif
847 endif
848 pre_args += [
849 '-DHAVE_ANDROID_PLATFORM',
850 '-DANDROID',
851 '-DANDROID_API_LEVEL=' + get_option('platform-sdk-version').to_string()
852 ]
853 endif
854 if with_platform_haiku
855 pre_args += '-DHAVE_HAIKU_PLATFORM'
856 endif
857
858 prog_python = import('python').find_installation('python3')
859 has_mako = run_command(
860 prog_python, '-c',
861 '''
862 from distutils.version import StrictVersion
863 import mako
864 assert StrictVersion(mako.__version__) > StrictVersion("0.8.0")
865 ''')
866 if has_mako.returncode() != 0
867 error('Python (3.x) mako module >= 0.8.0 required to build mesa.')
868 endif
869
870 if cc.get_id() == 'gcc' and cc.version().version_compare('< 4.4.6')
871 error('When using GCC, version 4.4.6 or later is required.')
872 endif
873
874 # Support systems without ETIME (e.g. FreeBSD)
875 if cc.get_define('ETIME', prefix : '#include <errno.h>') == ''
876 pre_args += '-DETIME=ETIMEDOUT'
877 endif
878
879 # Define DEBUG for debug builds only (debugoptimized is not included on this one)
880 if get_option('buildtype') == 'debug'
881 pre_args += '-DDEBUG'
882 endif
883
884 with_shader_cache = false
885 _shader_cache = get_option('shader-cache')
886 if _shader_cache == 'true'
887 _shader_cache = 'enabled'
888 warning('shader_cache option "true" deprecated, please use "enabled" instead.')
889 elif _shader_cache == 'false'
890 _shader_cache = 'disabled'
891 warning('shader_cache option "false" deprecated, please use "disabled" instead.')
892 endif
893 if _shader_cache != 'disabled'
894 if host_machine.system() == 'windows'
895 if _shader_cache == 'enabled'
896 error('Shader Cache does not currently work on Windows')
897 endif
898 else
899 pre_args += '-DENABLE_SHADER_CACHE'
900 with_shader_cache = true
901 endif
902 endif
903
904 # Check for GCC style builtins
905 foreach b : ['bswap32', 'bswap64', 'clz', 'clzll', 'ctz', 'expect', 'ffs',
906 'ffsll', 'popcount', 'popcountll', 'unreachable']
907 if cc.has_function(b)
908 pre_args += '-DHAVE___BUILTIN_@0@'.format(b.to_upper())
909 endif
910 endforeach
911
912 # check for GCC __attribute__
913 _attributes = [
914 'const', 'flatten', 'malloc', 'pure', 'unused', 'warn_unused_result',
915 'weak', 'format', 'packed', 'returns_nonnull', 'alias', 'noreturn',
916 ]
917 foreach a : cc.get_supported_function_attributes(_attributes)
918 pre_args += '-DHAVE_FUNC_ATTRIBUTE_@0@'.format(a.to_upper())
919 endforeach
920 if cc.has_function_attribute('visibility:hidden')
921 pre_args += '-DHAVE_FUNC_ATTRIBUTE_VISIBILITY'
922 endif
923 if cc.compiles('__uint128_t foo(void) { return 0; }',
924 name : '__uint128_t')
925 pre_args += '-DHAVE_UINT128'
926 endif
927
928 # TODO: this is very incomplete
929 if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd'].contains(host_machine.system())
930 pre_args += '-D_GNU_SOURCE'
931 elif host_machine.system() == 'sunos'
932 pre_args += '-D__EXTENSIONS__'
933 elif host_machine.system() == 'windows'
934 pre_args += [
935 '-D_WINDOWS', '-D_WIN32_WINNT=0x0A00', '-DWINVER=0x0A00',
936 '-DPIPE_SUBSYSTEM_WINDOWS_USER',
937 '-D_USE_MATH_DEFINES', # XXX: scons doesn't use this for mingw
938 ]
939 if cc.get_id() == 'msvc'
940 pre_args += [
941 '-DVC_EXTRALEAN',
942 '-D_CRT_SECURE_NO_WARNINGS',
943 '-D_CRT_SECURE_NO_DEPRECATE',
944 '-D_SCL_SECURE_NO_WARNINGS',
945 '-D_SCL_SECURE_NO_DEPRECATE',
946 '-D_ALLOW_KEYWORD_MACROS',
947 '-D_HAS_EXCEPTIONS=0', # Tell C++ STL to not use exceptions
948 ]
949 else
950 pre_args += ['-D__MSVCRT_VERSION__=0x0700']
951 endif
952 endif
953
954 # Check for generic C arguments
955 c_args = []
956 c_msvc_compat_args = []
957 no_override_init_args = []
958 cpp_args = []
959 cpp_msvc_compat_args = []
960 if cc.get_id() == 'msvc'
961 foreach a : ['/wd4018', # signed/unsigned mismatch
962 '/wd4056', # overflow in floating-point constant arithmetic
963 '/wd4244', # conversion from 'type1' to 'type2', possible loss of data
964 '/wd4267', # 'var' : conversion from 'size_t' to 'type', possible loss of data
965 '/wd4305', # trancation from 'type1' to 'type2'
966 '/wd4351', # new behavior: elements of array 'array' will be default initialized
967 '/wd4756', # overflow in constant arithmetic
968 '/wd4800', # forcing value to bool 'true' or 'false' (performance warning)
969 '/wd4996', # disabled deprecated POSIX name warnings
970 '/wd4291', # no matching operator delete found
971 '/wd4146', # unary minus operator applied to unsigned type, result still unsigned
972 '/wd4200', # nonstandard extension used: zero-sized array in struct/union
973 '/wd4624', # destructor was implicitly defined as deleted [from LLVM]
974 '/wd4309', # 'initializing': truncation of constant value
975 '/wd4838', # conversion from 'int' to 'const char' requires a narrowing conversion
976 '/we4020', # Error when passing the wrong number of parameters
977 '/we4024', # Error when passing different type of parameter
978 ]
979 if cc.has_argument(a)
980 c_args += a
981 endif
982 if cpp.has_argument(a)
983 cpp_args += a
984 endif
985 endforeach
986 if cc.has_argument('-Wmicrosoft-enum-value') # Clang
987 c_args += '-Wno-microsoft-enum-value'
988 cpp_args += '-Wno-microsoft-enum-value'
989 endif
990 else
991 _trial = [
992 '-Werror=implicit-function-declaration',
993 '-Werror=missing-prototypes',
994 '-Werror=return-type',
995 '-Werror=empty-body',
996 '-Werror=incompatible-pointer-types',
997 '-Werror=int-conversion',
998 '-Wimplicit-fallthrough',
999 '-Wno-missing-field-initializers',
1000 '-Wno-format-truncation',
1001 '-fno-math-errno',
1002 '-fno-trapping-math',
1003 '-Qunused-arguments',
1004 '-fno-common',
1005 ]
1006 # MinGW chokes on format specifiers and I can't get it all working
1007 if not (cc.get_id() == 'gcc' and host_machine.system() == 'windows')
1008 _trial += ['-Werror=format', '-Wformat-security']
1009 endif
1010 foreach a : _trial
1011 if cc.has_argument(a)
1012 c_args += a
1013 endif
1014 endforeach
1015
1016 _trial = [
1017 '-Werror=return-type',
1018 '-Werror=empty-body',
1019 '-Wno-non-virtual-dtor',
1020 '-Wno-missing-field-initializers',
1021 '-Wno-format-truncation',
1022 '-fno-math-errno',
1023 '-fno-trapping-math',
1024 '-Qunused-arguments',
1025 # Some classes use custom new operator which zeroes memory, however
1026 # gcc does aggressive dead-store elimination which threats all writes
1027 # to the memory before the constructor as "dead stores".
1028 # For now we disable this optimization.
1029 '-flifetime-dse=1',
1030 ]
1031 # MinGW chokes on format specifiers and I can't get it all working
1032 if not (cc.get_id() == 'gcc' and host_machine.system() == 'windows')
1033 _trial += ['-Werror=format', '-Wformat-security']
1034 endif
1035 foreach a : _trial
1036 if cpp.has_argument(a)
1037 cpp_args += a
1038 endif
1039 endforeach
1040
1041 foreach a : ['-Wno-override-init', '-Wno-initializer-overrides']
1042 if cc.has_argument(a)
1043 no_override_init_args += a
1044 endif
1045 endforeach
1046
1047 # Check for C and C++ arguments for MSVC compatibility. These are only used
1048 # in parts of the mesa code base that need to compile with MSVC, mainly
1049 # common code
1050 foreach a : ['-Werror=pointer-arith', '-Werror=vla', '-Werror=gnu-empty-initializer']
1051 if cc.has_argument(a)
1052 c_msvc_compat_args += a
1053 endif
1054 if cpp.has_argument(a)
1055 cpp_msvc_compat_args += a
1056 endif
1057 endforeach
1058 endif
1059
1060 # set linker arguments
1061 if host_machine.system() == 'windows'
1062 if cc.get_id() == 'msvc'
1063 add_project_link_arguments(
1064 '/fixed:no',
1065 '/dynamicbase',
1066 '/nxcompat',
1067 language : ['c', 'cpp'],
1068 )
1069 if get_option('buildtype') != 'debug'
1070 add_project_link_arguments(
1071 '/incremental:no',
1072 language : ['c', 'cpp'],
1073 )
1074 endif
1075 else
1076 add_project_link_arguments(
1077 '-Wl,--nxcompat',
1078 '-Wl,--dynamicbase',
1079 '-static-libgcc',
1080 '-static-libstdc++',
1081 language : ['c', 'cpp'],
1082 )
1083 endif
1084 endif
1085
1086 if host_machine.cpu_family().startswith('x86') and cc.get_id() != 'msvc'
1087 pre_args += '-DUSE_SSE41'
1088 with_sse41 = true
1089 sse41_args = ['-msse4.1']
1090
1091 # GCC on x86 (not x86_64) with -msse* assumes a 16 byte aligned stack, but
1092 # that's not guaranteed
1093 if host_machine.cpu_family() == 'x86'
1094 sse41_args += '-mstackrealign'
1095 endif
1096 else
1097 with_sse41 = false
1098 sse41_args = []
1099 endif
1100
1101 # Check for GCC style atomics
1102 dep_atomic = null_dep
1103
1104 if cc.compiles('''#include <stdint.h>
1105 int main() {
1106 struct {
1107 uint64_t *v;
1108 } x;
1109 return (int)__atomic_load_n(x.v, __ATOMIC_ACQUIRE) &
1110 (int)__atomic_add_fetch(x.v, (uint64_t)1, __ATOMIC_ACQ_REL);
1111
1112 }''',
1113 name : 'GCC atomic builtins')
1114 pre_args += '-DUSE_GCC_ATOMIC_BUILTINS'
1115
1116 # Not all atomic calls can be turned into lock-free instructions, in which
1117 # GCC will make calls into the libatomic library. Check whether we need to
1118 # link with -latomic.
1119 #
1120 # This can happen for 64-bit atomic operations on 32-bit architectures such
1121 # as ARM.
1122 if not cc.links('''#include <stdint.h>
1123 int main() {
1124 struct {
1125 uint64_t *v;
1126 } x;
1127 return (int)__atomic_load_n(x.v, __ATOMIC_ACQUIRE) &
1128 (int)__atomic_add_fetch(x.v, (uint64_t)1, __ATOMIC_ACQ_REL);
1129 }''',
1130 name : 'GCC atomic builtins required -latomic')
1131 dep_atomic = cc.find_library('atomic')
1132 endif
1133 endif
1134 if not cc.links('''#include <stdint.h>
1135 uint64_t v;
1136 int main() {
1137 return __sync_add_and_fetch(&v, (uint64_t)1);
1138 }''',
1139 dependencies : dep_atomic,
1140 name : 'GCC 64bit atomics')
1141 pre_args += '-DMISSING_64BIT_ATOMICS'
1142 endif
1143
1144 dep_ws2_32 = cc.find_library('ws2_32', required : with_platform_windows)
1145
1146 # TODO: shared/static? Is this even worth doing?
1147
1148 with_asm_arch = ''
1149 if host_machine.cpu_family() == 'x86'
1150 if system_has_kms_drm or host_machine.system() == 'gnu'
1151 with_asm_arch = 'x86'
1152 pre_args += ['-DUSE_X86_ASM', '-DUSE_MMX_ASM', '-DUSE_3DNOW_ASM',
1153 '-DUSE_SSE_ASM']
1154
1155 if with_glx_read_only_text
1156 pre_args += ['-DGLX_X86_READONLY_TEXT']
1157 endif
1158 endif
1159 elif host_machine.cpu_family() == 'x86_64'
1160 if system_has_kms_drm
1161 with_asm_arch = 'x86_64'
1162 pre_args += ['-DUSE_X86_64_ASM']
1163 endif
1164 elif host_machine.cpu_family() == 'arm'
1165 if system_has_kms_drm
1166 with_asm_arch = 'arm'
1167 pre_args += ['-DUSE_ARM_ASM']
1168 endif
1169 elif host_machine.cpu_family() == 'aarch64'
1170 if system_has_kms_drm
1171 with_asm_arch = 'aarch64'
1172 pre_args += ['-DUSE_AARCH64_ASM']
1173 endif
1174 elif host_machine.cpu_family() == 'sparc64'
1175 if system_has_kms_drm
1176 with_asm_arch = 'sparc'
1177 pre_args += ['-DUSE_SPARC_ASM']
1178 endif
1179 elif host_machine.cpu_family().startswith('ppc64') and host_machine.endian() == 'little'
1180 if system_has_kms_drm
1181 with_asm_arch = 'ppc64le'
1182 pre_args += ['-DUSE_PPC64LE_ASM']
1183 endif
1184 endif
1185
1186 # Check for standard headers and functions
1187 if (cc.has_header_symbol('sys/sysmacros.h', 'major') and
1188 cc.has_header_symbol('sys/sysmacros.h', 'minor') and
1189 cc.has_header_symbol('sys/sysmacros.h', 'makedev'))
1190 pre_args += '-DMAJOR_IN_SYSMACROS'
1191 endif
1192 if (cc.has_header_symbol('sys/mkdev.h', 'major') and
1193 cc.has_header_symbol('sys/mkdev.h', 'minor') and
1194 cc.has_header_symbol('sys/mkdev.h', 'makedev'))
1195 pre_args += '-DMAJOR_IN_MKDEV'
1196 endif
1197
1198 if not ['linux'].contains(host_machine.system())
1199 # Deprecated on Linux and requires <sys/types.h> on FreeBSD and OpenBSD
1200 if cc.check_header('sys/sysctl.h', prefix : '#include <sys/types.h>')
1201 pre_args += '-DHAVE_SYS_SYSCTL_H'
1202 endif
1203 endif
1204
1205 foreach h : ['xlocale.h', 'linux/futex.h', 'endian.h', 'dlfcn.h', 'execinfo.h', 'sys/shm.h', 'cet.h']
1206 if cc.check_header(h)
1207 pre_args += '-DHAVE_@0@'.format(h.to_upper().underscorify())
1208 endif
1209 endforeach
1210
1211 foreach f : ['strtof', 'mkostemp', 'timespec_get', 'memfd_create', 'random_r', 'flock', 'strtok_r', 'getrandom']
1212 if cc.has_function(f)
1213 pre_args += '-DHAVE_@0@'.format(f.to_upper())
1214 endif
1215 endforeach
1216
1217 if cc.has_header_symbol('errno.h', 'program_invocation_name',
1218 args : '-D_GNU_SOURCE')
1219 pre_args += '-DHAVE_PROGRAM_INVOCATION_NAME'
1220 elif with_tools.contains('intel')
1221 error('Intel tools require the program_invocation_name variable')
1222 endif
1223
1224 # MinGW provides a __builtin_posix_memalign function, but not a posix_memalign.
1225 # This means that this check will succeed, but then compilation will later
1226 # fail. MSVC doesn't have this function at all, so only check for it on
1227 # non-windows platforms.
1228 if host_machine.system() != 'windows'
1229 if cc.has_function('posix_memalign')
1230 pre_args += '-DHAVE_POSIX_MEMALIGN'
1231 endif
1232 endif
1233
1234 if cc.has_member('struct dirent', 'd_type', prefix: '''#include <sys/types.h>
1235 #include <dirent.h>''')
1236 pre_args += '-DHAVE_DIRENT_D_TYPE'
1237 endif
1238
1239 # strtod locale support
1240 if cc.links('''
1241 #define _GNU_SOURCE
1242 #include <stdlib.h>
1243 #include <locale.h>
1244 #ifdef HAVE_XLOCALE_H
1245 #include <xlocale.h>
1246 #endif
1247 int main() {
1248 locale_t loc = newlocale(LC_CTYPE_MASK, "C", NULL);
1249 const char *s = "1.0";
1250 char *end;
1251 double d = strtod_l(s, end, loc);
1252 float f = strtof_l(s, end, loc);
1253 freelocale(loc);
1254 return 0;
1255 }''',
1256 args : pre_args,
1257 name : 'strtod has locale support')
1258 pre_args += '-DHAVE_STRTOD_L'
1259 endif
1260
1261 # Check for some linker flags
1262 ld_args_bsymbolic = []
1263 if cc.links('int main() { return 0; }', args : '-Wl,-Bsymbolic', name : 'Bsymbolic')
1264 ld_args_bsymbolic += '-Wl,-Bsymbolic'
1265 endif
1266 ld_args_gc_sections = []
1267 if cc.links('static char unused() { return 5; } int main() { return 0; }',
1268 args : '-Wl,--gc-sections', name : 'gc-sections')
1269 ld_args_gc_sections += '-Wl,--gc-sections'
1270 endif
1271 with_ld_version_script = false
1272 if cc.links('int main() { return 0; }',
1273 args : '-Wl,--version-script=@0@'.format(
1274 join_paths(meson.source_root(), 'build-support/conftest.map')),
1275 name : 'version-script')
1276 with_ld_version_script = true
1277 endif
1278 with_ld_dynamic_list = false
1279 if cc.links('int main() { return 0; }',
1280 args : '-Wl,--dynamic-list=@0@'.format(
1281 join_paths(meson.source_root(), 'build-support/conftest.dyn')),
1282 name : 'dynamic-list')
1283 with_ld_dynamic_list = true
1284 endif
1285
1286 ld_args_build_id = cc.get_supported_link_arguments('-Wl,--build-id=sha1')
1287
1288 # check for dl support
1289 dep_dl = null_dep
1290 if not cc.has_function('dlopen')
1291 dep_dl = cc.find_library('dl', required : host_machine.system() != 'windows')
1292 endif
1293 if cc.has_function('dladdr', dependencies : dep_dl)
1294 # This is really only required for megadrivers
1295 pre_args += '-DHAVE_DLADDR'
1296 endif
1297
1298 if cc.has_function('dl_iterate_phdr')
1299 pre_args += '-DHAVE_DL_ITERATE_PHDR'
1300 elif with_intel_vk
1301 error('Intel "Anvil" Vulkan driver requires the dl_iterate_phdr function')
1302 elif with_dri_i965 and with_shader_cache
1303 error('Intel i965 GL driver requires dl_iterate_phdr when built with shader caching.')
1304 endif
1305
1306 # Determine whether or not the rt library is needed for time functions
1307 if host_machine.system() == 'windows' or cc.has_function('clock_gettime')
1308 dep_clock = null_dep
1309 else
1310 dep_clock = cc.find_library('rt')
1311 endif
1312
1313 # TODO: some of these may be conditional
1314 dep_zlib = dependency('zlib', version : '>= 1.2.3', fallback : ['zlib', 'zlib_dep'])
1315 pre_args += '-DHAVE_ZLIB'
1316
1317 _zstd = get_option('zstd')
1318 if _zstd == 'true'
1319 _zstd = 'enabled'
1320 warning('zstd option "true" deprecated, please use "enabled" instead.')
1321 elif _zstd == 'false'
1322 _zstd = 'disabled'
1323 warning('zstd option "false" deprecated, please use "disabled" instead.')
1324 endif
1325 if _zstd != 'disabled'
1326 dep_zstd = dependency('libzstd', required : _zstd == 'enabled')
1327 if dep_zstd.found()
1328 pre_args += '-DHAVE_ZSTD'
1329 endif
1330 else
1331 dep_zstd = null_dep
1332 endif
1333
1334 dep_thread = dependency('threads')
1335 if dep_thread.found() and host_machine.system() != 'windows'
1336 pre_args += '-DHAVE_PTHREAD'
1337 if cc.has_function(
1338 'pthread_setaffinity_np',
1339 dependencies : dep_thread,
1340 prefix : '#include <pthread.h>',
1341 args : '-D_GNU_SOURCE')
1342 pre_args += '-DHAVE_PTHREAD_SETAFFINITY'
1343 endif
1344 if cc.has_function(
1345 'pthread_setaffinity_np',
1346 dependencies : dep_thread,
1347 prefix : '#include <pthread_np.h>')
1348 pre_args += '-DPTHREAD_SETAFFINITY_IN_NP_HEADER'
1349 endif
1350 endif
1351 if host_machine.system() != 'windows'
1352 dep_expat = dependency('expat', fallback : ['expat', 'expat_dep'])
1353 else
1354 dep_expat = null_dep
1355 endif
1356 # this only exists on linux so either this is linux and it will be found, or
1357 # it's not linux and wont
1358 dep_m = cc.find_library('m', required : false)
1359
1360 # Check for libdrm. Various drivers have different libdrm version requirements,
1361 # but we always want to use the same version for all libdrm modules. That means
1362 # even if driver foo requires 2.4.0 and driver bar requires 2.4.3, if foo and
1363 # bar are both on use 2.4.3 for both of them
1364 dep_libdrm_amdgpu = null_dep
1365 dep_libdrm_radeon = null_dep
1366 dep_libdrm_nouveau = null_dep
1367 dep_libdrm_intel = null_dep
1368
1369 _drm_amdgpu_ver = '2.4.100'
1370 _drm_radeon_ver = '2.4.71'
1371 _drm_nouveau_ver = '2.4.102'
1372 _drm_intel_ver = '2.4.75'
1373 _drm_ver = '2.4.81'
1374
1375 _libdrm_checks = [
1376 ['intel', with_dri_i915 or with_gallium_i915],
1377 ['amdgpu', with_amd_vk or with_gallium_radeonsi],
1378 ['radeon', (with_gallium_radeonsi or with_dri_r100 or with_dri_r200 or
1379 with_gallium_r300 or with_gallium_r600)],
1380 ['nouveau', (with_gallium_nouveau or with_dri_nouveau)],
1381 ]
1382
1383 # VC4 only needs core libdrm support of this version, not a libdrm_vc4
1384 # library.
1385 if with_gallium_vc4
1386 _drm_ver = '2.4.89'
1387 endif
1388
1389 # etnaviv only needs core libdrm
1390 if with_gallium_etnaviv
1391 _drm_ver = '2.4.89'
1392 endif
1393
1394 # Loop over the enables versions and get the highest libdrm requirement for all
1395 # active drivers.
1396 _drm_blame = ''
1397 foreach d : _libdrm_checks
1398 ver = get_variable('_drm_@0@_ver'.format(d[0]))
1399 if d[1] and ver.version_compare('>' + _drm_ver)
1400 _drm_ver = ver
1401 _drm_blame = d[0]
1402 endif
1403 endforeach
1404 if _drm_blame != ''
1405 message('libdrm @0@ needed because @1@ has the highest requirement'.format(_drm_ver, _drm_blame))
1406 endif
1407
1408 # Then get each libdrm module
1409 foreach d : _libdrm_checks
1410 if d[1]
1411 set_variable(
1412 'dep_libdrm_' + d[0],
1413 dependency('libdrm_' + d[0], version : '>=' + _drm_ver)
1414 )
1415 endif
1416 endforeach
1417
1418 with_gallium_drisw_kms = false
1419 dep_libdrm = dependency(
1420 'libdrm', version : '>=' + _drm_ver,
1421 # GNU/Hurd includes egl_dri2, without drm.
1422 required : (with_dri2 and host_machine.system() != 'gnu') or with_dri3
1423 )
1424 if dep_libdrm.found()
1425 pre_args += '-DHAVE_LIBDRM'
1426 if with_dri_platform == 'drm' and with_dri
1427 with_gallium_drisw_kms = true
1428 endif
1429 endif
1430
1431 llvm_modules = ['bitwriter', 'engine', 'mcdisassembler', 'mcjit', 'core', 'executionengine', 'scalaropts', 'transformutils', 'instcombine']
1432 llvm_optional_modules = ['coroutines']
1433 if with_amd_vk or with_gallium_radeonsi or with_gallium_r600
1434 llvm_modules += ['amdgpu', 'native', 'bitreader', 'ipo']
1435 if with_gallium_r600
1436 llvm_modules += 'asmparser'
1437 endif
1438 endif
1439 if with_gallium_opencl
1440 llvm_modules += [
1441 'all-targets', 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
1442 'lto', 'option', 'objcarcopts', 'profiledata',
1443 ]
1444 endif
1445
1446 with_opencl_spirv = _opencl != 'disabled' and get_option('opencl-spirv')
1447 if with_amd_vk or with_gallium_radeonsi or with_opencl_spirv
1448 _llvm_version = '>= 8.0.0'
1449 elif with_gallium_swr
1450 _llvm_version = '>= 6.0.0'
1451 else
1452 _llvm_version = '>= 3.9.0'
1453 endif
1454
1455 _shared_llvm = get_option('shared-llvm')
1456 if _shared_llvm == 'true'
1457 _shared_llvm = 'enabled'
1458 warning('shared_llvm option "true" deprecated, please use "enabled" instead.')
1459 elif _shared_llvm == 'false'
1460 _shared_llvm = 'disabled'
1461 warning('shared_llvm option "false" deprecated, please use "disabled" instead.')
1462 endif
1463 if _shared_llvm == 'auto'
1464 _shared_llvm = (host_machine.system() != 'windows')
1465 else
1466 _shared_llvm = (_shared_llvm == 'enabled')
1467 endif
1468 _llvm = get_option('llvm')
1469 if _llvm == 'true'
1470 _llvm = 'enabled'
1471 warning('llvm option "true" deprecated, please use "enabled" instead.')
1472 elif _llvm == 'false'
1473 _llvm = 'disabled'
1474 warning('llvm option "false" deprecated, please use "disabled" instead.')
1475 endif
1476
1477 # the cmake method can only link statically, so don't attempt to use it if we
1478 # want to link dynamically. Before 0.54.0 meson will try cmake even when shared
1479 # linking is requested, so we need to force the config-tool method to be used
1480 # in that case, but in 0.54.0 meson won't try the cmake method if shared
1481 # linking is requested.
1482 _llvm_method = 'auto'
1483 if meson.version().version_compare('< 0.54.0') and _shared_llvm
1484 _llvm_method = 'config-tool'
1485 endif
1486
1487 dep_llvm = null_dep
1488 with_llvm = false
1489 if _llvm != 'disabled'
1490 dep_llvm = dependency(
1491 'llvm',
1492 version : _llvm_version,
1493 modules : llvm_modules,
1494 optional_modules : llvm_optional_modules,
1495 required : (
1496 with_amd_vk or with_gallium_radeonsi or with_gallium_swr or
1497 with_gallium_opencl or _llvm == 'enabled'
1498 ),
1499 static : not _shared_llvm,
1500 method : _llvm_method,
1501 fallback : ['llvm', 'dep_llvm'],
1502 )
1503 with_llvm = dep_llvm.found()
1504 endif
1505 if with_llvm
1506 pre_args += '-DLLVM_AVAILABLE'
1507 pre_args += '-DMESA_LLVM_VERSION_STRING="@0@"'.format(dep_llvm.version())
1508 pre_args += '-DLLVM_IS_SHARED=@0@'.format(_shared_llvm.to_int())
1509
1510 # LLVM can be built without rtti, turning off rtti changes the ABI of C++
1511 # programs, so we need to build all C++ code in mesa without rtti as well to
1512 # ensure that linking works.
1513 #
1514 # In meson 0.51.0 we can use cmake to find LLVM in addittion to meson's
1515 # builtin llvm-config based finder. A new generic variable getter method
1516 # has also been added, so we'll use that if we can, to cover the cmake case.
1517 if dep_llvm.type_name() == 'internal'
1518 _rtti = subproject('llvm').get_variable('has_rtti', true)
1519 else
1520 # The CMake finder will return 'ON', the llvm-config will return 'YES'
1521 _rtti = ['ON', 'YES'].contains(dep_llvm.get_variable(cmake : 'LLVM_ENABLE_RTTI', configtool: 'has-rtti'))
1522 endif
1523 if not _rtti
1524 if with_gallium_nouveau
1525 error('The Nouveau driver requires rtti. You either need to turn off nouveau or use an LLVM built with LLVM_ENABLE_RTTI.')
1526 elif with_gallium_opencl
1527 error('The Clover OpenCL state tracker requires rtti, you need to turn off clover or use an LLVM built with LLVM_ENABLE_RTTI.')
1528 endif
1529 if cc.get_id() == 'msvc'
1530 cpp_args += '/GR-'
1531 else
1532 cpp_args += '-fno-rtti'
1533 endif
1534 endif
1535 elif with_amd_vk or with_gallium_radeonsi or with_gallium_swr
1536 error('The following drivers require LLVM: Radv, RadeonSI, SWR. One of these is enabled, but LLVM is disabled.')
1537 elif with_gallium_opencl
1538 error('The OpenCL "Clover" state tracker requires LLVM, but LLVM is disabled.')
1539 endif
1540
1541 if with_opencl_spirv
1542 chosen_llvm_version_array = dep_llvm.version().split('.')
1543 chosen_llvm_version_major = chosen_llvm_version_array[0].to_int()
1544 chosen_llvm_version_minor = chosen_llvm_version_array[1].to_int()
1545
1546 # Require an SPIRV-LLVM-Translator version compatible with the chosen LLVM
1547 # one.
1548 _llvmspirvlib_version = [
1549 # This first version check is still needed as maybe LLVM 8.0 was picked but
1550 # we do not want to accept SPIRV-LLVM-Translator 8.0.0.1 as that version does
1551 # not have the required API and those are only available starting from
1552 # 8.0.1.3.
1553 '>= 8.0.1.3',
1554 '>= @0@.@1@'.format(chosen_llvm_version_major, chosen_llvm_version_minor),
1555 '< @0@.@1@'.format(chosen_llvm_version_major, chosen_llvm_version_minor + 1) ]
1556
1557 dep_spirv_tools = dependency('SPIRV-Tools', required : true, version : '>= 2018.0')
1558 # LLVMSPIRVLib is available at https://github.com/KhronosGroup/SPIRV-LLVM-Translator
1559 dep_llvmspirvlib = dependency('LLVMSPIRVLib', required : true, version : _llvmspirvlib_version)
1560 else
1561 dep_spirv_tools = null_dep
1562 dep_llvmspirvlib = null_dep
1563 endif
1564
1565 if (with_amd_vk or with_gallium_radeonsi or with_gallium_opencl or
1566 (with_gallium_r600 and with_llvm))
1567 dep_elf = dependency('libelf', required : false)
1568 if not dep_elf.found()
1569 dep_elf = cc.find_library('elf')
1570 endif
1571 else
1572 dep_elf = null_dep
1573 endif
1574
1575 dep_glvnd = null_dep
1576 if with_glvnd
1577 dep_glvnd = dependency('libglvnd', version : '>= 1.3.2')
1578 pre_args += '-DUSE_LIBGLVND=1'
1579 endif
1580
1581 _valgrind = get_option('valgrind')
1582 if _valgrind == 'true'
1583 _valgrind = 'enabled'
1584 warning('valgrind option "true" deprecated, please use "enabled" instead.')
1585 elif _valgrind == 'false'
1586 _valgrind = 'disabled'
1587 warning('valgrind option "false" deprecated, please use "disabled" instead.')
1588 endif
1589 if _valgrind != 'disabled'
1590 dep_valgrind = dependency('valgrind', required : _valgrind == 'enabled')
1591 if dep_valgrind.found()
1592 pre_args += '-DHAVE_VALGRIND'
1593 endif
1594 else
1595 dep_valgrind = null_dep
1596 endif
1597
1598 # pthread stubs. Lets not and say we didn't
1599
1600 if host_machine.system() == 'windows'
1601 # Prefer the winflexbison versions, they're much easier to install and have
1602 # better windows support.
1603
1604 prog_flex = find_program('win_flex', required : false)
1605 if prog_flex.found()
1606 # windows compatibility (uses <io.h> instead of <unistd.h> and _isatty,
1607 # _fileno functions)
1608 prog_flex = [prog_flex, '--wincompat', '-D__STDC_VERSION__=199901']
1609 else
1610 prog_flex = [find_program('lex', 'flex', required : with_any_opengl)]
1611 endif
1612 # Force flex to use const keyword in prototypes, as relies on __cplusplus or
1613 # __STDC__ macro to determine whether it's safe to use const keyword, but
1614 # MSVC never defines __STDC__ unless we disable all MSVC extensions.
1615 prog_flex += '-DYY_USE_CONST='
1616
1617 prog_bison = find_program('win_bison', required : false)
1618 if not prog_bison.found()
1619 prog_bison = find_program('yacc', 'bison', required : with_any_opengl)
1620 endif
1621 else
1622 prog_bison = find_program('bison', required : with_any_opengl)
1623
1624 # Disable deprecated keyword warnings, since we have to use them for
1625 # old-bison compat. See discussion in
1626 # https://gitlab.freedesktop.org/mesa/mesa/merge_requests/2161
1627 if find_program('bison', required : false, version : '> 2.3').found()
1628 prog_bison = [prog_bison, '-Wno-deprecated']
1629 endif
1630
1631 prog_flex = find_program('flex', required : with_any_opengl)
1632 endif
1633
1634 dep_selinux = null_dep
1635 if get_option('selinux')
1636 dep_selinux = dependency('libselinux')
1637 pre_args += '-DMESA_SELINUX'
1638 endif
1639
1640 _libunwind = get_option('libunwind')
1641 if _libunwind == 'true'
1642 _libunwind = 'enabled'
1643 warning('libunwind option "true" deprecated, please use "enabled" instead.')
1644 elif _libunwind == 'false'
1645 _libunwind = 'disabled'
1646 warning('libunwind option "false" deprecated, please use "disabled" instead.')
1647 endif
1648 if _libunwind != 'disabled'
1649 dep_unwind = dependency('libunwind', required : _libunwind == 'enabled')
1650 if dep_unwind.found()
1651 pre_args += '-DHAVE_LIBUNWIND'
1652 endif
1653 else
1654 dep_unwind = null_dep
1655 endif
1656
1657 if with_osmesa != 'none'
1658 if with_osmesa == 'gallium' and not with_gallium_softpipe
1659 error('OSMesa gallium requires gallium softpipe or llvmpipe.')
1660 endif
1661 if host_machine.system() == 'windows'
1662 osmesa_lib_name = 'osmesa'
1663 else
1664 osmesa_lib_name = 'OSMesa'
1665 endif
1666 osmesa_bits = get_option('osmesa-bits')
1667 if osmesa_bits != '8'
1668 if with_dri or with_glx != 'disabled'
1669 error('OSMesa bits must be 8 if building glx or dri based drivers')
1670 endif
1671 osmesa_lib_name = osmesa_lib_name + osmesa_bits
1672 pre_args += [
1673 '-DCHAN_BITS=@0@'.format(osmesa_bits), '-DDEFAULT_SOFTWARE_DEPTH_BITS=31'
1674 ]
1675 endif
1676 endif
1677
1678 # TODO: symbol mangling
1679
1680 if with_platform_wayland
1681 dep_wl_scanner = dependency('wayland-scanner', native: true)
1682 prog_wl_scanner = find_program(dep_wl_scanner.get_pkgconfig_variable('wayland_scanner'))
1683 if dep_wl_scanner.version().version_compare('>= 1.15')
1684 wl_scanner_arg = 'private-code'
1685 else
1686 wl_scanner_arg = 'code'
1687 endif
1688 dep_wl_protocols = dependency('wayland-protocols', version : '>= 1.8')
1689 dep_wayland_client = dependency('wayland-client', version : '>=1.11')
1690 dep_wayland_server = dependency('wayland-server', version : '>=1.11')
1691 if with_egl
1692 dep_wayland_egl = dependency('wayland-egl-backend', version : '>= 3')
1693 dep_wayland_egl_headers = dep_wayland_egl.partial_dependency(compile_args : true)
1694 endif
1695 wayland_dmabuf_xml = join_paths(
1696 dep_wl_protocols.get_pkgconfig_variable('pkgdatadir'), 'unstable',
1697 'linux-dmabuf', 'linux-dmabuf-unstable-v1.xml'
1698 )
1699 pre_args += ['-DHAVE_WAYLAND_PLATFORM', '-DWL_HIDE_DEPRECATED']
1700 endif
1701
1702 dep_x11 = null_dep
1703 dep_xext = null_dep
1704 dep_xdamage = null_dep
1705 dep_xfixes = null_dep
1706 dep_x11_xcb = null_dep
1707 dep_xcb = null_dep
1708 dep_xcb_glx = null_dep
1709 dep_xcb_dri2 = null_dep
1710 dep_xcb_dri3 = null_dep
1711 dep_dri2proto = null_dep
1712 dep_glproto = null_dep
1713 dep_xxf86vm = null_dep
1714 dep_xcb_dri3 = null_dep
1715 dep_xcb_present = null_dep
1716 dep_xcb_sync = null_dep
1717 dep_xcb_xfixes = null_dep
1718 dep_xshmfence = null_dep
1719 dep_xcb_xrandr = null_dep
1720 dep_xcb_shm = null_dep
1721 dep_xlib_xrandr = null_dep
1722 if with_platform_x11
1723 if with_glx == 'xlib' or with_glx == 'gallium-xlib'
1724 dep_x11 = dependency('x11')
1725 dep_xext = dependency('xext')
1726 dep_xcb = dependency('xcb')
1727 elif with_glx == 'dri'
1728 dep_x11 = dependency('x11')
1729 dep_xext = dependency('xext')
1730 dep_xdamage = dependency('xdamage', version : '>= 1.1')
1731 dep_xfixes = dependency('xfixes', version : '>= 2.0')
1732 dep_xcb_glx = dependency('xcb-glx', version : '>= 1.8.1')
1733 dep_xcb_shm = dependency('xcb-shm')
1734 endif
1735 if (with_any_vk or with_glx == 'dri' or with_egl or
1736 (with_gallium_vdpau or with_gallium_xvmc or with_gallium_va or
1737 with_gallium_omx != 'disabled'))
1738 dep_xcb = dependency('xcb')
1739 dep_x11_xcb = dependency('x11-xcb')
1740 if with_dri_platform == 'drm' and not dep_libdrm.found()
1741 error('libdrm required for gallium video statetrackers when using x11')
1742 endif
1743 endif
1744 if with_any_vk or with_egl or (with_glx == 'dri' and with_dri_platform == 'drm')
1745 dep_xcb_dri2 = dependency('xcb-dri2', version : '>= 1.8')
1746
1747 if with_dri3
1748 pre_args += '-DHAVE_DRI3'
1749 dep_xcb_dri3 = dependency('xcb-dri3')
1750 dep_xcb_present = dependency('xcb-present')
1751 # until xcb-dri3 has been around long enough to make a hard-dependency:
1752 if (dep_xcb_dri3.version().version_compare('>= 1.13') and
1753 dep_xcb_present.version().version_compare('>= 1.13'))
1754 pre_args += '-DHAVE_DRI3_MODIFIERS'
1755 endif
1756 dep_xcb_sync = dependency('xcb-sync')
1757 dep_xshmfence = dependency('xshmfence', version : '>= 1.1')
1758 endif
1759 endif
1760 if with_glx == 'dri' or with_glx == 'gallium-xlib'
1761 dep_glproto = dependency('glproto', version : '>= 1.4.14')
1762 endif
1763 if with_glx == 'dri'
1764 if with_dri_platform == 'drm'
1765 dep_dri2proto = dependency('dri2proto', version : '>= 2.8')
1766 dep_xxf86vm = dependency('xxf86vm')
1767 endif
1768 endif
1769 if (with_egl or (
1770 with_gallium_vdpau or with_gallium_xvmc or with_gallium_xa or
1771 with_gallium_omx != 'disabled'))
1772 dep_xcb_xfixes = dependency('xcb-xfixes')
1773 endif
1774 if with_xlib_lease
1775 dep_xcb_xrandr = dependency('xcb-randr')
1776 dep_xlib_xrandr = dependency('xrandr', version : '>= 1.3')
1777 endif
1778 endif
1779
1780 if get_option('gallium-extra-hud')
1781 pre_args += '-DHAVE_GALLIUM_EXTRA_HUD=1'
1782 endif
1783
1784 _sensors = get_option('lmsensors')
1785 if _sensors == 'true'
1786 _sensors = 'enabled'
1787 warning('lmsensors option "true" deprecated, please use "enabled" instead.')
1788 elif _sensors == 'false'
1789 _sensors = 'disabled'
1790 warning('lmsensors option "false" deprecated, please use "disabled" instead.')
1791 endif
1792 if _sensors != 'disabled'
1793 dep_lmsensors = cc.find_library('sensors', required : _sensors == 'enabled')
1794 if dep_lmsensors.found()
1795 pre_args += '-DHAVE_LIBSENSORS=1'
1796 endif
1797 else
1798 dep_lmsensors = null_dep
1799 endif
1800
1801 # If the compiler supports it, put function and data symbols in their
1802 # own sections and GC the sections after linking. This lets drivers
1803 # drop shared code unused by that specific driver (particularly
1804 # relevant for Vulkan drivers).
1805 if cc.has_link_argument('-Wl,--gc-sections')
1806 add_project_arguments('-Wl,--gc-sections', language : ['c', 'cpp'])
1807 foreach a: ['-ffunction-sections', '-fdata-sections']
1808 if cc.has_argument(a)
1809 add_project_arguments(a, language : ['c', 'cpp'])
1810 endif
1811 endforeach
1812 endif
1813
1814 foreach a : pre_args
1815 add_project_arguments(a, language : ['c', 'cpp'])
1816 endforeach
1817 foreach a : c_args
1818 add_project_arguments(a, language : ['c'])
1819 endforeach
1820 foreach a : cpp_args
1821 add_project_arguments(a, language : ['cpp'])
1822 endforeach
1823
1824 gl_priv_reqs = []
1825
1826 if with_glx == 'xlib' or with_glx == 'gallium-xlib'
1827 gl_priv_reqs += ['x11', 'xext', 'xcb']
1828 elif with_glx == 'dri'
1829 gl_priv_reqs += [
1830 'x11', 'xext', 'xdamage >= 1.1', 'xfixes', 'x11-xcb', 'xcb',
1831 'xcb-glx >= 1.8.1']
1832 if with_dri_platform == 'drm'
1833 gl_priv_reqs += 'xcb-dri2 >= 1.8'
1834 gl_priv_reqs += 'xxf86vm'
1835 endif
1836 endif
1837 if dep_libdrm.found()
1838 gl_priv_reqs += 'libdrm >= 2.4.75'
1839 endif
1840
1841 gl_priv_libs = []
1842 if dep_thread.found()
1843 gl_priv_libs += ['-lpthread', '-pthread']
1844 endif
1845 if dep_m.found()
1846 gl_priv_libs += '-lm'
1847 endif
1848 if dep_dl.found()
1849 gl_priv_libs += '-ldl'
1850 endif
1851
1852 pkg = import('pkgconfig')
1853
1854 if host_machine.system() == 'windows'
1855 prog_dumpbin = find_program('dumpbin', required : false)
1856 with_symbols_check = prog_dumpbin.found() and with_tests
1857 symbols_check_args = ['--dumpbin', prog_dumpbin.path()]
1858 else
1859 prog_nm = find_program('nm')
1860 with_symbols_check = with_tests
1861 symbols_check_args = ['--nm', prog_nm.path()]
1862 endif
1863
1864 # This quirk needs to be applied to sources with functions defined in assembly
1865 # as GCC LTO drops them. See: https://bugs.freedesktop.org/show_bug.cgi?id=109391
1866 gcc_lto_quirk = (cc.get_id() == 'gcc') ? ['-fno-lto'] : []
1867
1868 subdir('include')
1869 subdir('bin')
1870 subdir('src')
1871
1872 # Meson 0.49 and earlier seems to have a bug that fails to evaluate the string-
1873 # formatting below unless the first argument is passed as a variable. This has
1874 # been fixed in Meson 0.50 and beyond, but we need to keep it like this for now
1875 # for backwards compatibility.
1876 _with_opengl_string = with_opengl ? 'yes' : 'no'
1877
1878 lines = ['',
1879 'prefix: ' + get_option('prefix'),
1880 'libdir: ' + get_option('libdir'),
1881 'includedir: ' + get_option('includedir'),
1882 '',
1883 'OpenGL: @0@ (ES1: @1@ ES2: @2@)'.format(_with_opengl_string,
1884 with_gles1 ? 'yes' : 'no',
1885 with_gles2 ? 'yes' : 'no'),
1886 ]
1887
1888 if with_osmesa != 'none'
1889 lines += ''
1890 suffix = ''
1891 if with_osmesa == 'gallium'
1892 suffix = '(Gallium)'
1893 endif
1894 lines += 'OSMesa: lib' + osmesa_lib_name + suffix
1895 else
1896 lines += 'OSMesa: no'
1897 endif
1898
1899 if with_dri
1900 lines += ''
1901 lines += 'DRI platform: ' + with_dri_platform
1902 if dri_drivers.length() != 0 and dri_drivers != ['']
1903 lines += 'DRI drivers: ' + ' '.join(dri_drivers)
1904 else
1905 lines += 'DRI drivers: no'
1906 endif
1907 lines += 'DRI driver dir: ' + dri_drivers_path
1908 endif
1909
1910 if with_glx != 'disabled'
1911 lines += ''
1912 if with_glx == 'dri'
1913 lines += 'GLX: DRI-based'
1914 elif with_glx == 'xlib'
1915 lines += 'GLX: Xlib-based'
1916 elif with_glx == 'gallium-xlib'
1917 lines += 'GLX: Xlib-based (Gallium)'
1918 else
1919 lines += 'GLX: ' + with_glx
1920 endif
1921 endif
1922
1923 lines += ''
1924 lines += 'EGL: ' + (with_egl ? 'yes' : 'no')
1925 if with_egl
1926 egl_drivers = []
1927 if with_dri
1928 egl_drivers += 'builtin:egl_dri2'
1929 endif
1930 if with_dri3
1931 egl_drivers += 'builtin:egl_dri3'
1932 endif
1933 lines += 'EGL drivers: ' + ' '.join(egl_drivers)
1934 endif
1935 lines += 'GBM: ' + (with_gbm ? 'yes' : 'no')
1936 if with_egl or with_any_vk
1937 _platforms += 'surfaceless'
1938 if with_gbm
1939 _platforms += 'drm'
1940 endif
1941 lines += 'EGL/Vulkan/VL platforms: ' + ' '.join(_platforms)
1942 endif
1943
1944 lines += ''
1945 if with_any_vk
1946 lines += 'Vulkan drivers: ' + ' '.join(_vulkan_drivers)
1947 lines += 'Vulkan ICD dir: ' + with_vulkan_icd_dir
1948 else
1949 lines += 'Vulkan drivers: no'
1950 endif
1951
1952 lines += ''
1953 if with_llvm
1954 lines += 'llvm: yes'
1955 lines += 'llvm-version: ' + dep_llvm.version()
1956 else
1957 lines += 'llvm: no'
1958 endif
1959
1960 lines += ''
1961 if with_gallium
1962 lines += 'Gallium drivers: ' + ' '.join(gallium_drivers)
1963 gallium_st = ['mesa']
1964 if with_gallium_xa
1965 gallium_st += 'xa'
1966 endif
1967 if with_gallium_xvmc
1968 gallium_st += 'xvmc'
1969 endif
1970 if with_gallium_xvmc
1971 gallium_st += 'xvmc'
1972 endif
1973 if with_gallium_vdpau
1974 gallium_st += 'vdpau'
1975 endif
1976 if with_gallium_omx != 'disabled'
1977 gallium_st += 'omx' + with_gallium_omx
1978 endif
1979 if with_gallium_va
1980 gallium_st += 'va'
1981 endif
1982 if with_gallium_st_nine
1983 gallium_st += 'nine'
1984 endif
1985 if with_gallium_opencl
1986 gallium_st += 'clover'
1987 endif
1988 lines += 'Gallium st: ' + ' '.join(gallium_st)
1989 else
1990 lines += 'Gallium: no'
1991 endif
1992
1993 lines += 'HUD lmsensors: ' + (dep_lmsensors.found() ? 'yes' : 'no')
1994
1995 lines += ''
1996 lines += 'Shared-glapi: ' + (with_shared_glapi ? 'yes' : 'no')
1997
1998
1999 indent = ' '
2000 summary = indent + ('\n' + indent).join(lines)
2001 message('Configuration summary:\n@0@\n'.format(summary))