3925ec483e50074cc5ecc8aae55e61b13087a8b1
[mesa.git] / meson.build
1 # Copyright © 2017 Intel Corporation
2
3 # Permission is hereby granted, free of charge, to any person obtaining a copy
4 # of this software and associated documentation files (the "Software"), to deal
5 # in the Software without restriction, including without limitation the rights
6 # to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
7 # copies of the Software, and to permit persons to whom the Software is
8 # furnished to do so, subject to the following conditions:
9
10 # The above copyright notice and this permission notice shall be included in
11 # all copies or substantial portions of the Software.
12
13 # THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
14 # IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
15 # FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
16 # AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
17 # LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
18 # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
19 # SOFTWARE.
20
21 project(
22 'mesa',
23 ['c', 'cpp'],
24 version : run_command(
25 [find_program('python', 'python2', 'python3'), 'bin/meson_get_version.py']
26 ).stdout(),
27 license : 'MIT',
28 meson_version : '>= 0.42',
29 default_options : ['buildtype=debugoptimized', 'c_std=c99', 'cpp_std=c++11']
30 )
31
32 # Arguments for the preprocessor, put these in a separate array from the C and
33 # C++ (cpp in meson terminology) arguments since they need to be added to the
34 # default arguments for both C and C++.
35 pre_args = [
36 '-D__STDC_CONSTANT_MACROS',
37 '-D__STDC_FORMAT_MACROS',
38 '-D__STDC_LIMIT_MACROS',
39 '-DVERSION="@0@"'.format(meson.project_version()),
40 '-DPACKAGE_VERSION=VERSION',
41 '-DPACKAGE_BUGREPORT="https://bugs.freedesktop.org/enter_bug.cgi?product=Mesa"',
42 ]
43
44 with_vulkan_icd_dir = get_option('vulkan-icd-dir')
45 with_tests = get_option('build-tests')
46 with_valgrind = get_option('valgrind')
47 with_libunwind = get_option('libunwind')
48 with_asm = get_option('asm')
49 with_osmesa = get_option('osmesa')
50 with_swr_arches = get_option('swr-arches').split(',')
51 with_tools = get_option('tools').split(',')
52 if with_tools.contains('all')
53 with_tools = ['freedreno', 'glsl', 'intel', 'nir', 'nouveau']
54 endif
55 if get_option('texture-float')
56 pre_args += '-DTEXTURE_FLOAT_ENABLED'
57 message('WARNING: Floating-point texture enabled. Please consult docs/patents.txt and your lawyer before building mesa.')
58 endif
59
60 dri_drivers_path = get_option('dri-drivers-path')
61 if dri_drivers_path == ''
62 dri_drivers_path = join_paths(get_option('libdir'), 'dri')
63 endif
64 dri_search_path = get_option('dri-search-path')
65 if dri_search_path == ''
66 dri_search_path = join_paths(get_option('prefix'), dri_drivers_path)
67 endif
68
69 with_gles1 = get_option('gles1')
70 with_gles2 = get_option('gles2')
71 with_opengl = get_option('opengl')
72 with_any_opengl = with_opengl or with_gles1 or with_gles2
73 # Only build shared_glapi if at least one OpenGL API is enabled
74 with_shared_glapi = get_option('shared-glapi') and with_any_opengl
75
76
77 # shared-glapi is required if at least two OpenGL APIs are being built
78 if not with_shared_glapi
79 if ((with_gles1 and with_gles2) or (with_gles1 and with_opengl)
80 or (with_gles2 and with_opengl))
81 error('shared-glapi required for building two or more of OpenGL, OpenGL ES 1.x, OpenGL ES 2.x')
82 endif
83 endif
84
85 # We require OpenGL for OpenGL ES
86 if (with_gles1 or with_gles2) and not with_opengl
87 error('building OpenGL ES without OpenGL is not supported.')
88 endif
89
90 with_dri = false
91 with_dri_i915 = false
92 with_dri_i965 = false
93 with_dri_r100 = false
94 with_dri_r200 = false
95 with_dri_nouveau = false
96 with_dri_swrast = false
97 _drivers = get_option('dri-drivers')
98 if _drivers == 'auto'
99 if host_machine.system() == 'linux'
100 # TODO: PPC, Sparc
101 if ['x86', 'x86_64'].contains(host_machine.cpu_family())
102 _drivers = 'i915,i965,r100,r200,nouveau'
103 else
104 error('Unknown architecture. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.')
105 endif
106 elif ['darwin', 'windows', 'cygwin'].contains(host_machine.system())
107 # only swrast would make sense here, but gallium swrast is a much better default
108 _drivers = ''
109 else
110 error('Unknown OS. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.')
111 endif
112 endif
113 if _drivers != ''
114 _split = _drivers.split(',')
115 with_dri_i915 = _split.contains('i915')
116 with_dri_i965 = _split.contains('i965')
117 with_dri_r100 = _split.contains('r100')
118 with_dri_r200 = _split.contains('r200')
119 with_dri_nouveau = _split.contains('nouveau')
120 with_dri_swrast = _split.contains('swrast')
121 with_dri = true
122 endif
123
124 with_gallium = false
125 with_gallium_pl111 = false
126 with_gallium_radeonsi = false
127 with_gallium_r300 = false
128 with_gallium_r600 = false
129 with_gallium_nouveau = false
130 with_gallium_freedreno = false
131 with_gallium_softpipe = false
132 with_gallium_vc4 = false
133 with_gallium_vc5 = false
134 with_gallium_etnaviv = false
135 with_gallium_imx = false
136 with_gallium_i915 = false
137 with_gallium_svga = false
138 with_gallium_virgl = false
139 with_gallium_swr = false
140 _drivers = get_option('gallium-drivers')
141 if _drivers == 'auto'
142 if host_machine.system() == 'linux'
143 # TODO: PPC, Sparc
144 if ['x86', 'x86_64'].contains(host_machine.cpu_family())
145 _drivers = 'r300,r600,radeonsi,nouveau,virgl,svga,swrast'
146 elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
147 _drivers = 'pl111,vc4,vc5,freedreno,etnaviv,imx,virgl,svga,swrast'
148 else
149 error('Unknown architecture. Please pass -Dgallium-drivers to set driver options. Patches gladly accepted to fix this.')
150 endif
151 elif ['darwin', 'windows', 'cygwin'].contains(host_machine.system())
152 _drivers = 'swrast'
153 else
154 error('Unknown OS. Please pass -Dgallium-drivers to set driver options. Patches gladly accepted to fix this.')
155 endif
156 endif
157 if _drivers != ''
158 _split = _drivers.split(',')
159 with_gallium_pl111 = _split.contains('pl111')
160 with_gallium_radeonsi = _split.contains('radeonsi')
161 with_gallium_r300 = _split.contains('r300')
162 with_gallium_r600 = _split.contains('r600')
163 with_gallium_nouveau = _split.contains('nouveau')
164 with_gallium_freedreno = _split.contains('freedreno')
165 with_gallium_softpipe = _split.contains('swrast')
166 with_gallium_vc4 = _split.contains('vc4')
167 with_gallium_vc5 = _split.contains('vc5')
168 with_gallium_etnaviv = _split.contains('etnaviv')
169 with_gallium_imx = _split.contains('imx')
170 with_gallium_i915 = _split.contains('i915')
171 with_gallium_svga = _split.contains('svga')
172 with_gallium_virgl = _split.contains('virgl')
173 with_gallium_swr = _split.contains('swr')
174 with_gallium = true
175 endif
176
177 with_intel_vk = false
178 with_amd_vk = false
179 with_any_vk = false
180 _vulkan_drivers = get_option('vulkan-drivers')
181 if _vulkan_drivers == 'auto'
182 if host_machine.system() == 'linux'
183 if host_machine.cpu_family().startswith('x86')
184 _vulkan_drivers = 'amd,intel'
185 else
186 error('Unknown architecture. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.')
187 endif
188 elif ['darwin', 'windows', 'cygwin'].contains(host_machine.system())
189 # No vulkan driver supports windows or macOS currently
190 _vulkan_drivers = ''
191 else
192 error('Unknown OS. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.')
193 endif
194 endif
195 if _vulkan_drivers != ''
196 _split = _vulkan_drivers.split(',')
197 with_intel_vk = _split.contains('intel')
198 with_amd_vk = _split.contains('amd')
199 with_any_vk = with_amd_vk or with_intel_vk
200 endif
201
202 if with_dri_swrast and (with_gallium_softpipe or with_gallium_swr)
203 error('Only one swrast provider can be built')
204 endif
205 if with_dri_i915 and with_gallium_i915
206 error('Only one i915 provider can be built')
207 endif
208 if with_gallium_imx and not with_gallium_etnaviv
209 error('IMX driver requires etnaviv driver')
210 endif
211 if with_gallium_pl111 and not with_gallium_vc4
212 error('pl111 driver requires vc4 driver')
213 endif
214
215 dep_libdrm_intel = []
216 if with_dri_i915 or with_gallium_i915
217 dep_libdrm_intel = dependency('libdrm_intel', version : '>= 2.4.75')
218 endif
219
220 system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'dragonfly', 'linux'].contains(host_machine.system())
221
222 if host_machine.system() == 'darwin'
223 with_dri_platform = 'apple'
224 elif ['windows', 'cygwin'].contains(host_machine.system())
225 with_dri_platform = 'windows'
226 elif system_has_kms_drm
227 with_dri_platform = 'drm'
228 else
229 # FIXME: haiku doesn't use dri, and xlib doesn't use dri, probably should
230 # assert here that one of those cases has been met.
231 # FIXME: GNU (hurd) ends up here as well, but meson doesn't officially
232 # support Hurd at time of writing (2017/11)
233 # FIXME: illumos ends up here as well
234 with_dri_platform = 'none'
235 endif
236
237 with_platform_android = false
238 with_platform_wayland = false
239 with_platform_x11 = false
240 with_platform_drm = false
241 with_platform_surfaceless = false
242 egl_native_platform = ''
243 _platforms = get_option('platforms')
244 if _platforms == 'auto'
245 if system_has_kms_drm
246 _platforms = 'x11,wayland,drm,surfaceless'
247 elif ['darwin', 'windows', 'cygwin'].contains(host_machine.system())
248 _platforms = 'x11,surfaceless'
249 else
250 error('Unknown OS. Please pass -Dplatforms to set platforms. Patches gladly accepted to fix this.')
251 endif
252 endif
253 if _platforms != ''
254 _split = _platforms.split(',')
255 with_platform_android = _split.contains('android')
256 with_platform_x11 = _split.contains('x11')
257 with_platform_wayland = _split.contains('wayland')
258 with_platform_drm = _split.contains('drm')
259 with_platform_surfaceless = _split.contains('surfaceless')
260 egl_native_platform = _split[0]
261 endif
262
263 with_glx = get_option('glx')
264 if with_glx == 'auto'
265 if with_dri
266 with_glx = 'dri'
267 elif with_gallium
268 # Even when building just gallium drivers the user probably wants dri
269 with_glx = 'dri'
270 elif with_platform_x11 and with_any_opengl and not with_any_vk
271 # The automatic behavior should not be to turn on xlib based glx when
272 # building only vulkan drivers
273 with_glx = 'xlib'
274 else
275 with_glx = 'disabled'
276 endif
277 endif
278 if with_glx == 'dri'
279 if with_gallium
280 with_dri = true
281 endif
282 endif
283
284 if not (with_dri or with_gallium or with_glx == 'xlib' or with_glx == 'gallium-xlib')
285 with_gles1 = false
286 with_gles2 = false
287 with_opengl = false
288 with_any_opengl = false
289 with_shared_glapi = false
290 endif
291
292 with_gbm = get_option('gbm')
293 if with_gbm == 'auto' and with_dri # TODO: or gallium
294 with_gbm = system_has_kms_drm
295 elif with_gbm == 'true'
296 if not system_has_kms_drm
297 error('GBM only supports DRM/KMS platforms')
298 endif
299 with_gbm = true
300 else
301 with_gbm = false
302 endif
303
304 _egl = get_option('egl')
305 if _egl == 'auto'
306 with_egl = with_dri and with_shared_glapi and egl_native_platform != ''
307 elif _egl == 'true'
308 if not with_dri
309 error('EGL requires dri')
310 elif not with_shared_glapi
311 error('EGL requires shared-glapi')
312 elif egl_native_platform == ''
313 error('No platforms specified, consider -Dplatforms=drm,x11 at least')
314 endif
315 with_egl = true
316 else
317 with_egl = false
318 endif
319
320 if with_egl and not (with_platform_drm or with_platform_surfaceless)
321 if with_gallium_radeonsi
322 error('RadeonSI requires drm or surfaceless platform when using EGL')
323 endif
324 if with_gallium_virgl
325 error('Virgl requires drm or surfaceless platform when using EGL')
326 endif
327 endif
328
329 pre_args += '-DGLX_USE_TLS'
330 if with_glx != 'disabled'
331 if not (with_platform_x11 and with_any_opengl)
332 if with_glx == 'auto'
333 with_glx = 'disabled'
334 else
335 error('Cannot build GLX support without X11 platform support and at least one OpenGL API')
336 endif
337 elif with_glx == 'gallium-xlib'
338 if not with_gallium
339 error('Gallium-xlib based GLX requires at least one gallium driver')
340 elif not with_gallium_softpipe
341 error('Gallium-xlib based GLX requires softpipe or llvmpipe.')
342 elif with_dri
343 error('gallium-xlib conflicts with any dri driver')
344 endif
345 elif with_glx == 'xlib'
346 if with_dri
347 error('xlib conflicts with any dri driver')
348 endif
349 elif with_glx == 'dri' and not with_dri
350 error('dri based GLX requires at least one DRI driver')
351 endif
352 endif
353
354 with_glvnd = get_option('glvnd')
355 if with_glvnd
356 if with_glx == 'xlib' or with_glx == 'gallium-xlib'
357 error('Cannot build glvnd support for GLX that is not DRI based.')
358 elif with_glx == 'disabled' and not with_egl
359 error('glvnd requires DRI based GLX and/or EGL')
360 endif
361 endif
362
363 # TODO: toggle for this
364 with_glx_direct = true
365
366 if with_vulkan_icd_dir == ''
367 with_vulkan_icd_dir = join_paths(get_option('datadir'), 'vulkan/icd.d')
368 endif
369
370 with_dri2 = (with_dri or with_any_vk) and with_dri_platform == 'drm'
371 with_dri3 = get_option('dri3')
372 if with_dri3 == 'auto'
373 with_dri3 = system_has_kms_drm and with_dri2
374 else
375 with_dri3 = with_dri3 == 'true'
376 endif
377
378 if with_any_vk and (with_platform_x11 and not with_dri3)
379 error('Vulkan drivers require dri3 for X11 support')
380 endif
381 if with_dri or with_gallium
382 if with_glx == 'disabled' and not with_egl
383 error('building dri or gallium drivers require at least one window system')
384 endif
385 endif
386
387 prog_pkgconfig = find_program('pkg-config')
388
389 _vdpau = get_option('gallium-vdpau')
390 if not system_has_kms_drm
391 if _vdpau == 'true'
392 error('VDPAU state tracker can only be build on unix-like OSes.')
393 else
394 _vdpau = 'false'
395 endif
396 elif not with_platform_x11
397 if _vdpau == 'true'
398 error('VDPAU state tracker requires X11 support.')
399 else
400 _vdpau = 'false'
401 endif
402 elif not (with_gallium_r300 or with_gallium_r600 or with_gallium_radeonsi or
403 with_gallium_nouveau)
404 if _vdpau == 'true'
405 error('VDPAU state tracker requires at least one of the following gallium drivers: r300, r600, radeonsi, nouveau.')
406 else
407 _vdpau = 'false'
408 endif
409 elif _vdpau == 'auto'
410 _vdpau = 'true'
411 endif
412 with_gallium_vdpau = _vdpau == 'true'
413 dep_vdpau = []
414 if with_gallium_vdpau
415 dep_vdpau = dependency('vdpau', version : '>= 1.1')
416 dep_vdpau = declare_dependency(
417 compile_args : run_command(prog_pkgconfig, ['vdpau', '--cflags']).stdout().split()
418 )
419 endif
420
421 if with_gallium_vdpau
422 pre_args += '-DHAVE_ST_VDPAU'
423 endif
424 vdpau_drivers_path = get_option('vdpau-libs-path')
425 if vdpau_drivers_path == ''
426 vdpau_drivers_path = join_paths(get_option('libdir'), 'vdpau')
427 endif
428
429 _xvmc = get_option('gallium-xvmc')
430 if not system_has_kms_drm
431 if _xvmc == 'true'
432 error('XVMC state tracker can only be build on unix-like OSes.')
433 else
434 _xvmc = 'false'
435 endif
436 elif not with_platform_x11
437 if _xvmc == 'true'
438 error('XVMC state tracker requires X11 support.')
439 else
440 _xvmc = 'false'
441 endif
442 elif not (with_gallium_r600 or with_gallium_nouveau)
443 if _xvmc == 'true'
444 error('XVMC state tracker requires at least one of the following gallium drivers: r600, nouveau.')
445 else
446 _xvmc = 'false'
447 endif
448 elif _xvmc == 'auto'
449 _xvmc = 'true'
450 endif
451 with_gallium_xvmc = _xvmc == 'true'
452 dep_xvmc = []
453 if with_gallium_xvmc
454 dep_xvmc = dependency('xvmc', version : '>= 1.0.6')
455 endif
456
457 xvmc_drivers_path = get_option('xvmc-libs-path')
458 if xvmc_drivers_path == ''
459 xvmc_drivers_path = get_option('libdir')
460 endif
461
462 _omx = get_option('gallium-omx')
463 if not system_has_kms_drm
464 if _omx == 'true'
465 error('OMX state tracker can only be built on unix-like OSes.')
466 else
467 _omx = 'false'
468 endif
469 elif not (with_platform_x11 or with_platform_drm)
470 if _omx == 'true'
471 error('OMX state tracker requires X11 or drm platform support.')
472 else
473 _omx = 'false'
474 endif
475 elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
476 if _omx == 'true'
477 error('OMX state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau.')
478 else
479 _omx = 'false'
480 endif
481 elif _omx == 'auto'
482 _omx = 'true'
483 endif
484 with_gallium_omx = _omx == 'true'
485 dep_omx = []
486 if with_gallium_omx
487 dep_omx = dependency('libomxil-bellagio')
488 endif
489
490 omx_drivers_path = get_option('omx-libs-path')
491 if with_gallium_omx
492 # Figure out where to put the omx driver.
493 # FIXME: this could all be vastly simplified by adding a 'defined_variable'
494 # argument to meson's get_pkgconfig_variable method.
495 if omx_drivers_path == ''
496 _omx_libdir = dep_omx.get_pkgconfig_variable('libdir')
497 _omx_drivers_dir = dep_omx.get_pkgconfig_variable('pluginsdir')
498 if _omx_libdir == get_option('libdir')
499 omx_drivers_path = _omx_drivers_dir
500 else
501 _omx_base_dir = []
502 # This will fail on windows. Does OMX run on windows?
503 _omx_libdir = _omx_libdir.split('/')
504 _omx_drivers_dir = _omx_drivers_dir.split('/')
505 foreach o : _omx_drivers_dir
506 if not _omx_libdir.contains(o)
507 _omx_base_dir += o
508 endif
509 endforeach
510 omx_drivers_path = join_paths(get_option('libdir'), _omx_base_dir)
511 endif
512 endif
513 endif
514
515 _va = get_option('gallium-va')
516 if not system_has_kms_drm
517 if _va == 'true'
518 error('VA state tracker can only be built on unix-like OSes.')
519 else
520 _va = 'false'
521 endif
522 elif not (with_platform_x11 or with_platform_drm)
523 if _va == 'true'
524 error('VA state tracker requires X11 or drm or wayland platform support.')
525 else
526 _va = 'false'
527 endif
528 elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
529 if _va == 'true'
530 error('VA state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau.')
531 else
532 _va = 'false'
533 endif
534 elif _va == 'auto'
535 _va = 'true'
536 endif
537 with_gallium_va = _va == 'true'
538 dep_va = []
539 if with_gallium_va
540 dep_va = dependency('libva', version : '>= 0.38.0')
541 dep_va_headers = declare_dependency(
542 compile_args : run_command(prog_pkgconfig, ['libva', '--cflags']).stdout().split()
543 )
544 endif
545
546 va_drivers_path = get_option('va-libs-path')
547 if va_drivers_path == ''
548 va_drivers_path = join_paths(get_option('libdir'), 'dri')
549 endif
550
551 _xa = get_option('gallium-xa')
552 if not system_has_kms_drm
553 if _xa == 'true'
554 error('XA state tracker can only be built on unix-like OSes.')
555 else
556 _xa = 'false'
557 endif
558 elif not (with_gallium_nouveau or with_gallium_freedreno or with_gallium_i915
559 or with_gallium_svga)
560 if _xa == 'true'
561 error('XA state tracker requires at least one of the following gallium drivers: nouveau, freedreno, i915, svga.')
562 else
563 _xa = 'false'
564 endif
565 endif
566 with_gallium_xa = _xa != 'false'
567
568 d3d_drivers_path = get_option('d3d-drivers-path')
569 if d3d_drivers_path == ''
570 d3d_drivers_path = join_paths(get_option('libdir'), 'd3d')
571 endif
572
573 with_gallium_st_nine = get_option('gallium-nine')
574 if with_gallium_st_nine
575 if not with_gallium_softpipe
576 error('The nine state tracker requires gallium softpipe/llvmpipe.')
577 elif not (with_gallium_radeonsi or with_gallium_nouveau or with_gallium_r600
578 or with_gallium_r300 or with_gallium_svga or with_gallium_i915)
579 error('The nine state tracker requires at least on non-swrast gallium driver.')
580 endif
581 if not with_dri3
582 error('Using nine with wine requires dri3')
583 endif
584 endif
585
586 _opencl = get_option('gallium-opencl')
587 if _opencl != 'disabled'
588 if not with_gallium
589 error('OpenCL Clover implementation requires at least one gallium driver.')
590 endif
591
592 # TODO: alitvec?
593 dep_clc = dependency('libclc')
594 with_gallium_opencl = true
595 with_opencl_icd = _opencl == 'icd'
596 else
597 dep_clc = []
598 with_gallium_opencl = false
599 with_gallium_icd = false
600 endif
601
602 gl_pkgconfig_c_flags = []
603 if with_platform_x11
604 if with_any_vk or (with_glx == 'dri' and with_dri_platform == 'drm')
605 pre_args += '-DHAVE_X11_PLATFORM'
606 endif
607 if with_glx == 'xlib' or with_glx == 'gallium-xlib'
608 pre_args += '-DUSE_XSHM'
609 else
610 pre_args += '-DGLX_INDIRECT_RENDERING'
611 if with_glx_direct
612 pre_args += '-DGLX_DIRECT_RENDERING'
613 endif
614 if with_dri_platform == 'drm'
615 pre_args += '-DGLX_USE_DRM'
616 elif with_dri_platform == 'apple'
617 pre_args += '-DGLX_USE_APPLEGL'
618 elif with_dri_platform == 'windows'
619 pre_args += '-DGLX_USE_WINDOWSGL'
620 endif
621 endif
622 else
623 pre_args += '-DMESA_EGL_NO_X11_HEADERS'
624 gl_pkgconfig_c_flags += '-DMESA_EGL_NO_X11_HEADERS'
625 endif
626 if with_platform_drm
627 if with_egl and not with_gbm
628 error('EGL drm platform requires gbm')
629 endif
630 pre_args += '-DHAVE_DRM_PLATFORM'
631 endif
632 if with_platform_surfaceless
633 pre_args += '-DHAVE_SURFACELESS_PLATFORM'
634 endif
635 if with_platform_android
636 dep_android = [
637 dependency('cutils'),
638 dependency('hardware'),
639 dependency('sync'),
640 ]
641 pre_args += '-DHAVE_ANDROID_PLATFORM'
642 endif
643
644 prog_python2 = find_program('python2')
645 has_mako = run_command(prog_python2, '-c', 'import mako')
646 if has_mako.returncode() != 0
647 error('Python (2.x) mako module required to build mesa.')
648 endif
649
650 cc = meson.get_compiler('c')
651 if cc.get_id() == 'gcc' and cc.version().version_compare('< 4.4.6')
652 error('When using GCC, version 4.4.6 or later is required.')
653 endif
654
655 # Define DEBUG for debug builds only (debugoptimized is not included on this one)
656 if get_option('buildtype') == 'debug'
657 pre_args += '-DDEBUG'
658 endif
659
660 if get_option('shader-cache')
661 pre_args += '-DENABLE_SHADER_CACHE'
662 elif with_amd_vk
663 error('Radv requires shader cache support')
664 endif
665
666 # Check for GCC style builtins
667 foreach b : ['bswap32', 'bswap64', 'clz', 'clzll', 'ctz', 'expect', 'ffs',
668 'ffsll', 'popcount', 'popcountll', 'unreachable']
669 if cc.has_function(b)
670 pre_args += '-DHAVE___BUILTIN_@0@'.format(b.to_upper())
671 endif
672 endforeach
673
674 # check for GCC __attribute__
675 foreach a : ['const', 'flatten', 'malloc', 'pure', 'unused',
676 'warn_unused_result', 'weak',]
677 if cc.compiles('int foo(void) __attribute__((@0@));'.format(a),
678 name : '__attribute__((@0@))'.format(a))
679 pre_args += '-DHAVE_FUNC_ATTRIBUTE_@0@'.format(a.to_upper())
680 endif
681 endforeach
682 if cc.compiles('int foo(const char *p, ...) __attribute__((format(printf, 1, 2)));',
683 name : '__attribute__((format(...)))')
684 pre_args += '-DHAVE_FUNC_ATTRIBUTE_FORMAT'
685 endif
686 if cc.compiles('struct __attribute__((packed)) foo { int bar; };',
687 name : '__attribute__((packed))')
688 pre_args += '-DHAVE_FUNC_ATTRIBUTE_PACKED'
689 endif
690 if cc.compiles('int *foo(void) __attribute__((returns_nonnull));',
691 name : '__attribute__((returns_nonnull))')
692 pre_args += '-DHAVE_FUNC_ATTRIBUTE_RETURNS_NONNULL'
693 endif
694 if cc.compiles('''int foo_def(void) __attribute__((visibility("default")));
695 int foo_hid(void) __attribute__((visibility("hidden")));
696 int foo_int(void) __attribute__((visibility("internal")));
697 int foo_pro(void) __attribute__((visibility("protected")));''',
698 name : '__attribute__((visibility(...)))')
699 pre_args += '-DHAVE_FUNC_ATTRIBUTE_VISIBILITY'
700 endif
701 if cc.compiles('int foo(void) { return 0; } int bar(void) __attribute__((alias("foo")));',
702 name : '__attribute__((alias(...)))')
703 pre_args += '-DHAVE_FUNC_ATTRIBUTE_ALIAS'
704 endif
705 if cc.compiles('int foo(void) __attribute__((__noreturn__));',
706 name : '__attribute__((__noreturn__))')
707 pre_args += '-DHAVE_FUNC_ATTRIBUTE_NORETURN'
708 endif
709
710 # TODO: this is very incomplete
711 if ['linux', 'cygwin'].contains(host_machine.system())
712 pre_args += '-D_GNU_SOURCE'
713 endif
714
715 # Check for generic C arguments
716 c_args = []
717 foreach a : ['-Wall', '-Werror=implicit-function-declaration',
718 '-Werror=missing-prototypes', '-fno-math-errno',
719 '-fno-trapping-math', '-Qunused-arguments']
720 if cc.has_argument(a)
721 c_args += a
722 endif
723 endforeach
724 c_vis_args = []
725 if cc.has_argument('-fvisibility=hidden')
726 c_vis_args += '-fvisibility=hidden'
727 endif
728
729 # Check for generic C++ arguments
730 cpp = meson.get_compiler('cpp')
731 cpp_args = []
732 foreach a : ['-Wall', '-fno-math-errno', '-fno-trapping-math',
733 '-Qunused-arguments']
734 if cpp.has_argument(a)
735 cpp_args += a
736 endif
737 endforeach
738
739 # For some reason, the test for -Wno-foo always succeeds with gcc, even if the
740 # option is not supported. Hence, check for -Wfoo instead.
741 if cpp.has_argument('-Wnon-virtual-dtor')
742 cpp_args += '-Wno-non-virtual-dtor'
743 endif
744
745 no_override_init_args = []
746 foreach a : ['override-init', 'initializer-overrides']
747 if cc.has_argument('-W' + a)
748 no_override_init_args += '-Wno-' + a
749 endif
750 endforeach
751
752 cpp_vis_args = []
753 if cpp.has_argument('-fvisibility=hidden')
754 cpp_vis_args += '-fvisibility=hidden'
755 endif
756
757 # Check for C and C++ arguments for MSVC2013 compatibility. These are only used
758 # in parts of the mesa code base that need to compile with old versions of
759 # MSVC, mainly common code
760 c_msvc_compat_args = []
761 cpp_msvc_compat_args = []
762 foreach a : ['-Werror=pointer-arith', '-Werror=vla']
763 if cc.has_argument(a)
764 c_msvc_compat_args += a
765 endif
766 if cpp.has_argument(a)
767 cpp_msvc_compat_args += a
768 endif
769 endforeach
770
771 if host_machine.cpu_family().startswith('x86')
772 pre_args += '-DUSE_SSE41'
773 with_sse41 = true
774 sse41_args = ['-msse4.1']
775
776 # GCC on x86 (not x86_64) with -msse* assumes a 16 byte aligned stack, but
777 # that's not guaranteed
778 if host_machine.cpu_family() == 'x86'
779 sse41_args += '-mstackrealign'
780 endif
781 else
782 with_sse41 = false
783 sse41_args = []
784 endif
785
786 # Check for GCC style atomics
787 if cc.compiles('int main() { int n; return __atomic_load_n(&n, __ATOMIC_ACQUIRE); }',
788 name : 'GCC atomic builtins')
789 pre_args += '-DUSE_GCC_ATOMIC_BUILTINS'
790 endif
791 if not cc.links('''#include <stdint.h>
792 uint64_t v;
793 int main() {
794 return __sync_add_and_fetch(&v, (uint64_t)1);
795 }''',
796 name : 'GCC 64bit atomics')
797 pre_args += '-DMISSING_64_BIT_ATOMICS'
798 endif
799
800 # TODO: endian
801 # TODO: powr8
802 # TODO: shared/static? Is this even worth doing?
803
804 # Building x86 assembly code requires running x86 binaries. It is possible for
805 # x86_64 OSes to run x86 binaries, so don't disable asm in those cases
806 # TODO: it should be possible to use an exe_wrapper to run the binary during
807 # the build.
808 if meson.is_cross_build()
809 if not (build_machine.cpu_family() == 'x86_64' and host_machine.cpu_family() == 'x86'
810 and build_machine.system() == host_machine.system())
811 message('Cross compiling to x86 from non-x86, disabling asm')
812 with_asm = false
813 endif
814 endif
815
816 with_asm_arch = ''
817 if with_asm
818 # TODO: SPARC and PPC
819 if host_machine.cpu_family() == 'x86'
820 if system_has_kms_drm
821 with_asm_arch = 'x86'
822 pre_args += ['-DUSE_X86_ASM', '-DUSE_MMX_ASM', '-DUSE_3DNOW_ASM',
823 '-DUSE_SSE_ASM']
824 endif
825 elif host_machine.cpu_family() == 'x86_64'
826 if system_has_kms_drm
827 with_asm_arch = 'x86_64'
828 pre_args += ['-DUSE_X86_64_ASM']
829 endif
830 elif host_machine.cpu_family() == 'arm'
831 if system_has_kms_drm
832 with_asm_arch = 'arm'
833 pre_args += ['-DUSE_ARM_ASM']
834 endif
835 elif host_machine.cpu_family() == 'aarch64'
836 if system_has_kms_drm
837 with_asm_arch = 'aarch64'
838 pre_args += ['-DUSE_AARCH64_ASM']
839 endif
840 endif
841 endif
842
843 # Check for standard headers and functions
844 if cc.has_header_symbol('sys/sysmacros.h', 'major')
845 pre_args += '-DMAJOR_IN_SYSMACROS'
846 elif cc.has_header_symbol('sys/mkdev.h', 'major')
847 pre_args += '-DMAJOR_IN_MKDEV'
848 endif
849
850 foreach h : ['xlocale.h', 'sys/sysctl.h', 'linux/futex.h']
851 if cc.has_header(h)
852 pre_args += '-DHAVE_@0@'.format(h.to_upper().underscorify())
853 endif
854 endforeach
855
856 foreach f : ['strtof', 'mkostemp', 'posix_memalign', 'timespec_get', 'memfd_create']
857 if cc.has_function(f)
858 pre_args += '-DHAVE_@0@'.format(f.to_upper())
859 endif
860 endforeach
861
862 # strtod locale support
863 if cc.links('''
864 #define _GNU_SOURCE
865 #include <stdlib.h>
866 #include <locale.h>
867 #ifdef HAVE_XLOCALE_H
868 #include <xlocale.h>
869 #endif
870 int main() {
871 locale_t loc = newlocale(LC_CTYPE_MASK, "C", NULL);
872 const char *s = "1.0";
873 char *end;
874 double d = strtod_l(s, end, loc);
875 float f = strtof_l(s, end, loc);
876 freelocale(loc);
877 return 0;
878 }''',
879 extra_args : pre_args,
880 name : 'strtod has locale support')
881 pre_args += '-DHAVE_STRTOD_L'
882 endif
883
884 # Check for some linker flags
885 ld_args_bsymbolic = []
886 if cc.links('int main() { return 0; }', args : '-Wl,-Bsymbolic', name : 'Bsymbolic')
887 ld_args_bsymbolic += '-Wl,-Bsymbolic'
888 endif
889 ld_args_gc_sections = []
890 if cc.links('static char unused() { return 5; } int main() { return 0; }',
891 args : '-Wl,--gc-sections', name : 'gc-sections')
892 ld_args_gc_sections += '-Wl,--gc-sections'
893 endif
894 with_ld_version_script = false
895 if cc.links('int main() { return 0; }',
896 args : '-Wl,--version-script=@0@'.format(
897 join_paths(meson.source_root(), 'build-support/conftest.map')),
898 name : 'version-script')
899 with_ld_version_script = true
900 endif
901 with_ld_dynamic_list = false
902 if cc.links('int main() { return 0; }',
903 args : '-Wl,--dynamic-list=@0@'.format(
904 join_paths(meson.source_root(), 'build-support/conftest.dyn')),
905 name : 'dynamic-list')
906 with_ld_dynamic_list = true
907 endif
908 ld_args_build_id = []
909 if build_machine.system() != 'darwin'
910 ld_args_build_id += '-Wl,--build-id=sha1'
911 endif
912
913 # check for dl support
914 if cc.has_function('dlopen')
915 dep_dl = []
916 else
917 dep_dl = cc.find_library('dl')
918 endif
919 if cc.has_function('dladdr', dependencies : dep_dl)
920 # This is really only required for megadrivers
921 pre_args += '-DHAVE_DLADDR'
922 endif
923
924 if cc.has_function('dl_iterate_phdr')
925 pre_args += '-DHAVE_DL_ITERATE_PHDR'
926 elif with_intel_vk
927 error('Intel "Anvil" Vulkan driver requires the dl_iterate_phdr function')
928 elif with_dri_i965 and get_option('shader-cache')
929 error('Intel i965 GL driver requires dl_iterate_phdr when built with shader caching.')
930 endif
931
932 # Determine whether or not the rt library is needed for time functions
933 if cc.has_function('clock_gettime')
934 dep_clock = []
935 else
936 dep_clock = cc.find_library('rt')
937 endif
938
939 with_gallium_drisw_kms = false
940 dep_libdrm = dependency('libdrm', version : '>= 2.4.75',
941 required : with_dri2 or with_dri3)
942 if dep_libdrm.found()
943 pre_args += '-DHAVE_LIBDRM'
944 if with_dri_platform == 'drm' and with_dri
945 with_gallium_drisw_kms = true
946 endif
947 endif
948
949 # TODO: some of these may be conditional
950 dep_zlib = dependency('zlib', version : '>= 1.2.3')
951 pre_args += '-DHAVE_ZLIB'
952 dep_thread = dependency('threads')
953 if dep_thread.found() and host_machine.system() != 'windows'
954 pre_args += '-DHAVE_PTHREAD'
955 endif
956 if with_amd_vk or with_gallium_radeonsi or with_gallium_r600 or with_gallium_opencl
957 dep_elf = dependency('libelf', required : false)
958 if not dep_elf.found()
959 dep_elf = cc.find_library('elf')
960 endif
961 else
962 dep_elf = []
963 endif
964 dep_expat = dependency('expat')
965 # this only exists on linux so either this is linux and it will be found, or
966 # its not linux and and wont
967 dep_m = cc.find_library('m', required : false)
968
969 dep_libdrm_amdgpu = []
970 dep_libdrm_radeon = []
971 dep_libdrm_nouveau = []
972 dep_libdrm_etnaviv = []
973 dep_libdrm_freedreno = []
974 if with_amd_vk or with_gallium_radeonsi
975 dep_libdrm_amdgpu = dependency('libdrm_amdgpu', version : '>= 2.4.89')
976 endif
977 if (with_gallium_radeonsi or with_dri_r100 or with_dri_r200 or
978 with_gallium_r300 or with_gallium_r600)
979 dep_libdrm_radeon = dependency('libdrm_radeon', version : '>= 2.4.71')
980 endif
981 if with_gallium_nouveau or with_dri_nouveau
982 dep_libdrm_nouveau = dependency('libdrm_nouveau', version : '>= 2.4.66')
983 endif
984 if with_gallium_etnaviv
985 dep_libdrm_etnaviv = dependency('libdrm_etnaviv', version : '>= 2.4.82')
986 endif
987 if with_gallium_freedreno
988 dep_libdrm_freedreno = dependency('libdrm_freedreno', version : '>= 2.4.89')
989 endif
990
991 llvm_modules = ['bitwriter', 'engine', 'mcdisassembler', 'mcjit']
992 if with_amd_vk or with_gallium_radeonsi or with_gallium_r600
993 llvm_modules += ['amdgpu', 'bitreader', 'ipo']
994 if with_gallium_r600
995 llvm_modules += 'asmparser'
996 endif
997 endif
998 if with_gallium_opencl
999 llvm_modules += [
1000 'all-targets', 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
1001 'lto', 'option', 'objcarcopts', 'profiledata',
1002 ]
1003 # TODO: optional modules
1004 endif
1005
1006 if with_amd_vk or with_gallium_radeonsi
1007 _llvm_version = '>= 4.0.0'
1008 elif with_gallium_opencl or with_gallium_swr or with_gallium_r600
1009 _llvm_version = '>= 3.9.0'
1010 else
1011 _llvm_version = '>= 3.3.0'
1012 endif
1013
1014 _llvm = get_option('llvm')
1015 if _llvm == 'auto'
1016 dep_llvm = dependency(
1017 'llvm', version : _llvm_version, modules : llvm_modules,
1018 required : with_amd_vk or with_gallium_radeonsi or with_gallium_swr or with_gallium_opencl,
1019 )
1020 with_llvm = dep_llvm.found()
1021 elif _llvm == 'true'
1022 dep_llvm = dependency('llvm', version : _llvm_version, modules : llvm_modules)
1023 with_llvm = true
1024 else
1025 dep_llvm = []
1026 with_llvm = false
1027 endif
1028 if with_llvm
1029 _llvm_version = dep_llvm.version().split('.')
1030 # Development versions of LLVM have an 'svn' or 'git' suffix, we don't want
1031 # that for our version checks.
1032 # svn suffixes are stripped by meson as of 0.43, and git suffixes are
1033 # strippped as of 0.44, but we support older meson versions.
1034 _llvm_patch = _llvm_version[2]
1035 if _llvm_patch.endswith('svn')
1036 _llvm_patch = _llvm_patch.split('s')[0]
1037 elif _llvm_patch.contains('git')
1038 _llvm_patch = _llvm_patch.split('g')[0]
1039 endif
1040 pre_args += [
1041 '-DHAVE_LLVM=0x0@0@0@1@'.format(_llvm_version[0], _llvm_version[1]),
1042 '-DMESA_LLVM_VERSION_PATCH=@0@'.format(_llvm_patch),
1043 ]
1044 elif with_amd_vk or with_gallium_radeonsi or with_gallium_swr
1045 error('The following drivers require LLVM: Radv, RadeonSI, SWR. One of these is enabled, but LLVM is disabled.')
1046 endif
1047
1048 dep_glvnd = []
1049 if with_glvnd
1050 dep_glvnd = dependency('libglvnd', version : '>= 0.2.0')
1051 pre_args += '-DUSE_LIBGLVND=1'
1052 endif
1053
1054 if with_valgrind != 'false'
1055 dep_valgrind = dependency('valgrind', required : with_valgrind == 'true')
1056 if dep_valgrind.found()
1057 pre_args += '-DHAVE_VALGRIND'
1058 endif
1059 else
1060 dep_valgrind = []
1061 endif
1062
1063 # pthread stubs. Lets not and say we didn't
1064
1065 prog_bison = find_program('bison', required : with_any_opengl)
1066 prog_flex = find_program('flex', required : with_any_opengl)
1067
1068 dep_selinux = []
1069 if get_option('selinux')
1070 dep_selinux = dependency('libselinux')
1071 pre_args += '-DMESA_SELINUX'
1072 endif
1073
1074 # TODO: llvm-prefix and llvm-shared-libs
1075
1076 if with_libunwind != 'false'
1077 dep_unwind = dependency('libunwind', required : with_libunwind == 'true')
1078 if dep_unwind.found()
1079 pre_args += '-DHAVE_LIBUNWIND'
1080 endif
1081 else
1082 dep_unwind = []
1083 endif
1084
1085 # TODO: gallium-hud
1086
1087 if with_osmesa != 'none'
1088 if with_osmesa == 'classic' and not with_dri_swrast
1089 error('OSMesa classic requires dri (classic) swrast.')
1090 endif
1091 if with_osmesa == 'gallium' and not with_gallium_softpipe
1092 error('OSMesa gallium requires gallium softpipe or llvmpipe.')
1093 endif
1094 osmesa_lib_name = 'OSMesa'
1095 osmesa_bits = get_option('osmesa-bits')
1096 if osmesa_bits != '8'
1097 if with_dri or with_glx != 'disabled'
1098 error('OSMesa bits must be 8 if building glx or dir based drivers')
1099 endif
1100 osmesa_lib_name = osmesa_lib_name + osmesa_bits
1101 pre_args += [
1102 '-DCHAN_BITS=@0@'.format(osmesa_bits), '-DDEFAULT_SOFTWARE_DEPTH_BITS=31'
1103 ]
1104 endif
1105 endif
1106
1107 # TODO: symbol mangling
1108
1109 if with_platform_wayland
1110 prog_wl_scanner = find_program('wayland-scanner')
1111 dep_wl_protocols = dependency('wayland-protocols', version : '>= 1.8')
1112 dep_wayland_client = dependency('wayland-client', version : '>=1.11')
1113 dep_wayland_server = dependency('wayland-server', version : '>=1.11')
1114 wayland_dmabuf_xml = join_paths(
1115 dep_wl_protocols.get_pkgconfig_variable('pkgdatadir'), 'unstable',
1116 'linux-dmabuf', 'linux-dmabuf-unstable-v1.xml'
1117 )
1118 pre_args += ['-DHAVE_WAYLAND_PLATFORM', '-DWL_HIDE_DEPRECATED']
1119 else
1120 prog_wl_scanner = []
1121 dep_wl_protocols = []
1122 dep_wayland_client = []
1123 dep_wayland_server = []
1124 wayland_dmabuf_xml = ''
1125 endif
1126
1127 dep_x11 = []
1128 dep_xext = []
1129 dep_xdamage = []
1130 dep_xfixes = []
1131 dep_x11_xcb = []
1132 dep_xcb = []
1133 dep_xcb_glx = []
1134 dep_xcb_dri2 = []
1135 dep_xcb_dri3 = []
1136 dep_dri2proto = []
1137 dep_glproto = []
1138 dep_xxf86vm = []
1139 dep_xcb_dri3 = []
1140 dep_xcb_present = []
1141 dep_xcb_sync = []
1142 dep_xcb_xfixes = []
1143 dep_xshmfence = []
1144 if with_platform_x11
1145 if with_glx == 'xlib' or with_glx == 'gallium-xlib'
1146 dep_x11 = dependency('x11')
1147 dep_xext = dependency('xext')
1148 dep_xcb = dependency('xcb')
1149 elif with_glx == 'dri'
1150 dep_x11 = dependency('x11')
1151 dep_xext = dependency('xext')
1152 dep_xdamage = dependency('xdamage', version : '>= 1.1')
1153 dep_xfixes = dependency('xfixes')
1154 dep_xcb_glx = dependency('xcb-glx', version : '>= 1.8.1')
1155 dep_xxf86vm = dependency('xxf86vm', required : false)
1156 endif
1157 if (with_any_vk or with_glx == 'dri' or
1158 (with_gallium_vdpau or with_gallium_xvmc or with_gallium_omx or
1159 with_gallium_xa))
1160 dep_xcb = dependency('xcb')
1161 dep_x11_xcb = dependency('x11-xcb')
1162 endif
1163 if with_any_vk or (with_glx == 'dri' and with_dri_platform == 'drm')
1164 dep_xcb_dri2 = dependency('xcb-dri2', version : '>= 1.8')
1165
1166 if with_dri3
1167 pre_args += '-DHAVE_DRI3'
1168 dep_xcb_dri3 = dependency('xcb-dri3')
1169 dep_xcb_present = dependency('xcb-present')
1170 dep_xcb_sync = dependency('xcb-sync')
1171 dep_xshmfence = dependency('xshmfence', version : '>= 1.1')
1172 endif
1173 endif
1174 if with_glx == 'dri'
1175 if with_dri_platform == 'drm'
1176 dep_dri2proto = dependency('dri2proto', version : '>= 2.8')
1177 endif
1178 dep_glproto = dependency('glproto', version : '>= 1.4.14')
1179 endif
1180 if with_egl
1181 dep_xcb_xfixes = dependency('xcb-xfixes')
1182 endif
1183 endif
1184
1185 if get_option('gallium-extra-hud')
1186 pre_args += '-DHAVE_GALLIUM_EXTRA_HUD=1'
1187 endif
1188
1189 _sensors = get_option('lmsensors')
1190 if _sensors != 'false'
1191 dep_lmsensors = cc.find_library('libsensors', required : _sensors == 'true')
1192 if dep_lmsensors.found()
1193 pre_args += '-DHAVE_LIBSENSORS=1'
1194 endif
1195 else
1196 dep_lmsensors = []
1197 endif
1198
1199 # TODO: gallium tests
1200
1201 # TODO: various libdirs
1202
1203 # TODO: gallium driver dirs
1204
1205 # FIXME: this is a workaround for #2326
1206 prog_touch = find_program('touch')
1207 dummy_cpp = custom_target(
1208 'dummy_cpp',
1209 output : 'dummy.cpp',
1210 command : [prog_touch, '@OUTPUT@'],
1211 )
1212
1213 foreach a : pre_args
1214 add_project_arguments(a, language : ['c', 'cpp'])
1215 endforeach
1216 foreach a : c_args
1217 add_project_arguments(a, language : ['c'])
1218 endforeach
1219 foreach a : cpp_args
1220 add_project_arguments(a, language : ['cpp'])
1221 endforeach
1222
1223 inc_include = include_directories('include')
1224
1225 gl_priv_reqs = [
1226 'x11', 'xext', 'xdamage >= 1.1', 'xfixes', 'x11-xcb', 'xcb',
1227 'xcb-glx >= 1.8.1']
1228 if dep_libdrm.found()
1229 gl_priv_reqs += 'libdrm >= 2.4.75'
1230 endif
1231 if dep_xxf86vm != [] and dep_xxf86vm.found()
1232 gl_priv_reqs += 'xxf86vm'
1233 endif
1234 if with_dri_platform == 'drm'
1235 gl_priv_reqs += 'xcb-dri2 >= 1.8'
1236 endif
1237
1238 gl_priv_libs = []
1239 if dep_thread.found()
1240 gl_priv_libs += ['-lpthread', '-pthread']
1241 endif
1242 if dep_m.found()
1243 gl_priv_libs += '-lm'
1244 endif
1245 if dep_dl != [] and dep_dl.found()
1246 gl_priv_libs += '-ldl'
1247 endif
1248
1249 pkg = import('pkgconfig')
1250
1251 subdir('include')
1252 subdir('bin')
1253 subdir('src')