meson: Add Haiku platform support v4
[mesa.git] / meson.build
1 # Copyright © 2017 Intel Corporation
2
3 # Permission is hereby granted, free of charge, to any person obtaining a copy
4 # of this software and associated documentation files (the "Software"), to deal
5 # in the Software without restriction, including without limitation the rights
6 # to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
7 # copies of the Software, and to permit persons to whom the Software is
8 # furnished to do so, subject to the following conditions:
9
10 # The above copyright notice and this permission notice shall be included in
11 # all copies or substantial portions of the Software.
12
13 # THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
14 # IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
15 # FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
16 # AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
17 # LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
18 # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
19 # SOFTWARE.
20
21 project(
22 'mesa',
23 ['c', 'cpp'],
24 version : run_command(
25 [find_program('python', 'python2', 'python3'), 'bin/meson_get_version.py']
26 ).stdout(),
27 license : 'MIT',
28 meson_version : '>= 0.42',
29 default_options : ['buildtype=debugoptimized', 'c_std=c99', 'cpp_std=c++11']
30 )
31
32 # Arguments for the preprocessor, put these in a separate array from the C and
33 # C++ (cpp in meson terminology) arguments since they need to be added to the
34 # default arguments for both C and C++.
35 pre_args = [
36 '-D__STDC_CONSTANT_MACROS',
37 '-D__STDC_FORMAT_MACROS',
38 '-D__STDC_LIMIT_MACROS',
39 '-DVERSION="@0@"'.format(meson.project_version()),
40 '-DPACKAGE_VERSION=VERSION',
41 '-DPACKAGE_BUGREPORT="https://bugs.freedesktop.org/enter_bug.cgi?product=Mesa"',
42 ]
43
44 with_vulkan_icd_dir = get_option('vulkan-icd-dir')
45 with_tests = get_option('build-tests')
46 with_valgrind = get_option('valgrind')
47 with_libunwind = get_option('libunwind')
48 with_asm = get_option('asm')
49 with_osmesa = get_option('osmesa')
50 with_swr_arches = get_option('swr-arches').split(',')
51 with_tools = get_option('tools').split(',')
52 if with_tools.contains('all')
53 with_tools = ['freedreno', 'glsl', 'intel', 'nir', 'nouveau']
54 endif
55 if get_option('texture-float')
56 pre_args += '-DTEXTURE_FLOAT_ENABLED'
57 message('WARNING: Floating-point texture enabled. Please consult docs/patents.txt and your lawyer before building mesa.')
58 endif
59
60 dri_drivers_path = get_option('dri-drivers-path')
61 if dri_drivers_path == ''
62 dri_drivers_path = join_paths(get_option('libdir'), 'dri')
63 endif
64 dri_search_path = get_option('dri-search-path')
65 if dri_search_path == ''
66 dri_search_path = join_paths(get_option('prefix'), dri_drivers_path)
67 endif
68
69 with_gles1 = get_option('gles1')
70 with_gles2 = get_option('gles2')
71 with_opengl = get_option('opengl')
72 with_any_opengl = with_opengl or with_gles1 or with_gles2
73 # Only build shared_glapi if at least one OpenGL API is enabled
74 with_shared_glapi = get_option('shared-glapi') and with_any_opengl
75
76
77 # shared-glapi is required if at least two OpenGL APIs are being built
78 if not with_shared_glapi
79 if ((with_gles1 and with_gles2) or (with_gles1 and with_opengl)
80 or (with_gles2 and with_opengl))
81 error('shared-glapi required for building two or more of OpenGL, OpenGL ES 1.x, OpenGL ES 2.x')
82 endif
83 endif
84
85 # We require OpenGL for OpenGL ES
86 if (with_gles1 or with_gles2) and not with_opengl
87 error('building OpenGL ES without OpenGL is not supported.')
88 endif
89
90 with_dri = false
91 with_dri_i915 = false
92 with_dri_i965 = false
93 with_dri_r100 = false
94 with_dri_r200 = false
95 with_dri_nouveau = false
96 with_dri_swrast = false
97 _drivers = get_option('dri-drivers')
98 if _drivers == 'auto'
99 if host_machine.system() == 'linux'
100 # TODO: PPC, Sparc
101 if ['x86', 'x86_64'].contains(host_machine.cpu_family())
102 _drivers = 'i915,i965,r100,r200,nouveau'
103 else
104 error('Unknown architecture. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.')
105 endif
106 elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
107 # only swrast would make sense here, but gallium swrast is a much better default
108 _drivers = ''
109 else
110 error('Unknown OS. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.')
111 endif
112 endif
113 if _drivers != ''
114 _split = _drivers.split(',')
115 with_dri_i915 = _split.contains('i915')
116 with_dri_i965 = _split.contains('i965')
117 with_dri_r100 = _split.contains('r100')
118 with_dri_r200 = _split.contains('r200')
119 with_dri_nouveau = _split.contains('nouveau')
120 with_dri_swrast = _split.contains('swrast')
121 with_dri = true
122 endif
123
124 with_gallium = false
125 with_gallium_pl111 = false
126 with_gallium_radeonsi = false
127 with_gallium_r300 = false
128 with_gallium_r600 = false
129 with_gallium_nouveau = false
130 with_gallium_freedreno = false
131 with_gallium_softpipe = false
132 with_gallium_vc4 = false
133 with_gallium_vc5 = false
134 with_gallium_etnaviv = false
135 with_gallium_imx = false
136 with_gallium_i915 = false
137 with_gallium_svga = false
138 with_gallium_virgl = false
139 with_gallium_swr = false
140 _drivers = get_option('gallium-drivers')
141 if _drivers == 'auto'
142 if host_machine.system() == 'linux'
143 # TODO: PPC, Sparc
144 if ['x86', 'x86_64'].contains(host_machine.cpu_family())
145 _drivers = 'r300,r600,radeonsi,nouveau,virgl,svga,swrast'
146 elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
147 _drivers = 'pl111,vc4,vc5,freedreno,etnaviv,imx,virgl,svga,swrast'
148 else
149 error('Unknown architecture. Please pass -Dgallium-drivers to set driver options. Patches gladly accepted to fix this.')
150 endif
151 elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
152 _drivers = 'swrast'
153 else
154 error('Unknown OS. Please pass -Dgallium-drivers to set driver options. Patches gladly accepted to fix this.')
155 endif
156 endif
157 if _drivers != ''
158 _split = _drivers.split(',')
159 with_gallium_pl111 = _split.contains('pl111')
160 with_gallium_radeonsi = _split.contains('radeonsi')
161 with_gallium_r300 = _split.contains('r300')
162 with_gallium_r600 = _split.contains('r600')
163 with_gallium_nouveau = _split.contains('nouveau')
164 with_gallium_freedreno = _split.contains('freedreno')
165 with_gallium_softpipe = _split.contains('swrast')
166 with_gallium_vc4 = _split.contains('vc4')
167 with_gallium_vc5 = _split.contains('vc5')
168 with_gallium_etnaviv = _split.contains('etnaviv')
169 with_gallium_imx = _split.contains('imx')
170 with_gallium_i915 = _split.contains('i915')
171 with_gallium_svga = _split.contains('svga')
172 with_gallium_virgl = _split.contains('virgl')
173 with_gallium_swr = _split.contains('swr')
174 with_gallium = true
175 endif
176
177 with_intel_vk = false
178 with_amd_vk = false
179 with_any_vk = false
180 _vulkan_drivers = get_option('vulkan-drivers')
181 if _vulkan_drivers == 'auto'
182 if host_machine.system() == 'linux'
183 if host_machine.cpu_family().startswith('x86')
184 _vulkan_drivers = 'amd,intel'
185 else
186 error('Unknown architecture. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.')
187 endif
188 elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
189 # No vulkan driver supports windows or macOS currently
190 _vulkan_drivers = ''
191 else
192 error('Unknown OS. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.')
193 endif
194 endif
195 if _vulkan_drivers != ''
196 _split = _vulkan_drivers.split(',')
197 with_intel_vk = _split.contains('intel')
198 with_amd_vk = _split.contains('amd')
199 with_any_vk = with_amd_vk or with_intel_vk
200 endif
201
202 if with_dri_swrast and (with_gallium_softpipe or with_gallium_swr)
203 error('Only one swrast provider can be built')
204 endif
205 if with_dri_i915 and with_gallium_i915
206 error('Only one i915 provider can be built')
207 endif
208 if with_gallium_imx and not with_gallium_etnaviv
209 error('IMX driver requires etnaviv driver')
210 endif
211 if with_gallium_pl111 and not with_gallium_vc4
212 error('pl111 driver requires vc4 driver')
213 endif
214
215 dep_libdrm_intel = []
216 if with_dri_i915 or with_gallium_i915
217 dep_libdrm_intel = dependency('libdrm_intel', version : '>= 2.4.75')
218 endif
219
220 system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'dragonfly', 'linux'].contains(host_machine.system())
221
222 if host_machine.system() == 'darwin'
223 with_dri_platform = 'apple'
224 elif ['windows', 'cygwin'].contains(host_machine.system())
225 with_dri_platform = 'windows'
226 elif system_has_kms_drm
227 with_dri_platform = 'drm'
228 else
229 # FIXME: haiku doesn't use dri, and xlib doesn't use dri, probably should
230 # assert here that one of those cases has been met.
231 # FIXME: GNU (hurd) ends up here as well, but meson doesn't officially
232 # support Hurd at time of writing (2017/11)
233 # FIXME: illumos ends up here as well
234 with_dri_platform = 'none'
235 endif
236
237 with_platform_android = false
238 with_platform_wayland = false
239 with_platform_x11 = false
240 with_platform_drm = false
241 with_platform_surfaceless = false
242 egl_native_platform = ''
243 _platforms = get_option('platforms')
244 if _platforms == 'auto'
245 if system_has_kms_drm
246 _platforms = 'x11,wayland,drm,surfaceless'
247 elif ['darwin', 'windows', 'cygwin'].contains(host_machine.system())
248 _platforms = 'x11,surfaceless'
249 elif ['haiku'].contains(host_machine.system())
250 _platforms = 'haiku'
251 else
252 error('Unknown OS. Please pass -Dplatforms to set platforms. Patches gladly accepted to fix this.')
253 endif
254 endif
255 if _platforms != ''
256 _split = _platforms.split(',')
257 with_platform_android = _split.contains('android')
258 with_platform_x11 = _split.contains('x11')
259 with_platform_wayland = _split.contains('wayland')
260 with_platform_drm = _split.contains('drm')
261 with_platform_haiku = _split.contains('haiku')
262 with_platform_surfaceless = _split.contains('surfaceless')
263 egl_native_platform = _split[0]
264 endif
265
266 with_glx = get_option('glx')
267 if with_glx == 'auto'
268 if with_dri
269 with_glx = 'dri'
270 elif with_platform_haiku
271 with_glx = 'disabled'
272 elif with_gallium
273 # Even when building just gallium drivers the user probably wants dri
274 with_glx = 'dri'
275 elif with_platform_x11 and with_any_opengl and not with_any_vk
276 # The automatic behavior should not be to turn on xlib based glx when
277 # building only vulkan drivers
278 with_glx = 'xlib'
279 else
280 with_glx = 'disabled'
281 endif
282 endif
283 if with_glx == 'dri'
284 if with_gallium
285 with_dri = true
286 endif
287 endif
288
289 if not (with_dri or with_gallium or with_glx == 'xlib' or with_glx == 'gallium-xlib')
290 with_gles1 = false
291 with_gles2 = false
292 with_opengl = false
293 with_any_opengl = false
294 with_shared_glapi = false
295 endif
296
297 with_gbm = get_option('gbm')
298 if with_gbm == 'auto' and with_dri # TODO: or gallium
299 with_gbm = system_has_kms_drm
300 elif with_gbm == 'true'
301 if not system_has_kms_drm
302 error('GBM only supports DRM/KMS platforms')
303 endif
304 with_gbm = true
305 else
306 with_gbm = false
307 endif
308
309 _egl = get_option('egl')
310 if _egl == 'auto'
311 with_egl = with_dri and with_shared_glapi and egl_native_platform != ''
312 elif _egl == 'true'
313 if not with_dri
314 error('EGL requires dri')
315 elif not with_shared_glapi
316 error('EGL requires shared-glapi')
317 elif egl_native_platform == ''
318 error('No platforms specified, consider -Dplatforms=drm,x11 at least')
319 endif
320 with_egl = true
321 else
322 with_egl = false
323 endif
324
325 if with_egl and not (with_platform_drm or with_platform_surfaceless)
326 if with_gallium_radeonsi
327 error('RadeonSI requires drm or surfaceless platform when using EGL')
328 endif
329 if with_gallium_virgl
330 error('Virgl requires drm or surfaceless platform when using EGL')
331 endif
332 endif
333
334 pre_args += '-DGLX_USE_TLS'
335 if with_glx != 'disabled'
336 if not (with_platform_x11 and with_any_opengl)
337 if with_glx == 'auto'
338 with_glx = 'disabled'
339 else
340 error('Cannot build GLX support without X11 platform support and at least one OpenGL API')
341 endif
342 elif with_glx == 'gallium-xlib'
343 if not with_gallium
344 error('Gallium-xlib based GLX requires at least one gallium driver')
345 elif not with_gallium_softpipe
346 error('Gallium-xlib based GLX requires softpipe or llvmpipe.')
347 elif with_dri
348 error('gallium-xlib conflicts with any dri driver')
349 endif
350 elif with_glx == 'xlib'
351 if with_dri
352 error('xlib conflicts with any dri driver')
353 endif
354 elif with_glx == 'dri' and not with_dri
355 error('dri based GLX requires at least one DRI driver')
356 endif
357 endif
358
359 with_glvnd = get_option('glvnd')
360 if with_glvnd
361 if with_glx == 'xlib' or with_glx == 'gallium-xlib'
362 error('Cannot build glvnd support for GLX that is not DRI based.')
363 elif with_glx == 'disabled' and not with_egl
364 error('glvnd requires DRI based GLX and/or EGL')
365 endif
366 endif
367
368 # TODO: toggle for this
369 with_glx_direct = true
370
371 if with_vulkan_icd_dir == ''
372 with_vulkan_icd_dir = join_paths(get_option('datadir'), 'vulkan/icd.d')
373 endif
374
375 with_dri2 = (with_dri or with_any_vk) and with_dri_platform == 'drm'
376 with_dri3 = get_option('dri3')
377 if with_dri3 == 'auto'
378 with_dri3 = system_has_kms_drm and with_dri2
379 else
380 with_dri3 = with_dri3 == 'true'
381 endif
382
383 if with_any_vk and (with_platform_x11 and not with_dri3)
384 error('Vulkan drivers require dri3 for X11 support')
385 endif
386 if with_dri or with_gallium
387 if with_glx == 'disabled' and not with_egl and not with_platform_haiku
388 error('building dri or gallium drivers require at least one window system')
389 endif
390 endif
391
392 prog_pkgconfig = find_program('pkg-config')
393
394 _vdpau = get_option('gallium-vdpau')
395 if not system_has_kms_drm
396 if _vdpau == 'true'
397 error('VDPAU state tracker can only be build on unix-like OSes.')
398 else
399 _vdpau = 'false'
400 endif
401 elif not with_platform_x11
402 if _vdpau == 'true'
403 error('VDPAU state tracker requires X11 support.')
404 else
405 _vdpau = 'false'
406 endif
407 elif not (with_gallium_r300 or with_gallium_r600 or with_gallium_radeonsi or
408 with_gallium_nouveau)
409 if _vdpau == 'true'
410 error('VDPAU state tracker requires at least one of the following gallium drivers: r300, r600, radeonsi, nouveau.')
411 else
412 _vdpau = 'false'
413 endif
414 elif _vdpau == 'auto'
415 _vdpau = 'true'
416 endif
417 with_gallium_vdpau = _vdpau == 'true'
418 dep_vdpau = []
419 if with_gallium_vdpau
420 dep_vdpau = dependency('vdpau', version : '>= 1.1')
421 dep_vdpau = declare_dependency(
422 compile_args : run_command(prog_pkgconfig, ['vdpau', '--cflags']).stdout().split()
423 )
424 endif
425
426 if with_gallium_vdpau
427 pre_args += '-DHAVE_ST_VDPAU'
428 endif
429 vdpau_drivers_path = get_option('vdpau-libs-path')
430 if vdpau_drivers_path == ''
431 vdpau_drivers_path = join_paths(get_option('libdir'), 'vdpau')
432 endif
433
434 _xvmc = get_option('gallium-xvmc')
435 if not system_has_kms_drm
436 if _xvmc == 'true'
437 error('XVMC state tracker can only be build on unix-like OSes.')
438 else
439 _xvmc = 'false'
440 endif
441 elif not with_platform_x11
442 if _xvmc == 'true'
443 error('XVMC state tracker requires X11 support.')
444 else
445 _xvmc = 'false'
446 endif
447 elif not (with_gallium_r600 or with_gallium_nouveau)
448 if _xvmc == 'true'
449 error('XVMC state tracker requires at least one of the following gallium drivers: r600, nouveau.')
450 else
451 _xvmc = 'false'
452 endif
453 elif _xvmc == 'auto'
454 _xvmc = 'true'
455 endif
456 with_gallium_xvmc = _xvmc == 'true'
457 dep_xvmc = []
458 if with_gallium_xvmc
459 dep_xvmc = dependency('xvmc', version : '>= 1.0.6')
460 endif
461
462 xvmc_drivers_path = get_option('xvmc-libs-path')
463 if xvmc_drivers_path == ''
464 xvmc_drivers_path = get_option('libdir')
465 endif
466
467 _omx = get_option('gallium-omx')
468 if not system_has_kms_drm
469 if _omx == 'true'
470 error('OMX state tracker can only be built on unix-like OSes.')
471 else
472 _omx = 'false'
473 endif
474 elif not (with_platform_x11 or with_platform_drm)
475 if _omx == 'true'
476 error('OMX state tracker requires X11 or drm platform support.')
477 else
478 _omx = 'false'
479 endif
480 elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
481 if _omx == 'true'
482 error('OMX state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau.')
483 else
484 _omx = 'false'
485 endif
486 elif _omx == 'auto'
487 _omx = 'true'
488 endif
489 with_gallium_omx = _omx == 'true'
490 dep_omx = []
491 if with_gallium_omx
492 dep_omx = dependency('libomxil-bellagio')
493 endif
494
495 omx_drivers_path = get_option('omx-libs-path')
496 if with_gallium_omx
497 # Figure out where to put the omx driver.
498 # FIXME: this could all be vastly simplified by adding a 'defined_variable'
499 # argument to meson's get_pkgconfig_variable method.
500 if omx_drivers_path == ''
501 _omx_libdir = dep_omx.get_pkgconfig_variable('libdir')
502 _omx_drivers_dir = dep_omx.get_pkgconfig_variable('pluginsdir')
503 if _omx_libdir == get_option('libdir')
504 omx_drivers_path = _omx_drivers_dir
505 else
506 _omx_base_dir = []
507 # This will fail on windows. Does OMX run on windows?
508 _omx_libdir = _omx_libdir.split('/')
509 _omx_drivers_dir = _omx_drivers_dir.split('/')
510 foreach o : _omx_drivers_dir
511 if not _omx_libdir.contains(o)
512 _omx_base_dir += o
513 endif
514 endforeach
515 omx_drivers_path = join_paths(get_option('libdir'), _omx_base_dir)
516 endif
517 endif
518 endif
519
520 _va = get_option('gallium-va')
521 if not system_has_kms_drm
522 if _va == 'true'
523 error('VA state tracker can only be built on unix-like OSes.')
524 else
525 _va = 'false'
526 endif
527 elif not (with_platform_x11 or with_platform_drm)
528 if _va == 'true'
529 error('VA state tracker requires X11 or drm or wayland platform support.')
530 else
531 _va = 'false'
532 endif
533 elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
534 if _va == 'true'
535 error('VA state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau.')
536 else
537 _va = 'false'
538 endif
539 elif _va == 'auto'
540 _va = 'true'
541 endif
542 with_gallium_va = _va == 'true'
543 dep_va = []
544 if with_gallium_va
545 dep_va = dependency('libva', version : '>= 0.38.0')
546 dep_va_headers = declare_dependency(
547 compile_args : run_command(prog_pkgconfig, ['libva', '--cflags']).stdout().split()
548 )
549 endif
550
551 va_drivers_path = get_option('va-libs-path')
552 if va_drivers_path == ''
553 va_drivers_path = join_paths(get_option('libdir'), 'dri')
554 endif
555
556 _xa = get_option('gallium-xa')
557 if not system_has_kms_drm
558 if _xa == 'true'
559 error('XA state tracker can only be built on unix-like OSes.')
560 else
561 _xa = 'false'
562 endif
563 elif not (with_gallium_nouveau or with_gallium_freedreno or with_gallium_i915
564 or with_gallium_svga)
565 if _xa == 'true'
566 error('XA state tracker requires at least one of the following gallium drivers: nouveau, freedreno, i915, svga.')
567 else
568 _xa = 'false'
569 endif
570 endif
571 with_gallium_xa = _xa != 'false'
572
573 d3d_drivers_path = get_option('d3d-drivers-path')
574 if d3d_drivers_path == ''
575 d3d_drivers_path = join_paths(get_option('libdir'), 'd3d')
576 endif
577
578 with_gallium_st_nine = get_option('gallium-nine')
579 if with_gallium_st_nine
580 if not with_gallium_softpipe
581 error('The nine state tracker requires gallium softpipe/llvmpipe.')
582 elif not (with_gallium_radeonsi or with_gallium_nouveau or with_gallium_r600
583 or with_gallium_r300 or with_gallium_svga or with_gallium_i915)
584 error('The nine state tracker requires at least on non-swrast gallium driver.')
585 endif
586 if not with_dri3
587 error('Using nine with wine requires dri3')
588 endif
589 endif
590
591 _opencl = get_option('gallium-opencl')
592 if _opencl != 'disabled'
593 if not with_gallium
594 error('OpenCL Clover implementation requires at least one gallium driver.')
595 endif
596
597 # TODO: alitvec?
598 dep_clc = dependency('libclc')
599 with_gallium_opencl = true
600 with_opencl_icd = _opencl == 'icd'
601 else
602 dep_clc = []
603 with_gallium_opencl = false
604 with_gallium_icd = false
605 endif
606
607 gl_pkgconfig_c_flags = []
608 if with_platform_x11
609 if with_any_vk or (with_glx == 'dri' and with_dri_platform == 'drm')
610 pre_args += '-DHAVE_X11_PLATFORM'
611 endif
612 if with_glx == 'xlib' or with_glx == 'gallium-xlib'
613 pre_args += '-DUSE_XSHM'
614 else
615 pre_args += '-DGLX_INDIRECT_RENDERING'
616 if with_glx_direct
617 pre_args += '-DGLX_DIRECT_RENDERING'
618 endif
619 if with_dri_platform == 'drm'
620 pre_args += '-DGLX_USE_DRM'
621 elif with_dri_platform == 'apple'
622 pre_args += '-DGLX_USE_APPLEGL'
623 elif with_dri_platform == 'windows'
624 pre_args += '-DGLX_USE_WINDOWSGL'
625 endif
626 endif
627 else
628 pre_args += '-DMESA_EGL_NO_X11_HEADERS'
629 gl_pkgconfig_c_flags += '-DMESA_EGL_NO_X11_HEADERS'
630 endif
631 if with_platform_drm
632 if with_egl and not with_gbm
633 error('EGL drm platform requires gbm')
634 endif
635 pre_args += '-DHAVE_DRM_PLATFORM'
636 endif
637 if with_platform_surfaceless
638 pre_args += '-DHAVE_SURFACELESS_PLATFORM'
639 endif
640 if with_platform_android
641 dep_android = [
642 dependency('cutils'),
643 dependency('hardware'),
644 dependency('sync'),
645 ]
646 pre_args += '-DHAVE_ANDROID_PLATFORM'
647 endif
648 if with_platform_haiku
649 pre_args += '-DHAVE_HAIKU_PLATFORM'
650 endif
651
652 prog_python2 = find_program('python2')
653 has_mako = run_command(prog_python2, '-c', 'import mako')
654 if has_mako.returncode() != 0
655 error('Python (2.x) mako module required to build mesa.')
656 endif
657
658 cc = meson.get_compiler('c')
659 if cc.get_id() == 'gcc' and cc.version().version_compare('< 4.4.6')
660 error('When using GCC, version 4.4.6 or later is required.')
661 endif
662
663 # Define DEBUG for debug builds only (debugoptimized is not included on this one)
664 if get_option('buildtype') == 'debug'
665 pre_args += '-DDEBUG'
666 endif
667
668 if get_option('shader-cache')
669 pre_args += '-DENABLE_SHADER_CACHE'
670 elif with_amd_vk
671 error('Radv requires shader cache support')
672 endif
673
674 # Check for GCC style builtins
675 foreach b : ['bswap32', 'bswap64', 'clz', 'clzll', 'ctz', 'expect', 'ffs',
676 'ffsll', 'popcount', 'popcountll', 'unreachable']
677 if cc.has_function(b)
678 pre_args += '-DHAVE___BUILTIN_@0@'.format(b.to_upper())
679 endif
680 endforeach
681
682 # check for GCC __attribute__
683 foreach a : ['const', 'flatten', 'malloc', 'pure', 'unused',
684 'warn_unused_result', 'weak',]
685 if cc.compiles('int foo(void) __attribute__((@0@));'.format(a),
686 name : '__attribute__((@0@))'.format(a))
687 pre_args += '-DHAVE_FUNC_ATTRIBUTE_@0@'.format(a.to_upper())
688 endif
689 endforeach
690 if cc.compiles('int foo(const char *p, ...) __attribute__((format(printf, 1, 2)));',
691 name : '__attribute__((format(...)))')
692 pre_args += '-DHAVE_FUNC_ATTRIBUTE_FORMAT'
693 endif
694 if cc.compiles('struct __attribute__((packed)) foo { int bar; };',
695 name : '__attribute__((packed))')
696 pre_args += '-DHAVE_FUNC_ATTRIBUTE_PACKED'
697 endif
698 if cc.compiles('int *foo(void) __attribute__((returns_nonnull));',
699 name : '__attribute__((returns_nonnull))')
700 pre_args += '-DHAVE_FUNC_ATTRIBUTE_RETURNS_NONNULL'
701 endif
702 if cc.compiles('''int foo_def(void) __attribute__((visibility("default")));
703 int foo_hid(void) __attribute__((visibility("hidden")));
704 int foo_int(void) __attribute__((visibility("internal")));
705 int foo_pro(void) __attribute__((visibility("protected")));''',
706 name : '__attribute__((visibility(...)))')
707 pre_args += '-DHAVE_FUNC_ATTRIBUTE_VISIBILITY'
708 endif
709 if cc.compiles('int foo(void) { return 0; } int bar(void) __attribute__((alias("foo")));',
710 name : '__attribute__((alias(...)))')
711 pre_args += '-DHAVE_FUNC_ATTRIBUTE_ALIAS'
712 endif
713 if cc.compiles('int foo(void) __attribute__((__noreturn__));',
714 name : '__attribute__((__noreturn__))')
715 pre_args += '-DHAVE_FUNC_ATTRIBUTE_NORETURN'
716 endif
717
718 # TODO: this is very incomplete
719 if ['linux', 'cygwin'].contains(host_machine.system())
720 pre_args += '-D_GNU_SOURCE'
721 endif
722
723 # Check for generic C arguments
724 c_args = []
725 foreach a : ['-Wall', '-Werror=implicit-function-declaration',
726 '-Werror=missing-prototypes', '-fno-math-errno',
727 '-fno-trapping-math', '-Qunused-arguments']
728 if cc.has_argument(a)
729 c_args += a
730 endif
731 endforeach
732 c_vis_args = []
733 if cc.has_argument('-fvisibility=hidden')
734 c_vis_args += '-fvisibility=hidden'
735 endif
736
737 # Check for generic C++ arguments
738 cpp = meson.get_compiler('cpp')
739 cpp_args = []
740 foreach a : ['-Wall', '-fno-math-errno', '-fno-trapping-math',
741 '-Qunused-arguments']
742 if cpp.has_argument(a)
743 cpp_args += a
744 endif
745 endforeach
746
747 # For some reason, the test for -Wno-foo always succeeds with gcc, even if the
748 # option is not supported. Hence, check for -Wfoo instead.
749 if cpp.has_argument('-Wnon-virtual-dtor')
750 cpp_args += '-Wno-non-virtual-dtor'
751 endif
752
753 no_override_init_args = []
754 foreach a : ['override-init', 'initializer-overrides']
755 if cc.has_argument('-W' + a)
756 no_override_init_args += '-Wno-' + a
757 endif
758 endforeach
759
760 cpp_vis_args = []
761 if cpp.has_argument('-fvisibility=hidden')
762 cpp_vis_args += '-fvisibility=hidden'
763 endif
764
765 # Check for C and C++ arguments for MSVC2013 compatibility. These are only used
766 # in parts of the mesa code base that need to compile with old versions of
767 # MSVC, mainly common code
768 c_msvc_compat_args = []
769 cpp_msvc_compat_args = []
770 foreach a : ['-Werror=pointer-arith', '-Werror=vla']
771 if cc.has_argument(a)
772 c_msvc_compat_args += a
773 endif
774 if cpp.has_argument(a)
775 cpp_msvc_compat_args += a
776 endif
777 endforeach
778
779 if host_machine.cpu_family().startswith('x86')
780 pre_args += '-DUSE_SSE41'
781 with_sse41 = true
782 sse41_args = ['-msse4.1']
783
784 # GCC on x86 (not x86_64) with -msse* assumes a 16 byte aligned stack, but
785 # that's not guaranteed
786 if host_machine.cpu_family() == 'x86'
787 sse41_args += '-mstackrealign'
788 endif
789 else
790 with_sse41 = false
791 sse41_args = []
792 endif
793
794 # Check for GCC style atomics
795 if cc.compiles('int main() { int n; return __atomic_load_n(&n, __ATOMIC_ACQUIRE); }',
796 name : 'GCC atomic builtins')
797 pre_args += '-DUSE_GCC_ATOMIC_BUILTINS'
798 endif
799 if not cc.links('''#include <stdint.h>
800 uint64_t v;
801 int main() {
802 return __sync_add_and_fetch(&v, (uint64_t)1);
803 }''',
804 name : 'GCC 64bit atomics')
805 pre_args += '-DMISSING_64_BIT_ATOMICS'
806 endif
807
808 # TODO: endian
809 # TODO: powr8
810 # TODO: shared/static? Is this even worth doing?
811
812 # Building x86 assembly code requires running x86 binaries. It is possible for
813 # x86_64 OSes to run x86 binaries, so don't disable asm in those cases
814 # TODO: it should be possible to use an exe_wrapper to run the binary during
815 # the build.
816 if meson.is_cross_build()
817 if not (build_machine.cpu_family() == 'x86_64' and host_machine.cpu_family() == 'x86'
818 and build_machine.system() == host_machine.system())
819 message('Cross compiling to x86 from non-x86, disabling asm')
820 with_asm = false
821 endif
822 endif
823
824 with_asm_arch = ''
825 if with_asm
826 # TODO: SPARC and PPC
827 if host_machine.cpu_family() == 'x86'
828 if system_has_kms_drm
829 with_asm_arch = 'x86'
830 pre_args += ['-DUSE_X86_ASM', '-DUSE_MMX_ASM', '-DUSE_3DNOW_ASM',
831 '-DUSE_SSE_ASM']
832 endif
833 elif host_machine.cpu_family() == 'x86_64'
834 if system_has_kms_drm
835 with_asm_arch = 'x86_64'
836 pre_args += ['-DUSE_X86_64_ASM']
837 endif
838 elif host_machine.cpu_family() == 'arm'
839 if system_has_kms_drm
840 with_asm_arch = 'arm'
841 pre_args += ['-DUSE_ARM_ASM']
842 endif
843 elif host_machine.cpu_family() == 'aarch64'
844 if system_has_kms_drm
845 with_asm_arch = 'aarch64'
846 pre_args += ['-DUSE_AARCH64_ASM']
847 endif
848 endif
849 endif
850
851 # Check for standard headers and functions
852 if cc.has_header_symbol('sys/sysmacros.h', 'major')
853 pre_args += '-DMAJOR_IN_SYSMACROS'
854 elif cc.has_header_symbol('sys/mkdev.h', 'major')
855 pre_args += '-DMAJOR_IN_MKDEV'
856 endif
857
858 foreach h : ['xlocale.h', 'sys/sysctl.h', 'linux/futex.h']
859 if cc.has_header(h)
860 pre_args += '-DHAVE_@0@'.format(h.to_upper().underscorify())
861 endif
862 endforeach
863
864 foreach f : ['strtof', 'mkostemp', 'posix_memalign', 'timespec_get', 'memfd_create']
865 if cc.has_function(f)
866 pre_args += '-DHAVE_@0@'.format(f.to_upper())
867 endif
868 endforeach
869
870 # strtod locale support
871 if cc.links('''
872 #define _GNU_SOURCE
873 #include <stdlib.h>
874 #include <locale.h>
875 #ifdef HAVE_XLOCALE_H
876 #include <xlocale.h>
877 #endif
878 int main() {
879 locale_t loc = newlocale(LC_CTYPE_MASK, "C", NULL);
880 const char *s = "1.0";
881 char *end;
882 double d = strtod_l(s, end, loc);
883 float f = strtof_l(s, end, loc);
884 freelocale(loc);
885 return 0;
886 }''',
887 extra_args : pre_args,
888 name : 'strtod has locale support')
889 pre_args += '-DHAVE_STRTOD_L'
890 endif
891
892 # Check for some linker flags
893 ld_args_bsymbolic = []
894 if cc.links('int main() { return 0; }', args : '-Wl,-Bsymbolic', name : 'Bsymbolic')
895 ld_args_bsymbolic += '-Wl,-Bsymbolic'
896 endif
897 ld_args_gc_sections = []
898 if cc.links('static char unused() { return 5; } int main() { return 0; }',
899 args : '-Wl,--gc-sections', name : 'gc-sections')
900 ld_args_gc_sections += '-Wl,--gc-sections'
901 endif
902 with_ld_version_script = false
903 if cc.links('int main() { return 0; }',
904 args : '-Wl,--version-script=@0@'.format(
905 join_paths(meson.source_root(), 'build-support/conftest.map')),
906 name : 'version-script')
907 with_ld_version_script = true
908 endif
909 with_ld_dynamic_list = false
910 if cc.links('int main() { return 0; }',
911 args : '-Wl,--dynamic-list=@0@'.format(
912 join_paths(meson.source_root(), 'build-support/conftest.dyn')),
913 name : 'dynamic-list')
914 with_ld_dynamic_list = true
915 endif
916 ld_args_build_id = []
917 if build_machine.system() != 'darwin'
918 ld_args_build_id += '-Wl,--build-id=sha1'
919 endif
920
921 # check for dl support
922 if cc.has_function('dlopen')
923 dep_dl = []
924 else
925 dep_dl = cc.find_library('dl')
926 endif
927 if cc.has_function('dladdr', dependencies : dep_dl)
928 # This is really only required for megadrivers
929 pre_args += '-DHAVE_DLADDR'
930 endif
931
932 if cc.has_function('dl_iterate_phdr')
933 pre_args += '-DHAVE_DL_ITERATE_PHDR'
934 elif with_intel_vk
935 error('Intel "Anvil" Vulkan driver requires the dl_iterate_phdr function')
936 elif with_dri_i965 and get_option('shader-cache')
937 error('Intel i965 GL driver requires dl_iterate_phdr when built with shader caching.')
938 endif
939
940 # Determine whether or not the rt library is needed for time functions
941 if cc.has_function('clock_gettime')
942 dep_clock = []
943 else
944 dep_clock = cc.find_library('rt')
945 endif
946
947 with_gallium_drisw_kms = false
948 dep_libdrm = dependency('libdrm', version : '>= 2.4.75',
949 required : with_dri2 or with_dri3)
950 if dep_libdrm.found()
951 pre_args += '-DHAVE_LIBDRM'
952 if with_dri_platform == 'drm' and with_dri
953 with_gallium_drisw_kms = true
954 endif
955 endif
956
957 # TODO: some of these may be conditional
958 dep_zlib = dependency('zlib', version : '>= 1.2.3')
959 pre_args += '-DHAVE_ZLIB'
960 dep_thread = dependency('threads')
961 if dep_thread.found() and host_machine.system() != 'windows'
962 pre_args += '-DHAVE_PTHREAD'
963 endif
964 if with_amd_vk or with_gallium_radeonsi or with_gallium_r600 or with_gallium_opencl
965 dep_elf = dependency('libelf', required : false)
966 if not dep_elf.found()
967 dep_elf = cc.find_library('elf')
968 endif
969 else
970 dep_elf = []
971 endif
972 dep_expat = dependency('expat')
973 # this only exists on linux so either this is linux and it will be found, or
974 # its not linux and and wont
975 dep_m = cc.find_library('m', required : false)
976
977 dep_libdrm_amdgpu = []
978 dep_libdrm_radeon = []
979 dep_libdrm_nouveau = []
980 dep_libdrm_etnaviv = []
981 dep_libdrm_freedreno = []
982 if with_amd_vk or with_gallium_radeonsi
983 dep_libdrm_amdgpu = dependency('libdrm_amdgpu', version : '>= 2.4.89')
984 endif
985 if (with_gallium_radeonsi or with_dri_r100 or with_dri_r200 or
986 with_gallium_r300 or with_gallium_r600)
987 dep_libdrm_radeon = dependency('libdrm_radeon', version : '>= 2.4.71')
988 endif
989 if with_gallium_nouveau or with_dri_nouveau
990 dep_libdrm_nouveau = dependency('libdrm_nouveau', version : '>= 2.4.66')
991 endif
992 if with_gallium_etnaviv
993 dep_libdrm_etnaviv = dependency('libdrm_etnaviv', version : '>= 2.4.82')
994 endif
995 if with_gallium_freedreno
996 dep_libdrm_freedreno = dependency('libdrm_freedreno', version : '>= 2.4.89')
997 endif
998
999 llvm_modules = ['bitwriter', 'engine', 'mcdisassembler', 'mcjit']
1000 if with_amd_vk or with_gallium_radeonsi or with_gallium_r600
1001 llvm_modules += ['amdgpu', 'bitreader', 'ipo']
1002 if with_gallium_r600
1003 llvm_modules += 'asmparser'
1004 endif
1005 endif
1006 if with_gallium_opencl
1007 llvm_modules += [
1008 'all-targets', 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
1009 'lto', 'option', 'objcarcopts', 'profiledata',
1010 ]
1011 # TODO: optional modules
1012 endif
1013
1014 if with_amd_vk or with_gallium_radeonsi
1015 _llvm_version = '>= 4.0.0'
1016 elif with_gallium_opencl or with_gallium_swr or with_gallium_r600
1017 _llvm_version = '>= 3.9.0'
1018 else
1019 _llvm_version = '>= 3.3.0'
1020 endif
1021
1022 _llvm = get_option('llvm')
1023 if _llvm == 'auto'
1024 dep_llvm = dependency(
1025 'llvm', version : _llvm_version, modules : llvm_modules,
1026 required : with_amd_vk or with_gallium_radeonsi or with_gallium_swr or with_gallium_opencl,
1027 )
1028 with_llvm = dep_llvm.found()
1029 elif _llvm == 'true'
1030 dep_llvm = dependency('llvm', version : _llvm_version, modules : llvm_modules)
1031 with_llvm = true
1032 else
1033 dep_llvm = []
1034 with_llvm = false
1035 endif
1036 if with_llvm
1037 _llvm_version = dep_llvm.version().split('.')
1038 # Development versions of LLVM have an 'svn' or 'git' suffix, we don't want
1039 # that for our version checks.
1040 # svn suffixes are stripped by meson as of 0.43, and git suffixes are
1041 # strippped as of 0.44, but we support older meson versions.
1042 _llvm_patch = _llvm_version[2]
1043 if _llvm_patch.endswith('svn')
1044 _llvm_patch = _llvm_patch.split('s')[0]
1045 elif _llvm_patch.contains('git')
1046 _llvm_patch = _llvm_patch.split('g')[0]
1047 endif
1048 pre_args += [
1049 '-DHAVE_LLVM=0x0@0@0@1@'.format(_llvm_version[0], _llvm_version[1]),
1050 '-DMESA_LLVM_VERSION_PATCH=@0@'.format(_llvm_patch),
1051 ]
1052 elif with_amd_vk or with_gallium_radeonsi or with_gallium_swr
1053 error('The following drivers require LLVM: Radv, RadeonSI, SWR. One of these is enabled, but LLVM is disabled.')
1054 endif
1055
1056 dep_glvnd = []
1057 if with_glvnd
1058 dep_glvnd = dependency('libglvnd', version : '>= 0.2.0')
1059 pre_args += '-DUSE_LIBGLVND=1'
1060 endif
1061
1062 if with_valgrind != 'false'
1063 dep_valgrind = dependency('valgrind', required : with_valgrind == 'true')
1064 if dep_valgrind.found()
1065 pre_args += '-DHAVE_VALGRIND'
1066 endif
1067 else
1068 dep_valgrind = []
1069 endif
1070
1071 # pthread stubs. Lets not and say we didn't
1072
1073 prog_bison = find_program('bison', required : with_any_opengl)
1074 prog_flex = find_program('flex', required : with_any_opengl)
1075
1076 dep_selinux = []
1077 if get_option('selinux')
1078 dep_selinux = dependency('libselinux')
1079 pre_args += '-DMESA_SELINUX'
1080 endif
1081
1082 # TODO: llvm-prefix and llvm-shared-libs
1083
1084 if with_libunwind != 'false'
1085 dep_unwind = dependency('libunwind', required : with_libunwind == 'true')
1086 if dep_unwind.found()
1087 pre_args += '-DHAVE_LIBUNWIND'
1088 endif
1089 else
1090 dep_unwind = []
1091 endif
1092
1093 # TODO: gallium-hud
1094
1095 if with_osmesa != 'none'
1096 if with_osmesa == 'classic' and not with_dri_swrast
1097 error('OSMesa classic requires dri (classic) swrast.')
1098 endif
1099 if with_osmesa == 'gallium' and not with_gallium_softpipe
1100 error('OSMesa gallium requires gallium softpipe or llvmpipe.')
1101 endif
1102 osmesa_lib_name = 'OSMesa'
1103 osmesa_bits = get_option('osmesa-bits')
1104 if osmesa_bits != '8'
1105 if with_dri or with_glx != 'disabled'
1106 error('OSMesa bits must be 8 if building glx or dir based drivers')
1107 endif
1108 osmesa_lib_name = osmesa_lib_name + osmesa_bits
1109 pre_args += [
1110 '-DCHAN_BITS=@0@'.format(osmesa_bits), '-DDEFAULT_SOFTWARE_DEPTH_BITS=31'
1111 ]
1112 endif
1113 endif
1114
1115 # TODO: symbol mangling
1116
1117 if with_platform_wayland
1118 prog_wl_scanner = find_program('wayland-scanner')
1119 dep_wl_protocols = dependency('wayland-protocols', version : '>= 1.8')
1120 dep_wayland_client = dependency('wayland-client', version : '>=1.11')
1121 dep_wayland_server = dependency('wayland-server', version : '>=1.11')
1122 wayland_dmabuf_xml = join_paths(
1123 dep_wl_protocols.get_pkgconfig_variable('pkgdatadir'), 'unstable',
1124 'linux-dmabuf', 'linux-dmabuf-unstable-v1.xml'
1125 )
1126 pre_args += ['-DHAVE_WAYLAND_PLATFORM', '-DWL_HIDE_DEPRECATED']
1127 else
1128 prog_wl_scanner = []
1129 dep_wl_protocols = []
1130 dep_wayland_client = []
1131 dep_wayland_server = []
1132 wayland_dmabuf_xml = ''
1133 endif
1134
1135 dep_x11 = []
1136 dep_xext = []
1137 dep_xdamage = []
1138 dep_xfixes = []
1139 dep_x11_xcb = []
1140 dep_xcb = []
1141 dep_xcb_glx = []
1142 dep_xcb_dri2 = []
1143 dep_xcb_dri3 = []
1144 dep_dri2proto = []
1145 dep_glproto = []
1146 dep_xxf86vm = []
1147 dep_xcb_dri3 = []
1148 dep_xcb_present = []
1149 dep_xcb_sync = []
1150 dep_xcb_xfixes = []
1151 dep_xshmfence = []
1152 if with_platform_x11
1153 if with_glx == 'xlib' or with_glx == 'gallium-xlib'
1154 dep_x11 = dependency('x11')
1155 dep_xext = dependency('xext')
1156 dep_xcb = dependency('xcb')
1157 elif with_glx == 'dri'
1158 dep_x11 = dependency('x11')
1159 dep_xext = dependency('xext')
1160 dep_xdamage = dependency('xdamage', version : '>= 1.1')
1161 dep_xfixes = dependency('xfixes')
1162 dep_xcb_glx = dependency('xcb-glx', version : '>= 1.8.1')
1163 dep_xxf86vm = dependency('xxf86vm', required : false)
1164 endif
1165 if (with_any_vk or with_glx == 'dri' or
1166 (with_gallium_vdpau or with_gallium_xvmc or with_gallium_omx or
1167 with_gallium_xa))
1168 dep_xcb = dependency('xcb')
1169 dep_x11_xcb = dependency('x11-xcb')
1170 endif
1171 if with_any_vk or (with_glx == 'dri' and with_dri_platform == 'drm')
1172 dep_xcb_dri2 = dependency('xcb-dri2', version : '>= 1.8')
1173
1174 if with_dri3
1175 pre_args += '-DHAVE_DRI3'
1176 dep_xcb_dri3 = dependency('xcb-dri3')
1177 dep_xcb_present = dependency('xcb-present')
1178 dep_xcb_sync = dependency('xcb-sync')
1179 dep_xshmfence = dependency('xshmfence', version : '>= 1.1')
1180 endif
1181 endif
1182 if with_glx == 'dri'
1183 if with_dri_platform == 'drm'
1184 dep_dri2proto = dependency('dri2proto', version : '>= 2.8')
1185 endif
1186 dep_glproto = dependency('glproto', version : '>= 1.4.14')
1187 endif
1188 if with_egl
1189 dep_xcb_xfixes = dependency('xcb-xfixes')
1190 endif
1191 endif
1192
1193 if get_option('gallium-extra-hud')
1194 pre_args += '-DHAVE_GALLIUM_EXTRA_HUD=1'
1195 endif
1196
1197 _sensors = get_option('lmsensors')
1198 if _sensors != 'false'
1199 dep_lmsensors = cc.find_library('libsensors', required : _sensors == 'true')
1200 if dep_lmsensors.found()
1201 pre_args += '-DHAVE_LIBSENSORS=1'
1202 endif
1203 else
1204 dep_lmsensors = []
1205 endif
1206
1207 # TODO: gallium tests
1208
1209 # TODO: various libdirs
1210
1211 # TODO: gallium driver dirs
1212
1213 # FIXME: this is a workaround for #2326
1214 prog_touch = find_program('touch')
1215 dummy_cpp = custom_target(
1216 'dummy_cpp',
1217 output : 'dummy.cpp',
1218 command : [prog_touch, '@OUTPUT@'],
1219 )
1220
1221 foreach a : pre_args
1222 add_project_arguments(a, language : ['c', 'cpp'])
1223 endforeach
1224 foreach a : c_args
1225 add_project_arguments(a, language : ['c'])
1226 endforeach
1227 foreach a : cpp_args
1228 add_project_arguments(a, language : ['cpp'])
1229 endforeach
1230
1231 inc_include = include_directories('include')
1232
1233 gl_priv_reqs = [
1234 'x11', 'xext', 'xdamage >= 1.1', 'xfixes', 'x11-xcb', 'xcb',
1235 'xcb-glx >= 1.8.1']
1236 if dep_libdrm.found()
1237 gl_priv_reqs += 'libdrm >= 2.4.75'
1238 endif
1239 if dep_xxf86vm != [] and dep_xxf86vm.found()
1240 gl_priv_reqs += 'xxf86vm'
1241 endif
1242 if with_dri_platform == 'drm'
1243 gl_priv_reqs += 'xcb-dri2 >= 1.8'
1244 endif
1245
1246 gl_priv_libs = []
1247 if dep_thread.found()
1248 gl_priv_libs += ['-lpthread', '-pthread']
1249 endif
1250 if dep_m.found()
1251 gl_priv_libs += '-lm'
1252 endif
1253 if dep_dl != [] and dep_dl.found()
1254 gl_priv_libs += '-ldl'
1255 endif
1256
1257 pkg = import('pkgconfig')
1258
1259 subdir('include')
1260 subdir('bin')
1261 subdir('src')