specs: Remove GLES profile interaction text from GLX_MESA_query_renderer
[mesa.git] / docs / specs / MESA_query_renderer.spec
index bf0975669ab85558584084cec00fa7b25556c9e6..3b4a445cf8891757622f1c76cfb02d17f78f7de0 100644 (file)
@@ -16,11 +16,11 @@ IP Status
 
 Status
 
-    Incomplete.  DO NOT SHIP.
+    Shipping as of Mesa 10.0
 
 Version
 
-    Version 6, 7-November-2013
+    Version 8, 14-February-2014
 
 Number
 
@@ -32,9 +32,6 @@ Dependencies
 
     GLX_ARB_create_context and GLX_ARB_create_context_profile are required.
 
-    This extension interacts with GLX_EXT_create_context_es2_profile and
-    GLX_EXT_create_context_es_profile.
-
 Overview
 
     In many situations, applications want to detect characteristics of a
@@ -211,7 +208,7 @@ Additions to the GLX 1.4 Specification
 
     The attribute name GLX_RENDERER_ID_MESA specified the index of the render
     against which the context should be created.  The default value of
-    GLX_RENDER_ID_MESA is 0.
+    GLX_RENDERER_ID_MESA is 0.
 
 
     [Add to list of errors for glXCreateContextAttribsARB in section section
@@ -220,15 +217,6 @@ Additions to the GLX 1.4 Specification
       * If the value of GLX_RENDERER_ID_MESA specifies a non-existent
         renderer, BadMatch is generated.
 
-Dependencies on GLX_EXT_create_context_es_profile and
-GLX_EXT_create_context_es2_profile
-
-    If neither extension is supported, remove all mention of
-    GLX_RENDERER_OPENGL_ES2_PROFILE_VERSION_MESA from the spec.
-
-    If GLX_EXT_create_context_es_profile is not supported, remove all mention of
-    GLX_RENDERER_OPENGL_ES_PROFILE_VERSION_MESA from the spec.
-
 Issues
 
     1) How should the difference between on-card and GART memory be exposed?
@@ -373,7 +361,7 @@ Issues
         should make every attempt to return as much information as is
         possible.  For example, if the implementation is running on a non-PCI
         SoC with a Qualcomm GPU, GLX_RENDERER_VENDOR_ID_MESA should return
-        0x168C, but GLX_RENDERER_DEVICE_ID_MESA will return 0x0000.
+        0x5143, but GLX_RENDERER_DEVICE_ID_MESA will return 0xFFFFFFFF.
 
 Revision History
 
@@ -403,3 +391,8 @@ Revision History
 
     Version 7, 2013/11/07 - Fix a couple more typos.  Add issue #17 regarding
                             the PCI queries on systems that don't have PCI.
+
+    Version 8, 2014/02/14 - Fix a couple typos. GLX_RENDER_ID_MESA should
+                            read GLX_RENDERER_ID_MESA. The VENDOR/DEVICE_ID
+                            example given in issue #17 should be 0x5143 and
+                            0xFFFFFFFF respectively.