panfrost: Add optional opaque packs to GenXML
[mesa.git] / include / meson.build
index 149b122236b66f8ab20ffab10a308079d9a2bde9..981ab97913fe800336ed21ee5e58a0d033115ad8 100644 (file)
 # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
 # SOFTWARE.
 
-inc_include = include_directories('.')
+inc_include = [include_directories('.')]
 inc_d3d9 = include_directories('D3D9')
 inc_haikugl = include_directories('HaikuGL')
 
-if with_gles1 or with_gles2 or with_opengl or with_egl
-  install_headers('KHR/khrplatform.h', subdir : 'KHR')
+# Most things assume that Android headers are in the default include
+# path when compiling for Android so add the stub headers to
+# inc_include when using the stub.
+if with_android_stub
+  inc_include += [include_directories('android_stub')]
 endif
 
-if with_gles1
-  install_headers(
-    'GLES/egl.h',
-    'GLES/gl.h',
-    'GLES/glext.h',
-    'GLES/glplatform.h',
-    subdir : 'GLES',
-  )
-endif
-
-if with_gles2
-  install_headers(
-    'GLES2/gl2.h',
-    'GLES2/gl2ext.h',
-    'GLES2/gl2platform.h',
-    subdir : 'GLES2',
-  )
-  install_headers(
-    'GLES3/gl3.h',
-    'GLES3/gl31.h',
-    'GLES3/gl32.h',
-    'GLES3/gl3ext.h',
-    'GLES3/gl3platform.h',
-    subdir : 'GLES3',
-  )
-endif
-
-if with_opengl
-  install_headers(
-    'GL/gl.h',
-    'GL/glcorearb.h',
-    'GL/glext.h',
-    subdir : 'GL',
-  )
-endif
-
-if with_glx != 'disabled'
-  install_headers(
-    'GL/glx.h',
-    'GL/glxext.h',
-    subdir : 'GL')
-endif
-
-if with_egl
-  install_headers(
-    'EGL/egl.h',
-    'EGL/eglext.h',
-    'EGL/eglplatform.h',
-    subdir : 'EGL',
-  )
+if not with_glvnd
+  if with_gles1 or with_gles2 or with_opengl or with_egl
+    install_headers('KHR/khrplatform.h', subdir : 'KHR')
+  endif
+
+  if with_gles1
+    install_headers(
+      'GLES/egl.h',
+      'GLES/gl.h',
+      'GLES/glext.h',
+      'GLES/glplatform.h',
+      subdir : 'GLES',
+    )
+  endif
+
+  if with_gles2
+    install_headers(
+      'GLES2/gl2.h',
+      'GLES2/gl2ext.h',
+      'GLES2/gl2platform.h',
+      subdir : 'GLES2',
+    )
+    install_headers(
+      'GLES3/gl3.h',
+      'GLES3/gl31.h',
+      'GLES3/gl32.h',
+      'GLES3/gl3ext.h',
+      'GLES3/gl3platform.h',
+      subdir : 'GLES3',
+    )
+  endif
+
+  if with_opengl
+    install_headers(
+      'GL/gl.h',
+      'GL/glcorearb.h',
+      'GL/glext.h',
+      subdir : 'GL',
+    )
+  endif
+
+  if with_glx != 'disabled'
+    install_headers(
+      'GL/glx.h',
+      'GL/glxext.h',
+      subdir : 'GL')
+  endif
+
+  if with_egl
+    install_headers(
+      'EGL/egl.h',
+      'EGL/eglext.h',
+      'EGL/eglplatform.h',
+      subdir : 'EGL',
+    )
+  endif
 endif
 
 # Non-upstream headers
@@ -125,6 +134,7 @@ if with_gallium_opencl and not with_opencl_icd
     'CL/cl_ext_intel.h',
     'CL/cl_gl.h',
     'CL/cl_gl_ext.h',
+    'CL/cl_icd.h',
     'CL/cl_platform.h',
     'CL/cl_va_api_media_sharing_intel.h',
     'CL/cl_version.h',