meson: build clover
[mesa.git] / include / meson.build
index e4dae91cede1d55d981607f13b62b5e05fd6a3f9..a2e7ce6580e9822cc2df9ba7577828a54ca779af 100644 (file)
@@ -78,3 +78,22 @@ if with_gallium_st_nine
     subdir : 'd3dadapter',
   )
 endif
+
+# Only install the headers if we are building a stand alone implementation and
+# not an ICD enabled implementation
+if with_gallium_opencl and not with_opencl_icd
+  install_headers(
+    'CL/cl.h',
+    'CL/cl.hpp',
+    'CL/cl_d3d10.h',
+    'CL/cl_d3d11.h',
+    'CL/cl_dx9_media_sharing.h',
+    'CL/cl_egl.h',
+    'CL/cl_ext.h',
+    'CL/cl_gl.h',
+    'CL/cl_gl_ext.h',
+    'CL/cl_platform.h',
+    'CL/opencl.h',
+    subdir: 'CL'
+  )
+endif