drm-shim: Let the driver choose to overwrite the first render node.
[mesa.git] / include / meson.build
index d9b8df6ce52788600f8b81bff6951766a436858f..bddbd67d328ed760979e42a92d775084bce6d153 100644 (file)
@@ -22,44 +22,69 @@ inc_include = include_directories('.')
 inc_d3d9 = include_directories('D3D9')
 inc_haikugl = include_directories('HaikuGL')
 
-if with_gles1 or with_gles2 or with_opengl or with_egl
-  install_headers('KHR/khrplatform.h', subdir : 'KHR')
-endif
-
-if with_gles1
-  install_headers(
-    'GLES/egl.h', 'GLES/gl.h', 'GLES/glext.h', 'GLES/glplatform.h',
-    subdir : 'GLES',
-  )
-endif
-
-if with_gles2
-  install_headers(
-    'GLES2/gl2.h', 'GLES2/gl2ext.h', 'GLES2/gl2platform.h',
-    subdir : 'GLES2',
-  )
-  install_headers(
-    'GLES3/gl3.h', 'GLES3/gl31.h', 'GLES3/gl32.h', 'GLES3/gl3ext.h',
-    'GLES3/gl3platform.h',
-    subdir : 'GLES3',
-  )
-endif
-
-if with_opengl
-  install_headers(
-    'GL/gl.h', 'GL/glext.h', 'GL/glcorearb.h',
-    subdir : 'GL',
-  )
-endif
-
-if with_glx != 'disabled'
-  install_headers('GL/glx.h', 'GL/glxext.h', subdir : 'GL')
+if not with_glvnd
+  if with_gles1 or with_gles2 or with_opengl or with_egl
+    install_headers('KHR/khrplatform.h', subdir : 'KHR')
+  endif
+
+  if with_gles1
+    install_headers(
+      'GLES/egl.h',
+      'GLES/gl.h',
+      'GLES/glext.h',
+      'GLES/glplatform.h',
+      subdir : 'GLES',
+    )
+  endif
+
+  if with_gles2
+    install_headers(
+      'GLES2/gl2.h',
+      'GLES2/gl2ext.h',
+      'GLES2/gl2platform.h',
+      subdir : 'GLES2',
+    )
+    install_headers(
+      'GLES3/gl3.h',
+      'GLES3/gl31.h',
+      'GLES3/gl32.h',
+      'GLES3/gl3ext.h',
+      'GLES3/gl3platform.h',
+      subdir : 'GLES3',
+    )
+  endif
+
+  if with_opengl
+    install_headers(
+      'GL/gl.h',
+      'GL/glcorearb.h',
+      'GL/glext.h',
+      subdir : 'GL',
+    )
+  endif
+
+  if with_glx != 'disabled'
+    install_headers(
+      'GL/glx.h',
+      'GL/glxext.h',
+      subdir : 'GL')
+  endif
+
+  if with_egl
+    install_headers(
+      'EGL/egl.h',
+      'EGL/eglext.h',
+      'EGL/eglplatform.h',
+      subdir : 'EGL',
+    )
+  endif
 endif
 
+# Non-upstream headers
 if with_egl
   install_headers(
-    'EGL/eglext.h', 'EGL/egl.h', 'EGL/eglextchromium.h', 'EGL/eglmesaext.h',
-    'EGL/eglplatform.h',
+    'EGL/eglmesaext.h',
+    'EGL/eglextchromium.h',
     subdir : 'EGL',
   )
 endif
@@ -102,6 +127,7 @@ if with_gallium_opencl and not with_opencl_icd
     'CL/cl_ext_intel.h',
     'CL/cl_gl.h',
     'CL/cl_gl_ext.h',
+    'CL/cl_icd.h',
     'CL/cl_platform.h',
     'CL/cl_va_api_media_sharing_intel.h',
     'CL/cl_version.h',