meson: Add Haiku platform support v4
[mesa.git] / src / Makefile.am
index 01e9edfc4863a86edb4f71f3b9e42c263a3dd549..014ffaf3e29c8a0247729e8140503e6be35195b1 100644 (file)
 # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
 # IN THE SOFTWARE.
 
-.PHONY: git_sha1.h.tmp
-git_sha1.h.tmp:
-       @# Don't assume that $(top_srcdir)/.git is a directory. It may be
-       @# a gitlink file if $(top_srcdir) is a submodule checkout or a linked
-       @# worktree.
-       @# If we are building from a release tarball copy the bundled header.
-       @touch git_sha1.h.tmp
-       @if test -e $(top_srcdir)/.git; then \
-               if which git > /dev/null; then \
-                   git --git-dir=$(top_srcdir)/.git log -n 1 --oneline | \
-                       sed 's/^\([^ ]*\) .*/#define MESA_GIT_SHA1 "git-\1"/' \
-                       > git_sha1.h.tmp ; \
-               fi \
-       fi
-
-git_sha1.h: git_sha1.h.tmp
-       @echo "updating git_sha1.h"
-       @if ! cmp -s git_sha1.h.tmp git_sha1.h; then \
-               mv git_sha1.h.tmp git_sha1.h ;\
-       else \
-               rm git_sha1.h.tmp ;\
-       fi
+.PHONY: git_sha1.h
+git_sha1.h: $(top_srcdir)/src/git_sha1.h.in
+       @echo "updating $@"
+       @$(PYTHON2) $(top_srcdir)/bin/git_sha1_gen.py --output $@
 
 BUILT_SOURCES = git_sha1.h
 CLEANFILES = $(BUILT_SOURCES)
-EXTRA_DIST =
+EXTRA_DIST = git_sha1.h.in meson.build
 
 SUBDIRS = . gtest util mapi/glapi/gen mapi
 
@@ -75,7 +57,7 @@ endif
 # include only conditionally ?
 SUBDIRS += compiler
 
-## Optionally required by GBM, EGL and Vulkan
+## Optionally required by EGL
 if HAVE_PLATFORM_WAYLAND
 SUBDIRS += egl/wayland/wayland-drm
 endif
@@ -83,7 +65,9 @@ endif
 if HAVE_VULKAN_COMMON
 SUBDIRS += vulkan
 endif
+
 EXTRA_DIST += vulkan/registry/vk.xml
+EXTRA_DIST += vulkan/registry/vk_android_native_buffer.xml
 
 if HAVE_AMD_DRIVERS
 SUBDIRS += amd
@@ -93,6 +77,10 @@ if HAVE_INTEL_DRIVERS
 SUBDIRS += intel
 endif
 
+if HAVE_BROADCOM_DRIVERS
+SUBDIRS += broadcom
+endif
+
 if NEED_OPENGL_COMMON
 SUBDIRS += mesa
 endif
@@ -117,11 +105,6 @@ if HAVE_EGL
 SUBDIRS += egl
 endif
 
-## Requires the i965 compiler (part of mesa) and wayland-drm
-if HAVE_INTEL_VULKAN
-SUBDIRS += intel/vulkan
-endif
-
 # Requires wayland-drm
 if HAVE_RADEON_VULKAN
 SUBDIRS += amd/vulkan