vc4: Introduce XML-based packet header generation like Intel's.
[mesa.git] / src / Makefile.am
index 91d753aae34db4b85e6ac9f50dc4a35a102b49ff..36995e08a45c154c52daee3d59dd56523bb75608 100644 (file)
 
 .PHONY: git_sha1.h.tmp
 git_sha1.h.tmp:
-       @# Don't assume that $(top_srcdir)/.git is a directory. It may be
-       @# a gitlink file if $(top_srcdir) is a submodule checkout or a linked
-       @# worktree.
-       @# If we are building from a release tarball copy the bundled header.
-       @touch git_sha1.h.tmp
-       @if test -e $(top_srcdir)/.git; then \
-               if which git > /dev/null; then \
-                   git --git-dir=$(top_srcdir)/.git log -n 1 --oneline | \
-                       sed 's/^\([^ ]*\) .*/#define MESA_GIT_SHA1 "git-\1"/' \
-                       > git_sha1.h.tmp ; \
-               fi \
-       fi
+       @sh $(top_srcdir)/git_sha1_gen.sh > $@
 
 git_sha1.h: git_sha1.h.tmp
        @echo "updating git_sha1.h"
@@ -44,13 +33,48 @@ git_sha1.h: git_sha1.h.tmp
 
 BUILT_SOURCES = git_sha1.h
 CLEANFILES = $(BUILT_SOURCES)
+EXTRA_DIST =
 
 SUBDIRS = . gtest util mapi/glapi/gen mapi
 
+if HAVE_OPENGL
+gldir = $(includedir)/GL
+gl_HEADERS = \
+  $(top_srcdir)/include/GL/gl.h \
+  $(top_srcdir)/include/GL/glext.h \
+  $(top_srcdir)/include/GL/glcorearb.h \
+  $(top_srcdir)/include/GL/gl_mangle.h
+endif
+
+if HAVE_GLX
+glxdir = $(includedir)/GL
+glx_HEADERS = \
+  $(top_srcdir)/include/GL/glx.h \
+  $(top_srcdir)/include/GL/glxext.h \
+  $(top_srcdir)/include/GL/glx_mangle.h
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = mesa/gl.pc
+endif
+
+if HAVE_COMMON_OSMESA
+osmesadir = $(includedir)/GL
+osmesa_HEADERS = $(top_srcdir)/include/GL/osmesa.h
+endif
+
 # include only conditionally ?
 SUBDIRS += compiler
 
-if HAVE_GALLIUM_RADEON_COMMON
+## Optionally required by GBM, EGL and Vulkan
+if HAVE_PLATFORM_WAYLAND
+SUBDIRS += egl/wayland/wayland-drm
+endif
+
+if HAVE_VULKAN_COMMON
+SUBDIRS += vulkan
+endif
+EXTRA_DIST += vulkan/registry/vk.xml
+
+if HAVE_AMD_DRIVERS
 SUBDIRS += amd
 endif
 
@@ -58,6 +82,10 @@ if HAVE_INTEL_DRIVERS
 SUBDIRS += intel
 endif
 
+if HAVE_GALLIUM_VC4
+SUBDIRS += broadcom
+endif
+
 if NEED_OPENGL_COMMON
 SUBDIRS += mesa
 endif
@@ -68,11 +96,6 @@ if HAVE_DRI_GLX
 SUBDIRS += glx
 endif
 
-## Optionally required by GBM and EGL
-if HAVE_PLATFORM_WAYLAND
-SUBDIRS += egl/wayland/wayland-drm
-endif
-
 ## Optionally required by EGL (aka PLATFORM_GBM)
 if HAVE_GBM
 SUBDIRS += gbm
@@ -87,21 +110,18 @@ if HAVE_EGL
 SUBDIRS += egl
 endif
 
-if HAVE_INTEL_DRIVERS
-SUBDIRS += intel/tools
-endif
-
-## Requires the i965 compiler (part of mesa) and wayland-drm
-if HAVE_INTEL_VULKAN
-SUBDIRS += intel/vulkan
+# Requires wayland-drm
+if HAVE_RADEON_VULKAN
+SUBDIRS += amd/vulkan
 endif
 
 if HAVE_GALLIUM
 SUBDIRS += gallium
 endif
 
-EXTRA_DIST = \
-       getopt hgl SConscript
+EXTRA_DIST += \
+       getopt hgl SConscript \
+       $(top_srcdir)/include/GL/mesa_glinterop.h
 
 AM_CFLAGS = $(VISIBILITY_CFLAGS)
 AM_CXXFLAGS = $(VISIBILITY_CXXFLAGS)
@@ -110,6 +130,8 @@ AM_CPPFLAGS = \
        -I$(top_srcdir)/include/ \
        -I$(top_srcdir)/src/mapi/ \
        -I$(top_srcdir)/src/mesa/ \
+       -I$(top_srcdir)/src/gallium/include \
+       -I$(top_srcdir)/src/gallium/auxiliary \
        $(DEFINES)
 
 noinst_LTLIBRARIES = libglsl_util.la
@@ -117,6 +139,6 @@ noinst_LTLIBRARIES = libglsl_util.la
 libglsl_util_la_SOURCES = \
        mesa/main/extensions_table.c \
        mesa/main/imports.c \
-       mesa/program/prog_hash_table.c \
+       mesa/program/prog_parameter.c \
        mesa/program/symbol_table.c \
        mesa/program/dummy_errors.c