vc4: Introduce XML-based packet header generation like Intel's.
[mesa.git] / src / Makefile.am
index aa5f8aaf7d7f98b11affc486db041db2f9ba627f..36995e08a45c154c52daee3d59dd56523bb75608 100644 (file)
 
 .PHONY: git_sha1.h.tmp
 git_sha1.h.tmp:
-       @# Don't assume that $(top_srcdir)/.git is a directory. It may be
-       @# a gitlink file if $(top_srcdir) is a submodule checkout or a linked
-       @# worktree.
-       @# If we are building from a release tarball copy the bundled header.
-       @touch git_sha1.h.tmp
-       @if test -e $(top_srcdir)/.git; then \
-               if which git > /dev/null; then \
-                   git --git-dir=$(top_srcdir)/.git log -n 1 --oneline | \
-                       sed 's/^\([^ ]*\) .*/#define MESA_GIT_SHA1 "git-\1"/' \
-                       > git_sha1.h.tmp ; \
-               fi \
-       fi
+       @sh $(top_srcdir)/git_sha1_gen.sh > $@
 
 git_sha1.h: git_sha1.h.tmp
        @echo "updating git_sha1.h"
@@ -93,6 +82,10 @@ if HAVE_INTEL_DRIVERS
 SUBDIRS += intel
 endif
 
+if HAVE_GALLIUM_VC4
+SUBDIRS += broadcom
+endif
+
 if NEED_OPENGL_COMMON
 SUBDIRS += mesa
 endif