build systems: move git_sha1_gen.sh to bin/
[mesa.git] / src / Makefile.am
index cab68b72d6a5c0ea1e1584345ad39e5a68a0387c..5aee6b01417ab06f4ccf488573168adb12e1ea41 100644 (file)
 
 .PHONY: git_sha1.h.tmp
 git_sha1.h.tmp:
-       @# Don't assume that $(top_srcdir)/.git is a directory. It may be
-       @# a gitlink file if $(top_srcdir) is a submodule checkout or a linked
-       @# worktree.
-       @# If we are building from a release tarball copy the bundled header.
-       @touch git_sha1.h.tmp
-       @if test -e $(top_srcdir)/.git; then \
-               if which git > /dev/null; then \
-                   git --git-dir=$(top_srcdir)/.git log -n 1 --oneline | \
-                       sed 's/^\([^ ]*\) .*/#define MESA_GIT_SHA1 "git-\1"/' \
-                       > git_sha1.h.tmp ; \
-               fi \
-       fi
+       @sh $(top_srcdir)/bin/git_sha1_gen.sh > $@
 
 git_sha1.h: git_sha1.h.tmp
        @echo "updating git_sha1.h"
@@ -75,6 +64,11 @@ endif
 # include only conditionally ?
 SUBDIRS += compiler
 
+## Optionally required by GBM, EGL and Vulkan
+if HAVE_PLATFORM_WAYLAND
+SUBDIRS += egl/wayland/wayland-drm
+endif
+
 if HAVE_VULKAN_COMMON
 SUBDIRS += vulkan
 endif
@@ -88,6 +82,10 @@ if HAVE_INTEL_DRIVERS
 SUBDIRS += intel
 endif
 
+if HAVE_GALLIUM_VC4
+SUBDIRS += broadcom
+endif
+
 if NEED_OPENGL_COMMON
 SUBDIRS += mesa
 endif
@@ -98,11 +96,6 @@ if HAVE_DRI_GLX
 SUBDIRS += glx
 endif
 
-## Optionally required by GBM and EGL
-if HAVE_PLATFORM_WAYLAND
-SUBDIRS += egl/wayland/wayland-drm
-endif
-
 ## Optionally required by EGL (aka PLATFORM_GBM)
 if HAVE_GBM
 SUBDIRS += gbm
@@ -117,15 +110,6 @@ if HAVE_EGL
 SUBDIRS += egl
 endif
 
-if HAVE_INTEL_DRIVERS
-SUBDIRS += intel/tools
-endif
-
-## Requires the i965 compiler (part of mesa) and wayland-drm
-if HAVE_INTEL_VULKAN
-SUBDIRS += intel/vulkan
-endif
-
 # Requires wayland-drm
 if HAVE_RADEON_VULKAN
 SUBDIRS += amd/vulkan