gbm: implement FD import with modifier
[mesa.git] / src / Makefile.am
index 630409c822b46486e62111cac5590032efbf6960..aa5f8aaf7d7f98b11affc486db041db2f9ba627f 100644 (file)
@@ -44,6 +44,7 @@ git_sha1.h: git_sha1.h.tmp
 
 BUILT_SOURCES = git_sha1.h
 CLEANFILES = $(BUILT_SOURCES)
+EXTRA_DIST =
 
 SUBDIRS = . gtest util mapi/glapi/gen mapi
 
@@ -74,12 +75,18 @@ endif
 # include only conditionally ?
 SUBDIRS += compiler
 
-if HAVE_AMD_DRIVERS
-SUBDIRS += amd
+## Optionally required by GBM, EGL and Vulkan
+if HAVE_PLATFORM_WAYLAND
+SUBDIRS += egl/wayland/wayland-drm
 endif
 
-if NEED_RADEON_LLVM
-SUBDIRS += amd/common
+if HAVE_VULKAN_COMMON
+SUBDIRS += vulkan
+endif
+EXTRA_DIST += vulkan/registry/vk.xml
+
+if HAVE_AMD_DRIVERS
+SUBDIRS += amd
 endif
 
 if HAVE_INTEL_DRIVERS
@@ -96,11 +103,6 @@ if HAVE_DRI_GLX
 SUBDIRS += glx
 endif
 
-## Optionally required by GBM and EGL
-if HAVE_PLATFORM_WAYLAND
-SUBDIRS += egl/wayland/wayland-drm
-endif
-
 ## Optionally required by EGL (aka PLATFORM_GBM)
 if HAVE_GBM
 SUBDIRS += gbm
@@ -115,19 +117,6 @@ if HAVE_EGL
 SUBDIRS += egl
 endif
 
-if HAVE_INTEL_DRIVERS
-SUBDIRS += intel/tools
-endif
-
-if HAVE_VULKAN_COMMON
-SUBDIRS += vulkan/wsi
-endif
-
-## Requires the i965 compiler (part of mesa) and wayland-drm
-if HAVE_INTEL_VULKAN
-SUBDIRS += intel/vulkan
-endif
-
 # Requires wayland-drm
 if HAVE_RADEON_VULKAN
 SUBDIRS += amd/vulkan
@@ -137,7 +126,7 @@ if HAVE_GALLIUM
 SUBDIRS += gallium
 endif
 
-EXTRA_DIST = \
+EXTRA_DIST += \
        getopt hgl SConscript \
        $(top_srcdir)/include/GL/mesa_glinterop.h