Merge remote-tracking branch 'mesa-public/master' into vulkan
[mesa.git] / src / Makefile.am
index 3e736d02934489e45a94c4065dccbdcc84196a2e..da638a811fbd2eec25c1814257071b3300b04730 100644 (file)
@@ -19,7 +19,7 @@
 # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
 # IN THE SOFTWARE.
 
-SUBDIRS = gtest util mapi
+SUBDIRS = . gtest util mapi/glapi/gen mapi
 
 if NEED_OPENGL_COMMON
 SUBDIRS += glsl mesa
@@ -32,11 +32,7 @@ SUBDIRS += glx
 endif
 
 if HAVE_EGL_PLATFORM_WAYLAND
-SUBDIRS += egl/wayland
-endif
-
-if HAVE_EGL_DRIVER_DRI2
-SUBDIRS += egl/drivers/dri2
+SUBDIRS += egl/wayland/wayland-egl egl/wayland/wayland-drm
 endif
 
 if HAVE_GBM
@@ -44,11 +40,33 @@ SUBDIRS += gbm
 endif
 
 if HAVE_EGL
-SUBDIRS += egl/main
+SUBDIRS += egl
 endif
 
 if HAVE_GALLIUM
 SUBDIRS += gallium
 endif
 
-EXTRA_DIST = getopt
+EXTRA_DIST = \
+       getopt hgl SConscript
+
+AM_CFLAGS = $(VISIBILITY_CFLAGS)
+AM_CXXFLAGS = $(VISIBILITY_CXXFLAGS)
+
+if HAVE_VULKAN
+SUBDIRS += vulkan
+endif
+
+AM_CPPFLAGS = \
+       -I$(top_srcdir)/include/ \
+       -I$(top_srcdir)/src/mapi/ \
+       -I$(top_srcdir)/src/mesa/ \
+       $(DEFINES)
+
+noinst_LTLIBRARIES = libglsl_util.la
+
+libglsl_util_la_SOURCES = \
+       mesa/main/imports.c \
+       mesa/program/prog_hash_table.c \
+       mesa/program/symbol_table.c \
+       mesa/program/dummy_errors.c