meson: use gnu_symbol_visibility argument
[mesa.git] / src / amd / common / meson.build
index 2804255697f12c10109549a46b8f566ef5b0f296..739428baec0ad3d5d5d1e4cca730abaf73e0039a 100644 (file)
@@ -20,7 +20,8 @@
 
 sid_tables_h = custom_target(
   'sid_tables_h',
-  input : ['sid_tables.py', 'sid.h', '../registers/amdgfxregs.json', '../registers/pkt3.json'],
+  input : ['sid_tables.py', 'sid.h', '../registers/amdgfxregs.json', '../registers/pkt3.json',
+           '../registers/gfx10.json', '../registers/gfx10-rsrc.json'],
   output : 'sid_tables.h',
   command : [prog_python, '@INPUT@'],
   capture : true,
@@ -28,7 +29,8 @@ sid_tables_h = custom_target(
 
 amdgfxregs_h = custom_target(
   'amdgfxregs_h',
-  input : ['../registers/makeregheader.py', '../registers/amdgfxregs.json', '../registers/pkt3.json'],
+  input : ['../registers/makeregheader.py', '../registers/amdgfxregs.json', '../registers/pkt3.json',
+           '../registers/gfx10.json', '../registers/gfx10-rsrc.json'],
   output : 'amdgfxregs.h',
   command : [prog_python, '@INPUT@', '--sort', 'address', '--guard', 'AMDGFXREGS_H'],
   capture : true,
@@ -38,18 +40,10 @@ amd_common_files = files(
   'ac_binary.c',
   'ac_binary.h',
   'ac_exp_param.h',
-  'ac_llvm_build.c',
-  'ac_llvm_build.h',
-  'ac_llvm_cull.c',
-  'ac_llvm_cull.h',
-  'ac_llvm_helper.cpp',
-  'ac_llvm_util.c',
-  'ac_llvm_util.h',
-  'ac_shader_abi.h',
+  'ac_shader_args.c',
+  'ac_shader_args.h',
   'ac_shader_util.c',
   'ac_shader_util.h',
-  'ac_nir_to_llvm.c',
-  'ac_nir_to_llvm.h',
   'ac_gpu_info.c',
   'ac_gpu_info.h',
   'ac_rtld.c',
@@ -64,14 +58,13 @@ libamd_common = static_library(
   'amd_common',
   [amd_common_files, sid_tables_h, amdgfxregs_h],
   include_directories : [
-    inc_common, inc_compiler, inc_mesa, inc_mapi, inc_amd,
+    inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux, inc_compiler, inc_mapi, inc_amd,
   ],
   dependencies : [
-    dep_llvm, dep_thread, dep_elf, dep_libdrm_amdgpu, dep_valgrind,
+    dep_thread, dep_elf, dep_libdrm_amdgpu, dep_valgrind,
     idep_nir_headers,
   ],
-  c_args : [c_vis_args],
-  cpp_args : [cpp_vis_args],
+  gnu_symbol_visibility : 'hidden',
 )
 
 idep_amdgfxregs_h = declare_dependency(sources : [amdgfxregs_h])