amd/common/gfx10: add register JSON
[mesa.git] / src / amd / common / meson.build
index 0967b1adb76d009741e3739917155ee176b81ab0..d5d70ad66db0fea4c237e43baca09f255ab37058 100644 (file)
 
 sid_tables_h = custom_target(
   'sid_tables_h',
-  input : ['sid_tables.py', 'sid.h', 'gfx9d.h'],
+  input : ['sid_tables.py', 'sid.h', '../registers/amdgfxregs.json', '../registers/pkt3.json',
+           '../registers/gfx10.json', '../registers/gfx10-rsrc.json'],
   output : 'sid_tables.h',
-  command : [prog_python2, '@INPUT@'],
+  command : [prog_python, '@INPUT@'],
+  capture : true,
+)
+
+amdgfxregs_h = custom_target(
+  'amdgfxregs_h',
+  input : ['../registers/makeregheader.py', '../registers/amdgfxregs.json', '../registers/pkt3.json',
+           '../registers/gfx10.json', '../registers/gfx10-rsrc.json'],
+  output : 'amdgfxregs.h',
+  command : [prog_python, '@INPUT@', '--sort', 'address', '--guard', 'AMDGFXREGS_H'],
   capture : true,
 )
 
@@ -32,6 +42,8 @@ amd_common_files = files(
   'ac_exp_param.h',
   'ac_llvm_build.c',
   'ac_llvm_build.h',
+  'ac_llvm_cull.c',
+  'ac_llvm_cull.h',
   'ac_llvm_helper.cpp',
   'ac_llvm_util.c',
   'ac_llvm_util.h',
@@ -42,6 +54,8 @@ amd_common_files = files(
   'ac_nir_to_llvm.h',
   'ac_gpu_info.c',
   'ac_gpu_info.h',
+  'ac_rtld.c',
+  'ac_rtld.h',
   'ac_surface.c',
   'ac_surface.h',
   'ac_debug.c',
@@ -50,7 +64,7 @@ amd_common_files = files(
 
 libamd_common = static_library(
   'amd_common',
-  [amd_common_files, sid_tables_h],
+  [amd_common_files, sid_tables_h, amdgfxregs_h],
   include_directories : [
     inc_common, inc_compiler, inc_mesa, inc_mapi, inc_amd,
   ],
@@ -61,3 +75,5 @@ libamd_common = static_library(
   c_args : [c_vis_args],
   cpp_args : [cpp_vis_args],
 )
+
+idep_amdgfxregs_h = declare_dependency(sources : [amdgfxregs_h])